1 Reply Latest reply: Nov 20, 2011 3:18 PM by ruggersf
ruggersf Level 1 (0 points)

I am using Aperture 3.2.1.  The library in question only has 612 photos.


When I have no fliters selected and I choose Photos in the Inspector panel in Browser view. I SELECT ALL photos. All of my photos show up.

If I then click on the Places in the Inspector panel, all locations and pins show up. All of my photos are accessible.

(The headline on the top of the screen for the places view shows 2 countries, 4 states, etc... correctly.)


However, if I then select Photos in the Inspector Panel. Again SELECT ALL Photos. All of my photos show up.

If I then click on the Places View in the upper right, a map shows up with the proper area of the map in zoom view, but no pins. The headline is still correct.

If I click on the headline to refine it to one place, the map jumps in close to one of the countries. Then I can hit the home button and all of the pins appear.  I can zoom out and all seems fine.


Then I click the browser view, and immediate switch back to the places view and again.. all the pins disappear.  I have tried repairing/rebuilding the database to no effect.

iMac, Mac OS X (10.7.2)
  • ruggersf Level 1 (0 points)

    ps. This happens only in this one library, gps information and pins show up properly in the metadata location view for each picture, pins show up properly when I go to the project inspector and click on the information button.  I have also tried exporting this project as a new library and conversly creating a new project and importing it. Neither remedies the situtation. I do not want to export all the pictures out of Aperture and then reimport them as I will lose all of my face information. Plus I would like to know what the problem is so I do not run into this situation again.