5 Replies Latest reply: Mar 22, 2012 7:02 AM by Rock Dr
greg_m59 Level 1 Level 1 (0 points)

I have an iPad 2, recently upgraded to ios 5.  I have an AirPrint compatible printer (HP Officejet 8500A).  Prior to upgrading to ios 5, I was able to print from my iPad without problem.  After upgrading, when I try to print, the printer is included on my list, but when I hit print I receive the error message "printer no longer available".  How do I fix this?

  • 1. Re: Can't print from iPad?
    Demo Level 9 Level 9 (76,410 points)

    You might want to check with HP and see if there is a firmware update that will allow the printer to work with iOS 5.

     

    You can also restart the printer and your iPad and see if that helps.

     

    Restart the iPad by holding down onthe sleep button until the red slider appears and then slide to shut off. Topower up hold the sleep button until the Apple logo appears and let go of thebutton.

  • 2. Re: Can't print from iPad?
    Tgara Level 4 Level 4 (3,540 points)

    I had a similar problem with my Airprint printer after upgrading to iOS 5.  A restart of the printer, as Demo suggested, resolved the problem for me.

  • 3. Re: Can't print from iPad?
    greg_m59 Level 1 Level 1 (0 points)

    Thanks.  I will give it a try this evening.

  • 4. Re: Can't print from iPad?
    greg_m59 Level 1 Level 1 (0 points)

    Thanks again.  Turning the iPad and the printer off and back on worked!  And here I was thinking that the old "reboot" solution only worked on Windows machines (guess I figured Apple was beyond the turn off and on fix).  Appreciate the help.

  • 5. Re: Can't print from iPad?
    Rock Dr Level 1 Level 1 (0 points)

    Incredible - but turning it on and off again solved my printing problem, which was the same as the OP.

     

    Thanks!