Previous 1 2 3 Next 31 Replies Latest reply: Jul 27, 2015 8:58 AM by Mac Rock
laulau_kc Level 1 Level 1 (0 points)

Hi

 

I am having this right click problem with my magic mouse.  The right click function just suddenly stopped working two days ago.

 

I have checked the Mouse>Preference> Secondary click is enabled to "Right"

 

However, when I changed the secondary click to "Left", the "right click" function works perfectly fine w/ the left click, but when I change it back to "Right" nothing happens.  I even tried unchecking the secondary click function (someone said that will work in another support site) but that doesn't help either.

 

I have tried removing batteries from my mouse, turning it off, turning bluetooth off, restarting the laptop...

 

 

Very confused right now.  Please help!!


Magic Mouse, Mac OS X (10.7.2)
  • jamesfromlos molinos Level 1 Level 1 (20 points)

    Hav you checked the function box? Common mistake.

  • laulau_kc Level 1 Level 1 (0 points)

    Yes.... I have tried checking and unchecking it and restarting the computer...

     

    It just works only when I change the secondary click to 'left' or pressing the 'control' button while I click.

     

    Right click was working fine until two days ago I have no idea if I did anything that might've changed it or if the mouse itself is having problems.

     

     

    Thanks for your reply though. =)

  • PvT Level 1 Level 1 (5 points)

    The post is a month old now, but I did stumble upon it after I suddenly lost my "Magic Mouse" right click functionality.  Just as posted my; Mouse>Preference> Secondary click was enabled to "Right", though it would not work...

     

    I tried everything including; restart iMac, enable and disable "Secondary Click", disconnecting the Mouse bluetooth and reconnecting it using my Magic Trackpad, etc.... until this ended up being my solution:

     

    I went into System Preferences, Mouse>Preference> and disabled "Secondary click".  Then restarted the system.  Then returned to System Preferences, Mouse>Preference> and re-enabled Secondary Click.  That worked and was my solution and has been working fine since yesterday.

     

    I hope this helps anyone who encounters the same as we have.

  • Andy Drefs Level 1 Level 1 (5 points)

    Just exactly what the heck is going on at Apple?  This Magic Mouse is a piece of expensive junk as far as I'm concerned; it is VERY often jittery and slow, my right-click has now ceased operation (again) and when I go to reset it in the Mouse window I see that the Magic Mouse is paired but disconnected and something called "Demo's mouse" IS connected?  *** is "Demo's mouse"?  All of this on top of myriad Final Cut Pro X and Compressor 4 issues, not to mention all the bugs with iCloud, leaves me in a very frustrated and angry position towards the once loved Apple Corp.

  • Jorlewiesen Level 1 Level 1 (0 points)

    Have had a similar issue, except with me the left click stop working first followed promptly by the right click.  Strangly i can still open icons in the dock. If i have a webpage open the clicks turn into the "fast page scroll" thing and if i click tabs they are closed.

    This started happening to my original mouse a few months back so i replaced it with another mighty mouse worked fine for a day then same issues occured. Any help would be hugely appreciated.

     

    both mice are bluetooth and im running snow leaopard on 10.6.8

    thanks

  • OldManLink Level 1 Level 1 (0 points)

    Yes, it's very frustrating, but I have a workaround that works most of the time.

     

    When the RMB stops working, use the "screen zoom" function (ctrl + mouse scroll ball) to zoom in to the screen a bit, then zoom out again. This usually makes the RMB start working again, at least for a while. If it doesn't help, then rebooting the computer usually does.

     

    Still looking for a more permanent solution though.

  • wolfbyte Level 1 Level 1 (0 points)

    Another thing to try, which I dont see mentioned. Turn the mouse itself off, then on again. That worked for me. Seems like it "restarts" the mouse or its application.

     

    This original problem, however, states that the "right click function" works if he changes the function to left click. That suggests the possiblity of a mechanical problem if these other solutions don't work.

     

    Also, how old if the mouse, and the computer? Mice are not "forever". And if the computer is over four years old there is even a chance that the Pram battery needs to be replaced. (I've never had that happen but it's discussed elsewhere)

  • MightyMark Level 1 Level 1 (0 points)

    Have Dsame problem.. mine is when you use right click as left click the mouse works, but if you change it back, right click is just left click, its not working. just like wolfbyte said. BUT!... i think its not a mechanical problem, because i downloaded an app called " magicPrefs". it fixed the problem... right click works again for me. i was using OSX lion 10.7.. so try that guys.. apple should fix this problem, maybe reconfigure the mouse?, or i dont know. anyway.. just helping

  • MightyMark Level 1 Level 1 (0 points)

    on magicprefs.. go to tap, check "the one finger tap right*" and that should do it. hope this help. it works for me. im running OS X 10.8.2.

  • skywaym4n Level 1 Level 1 (0 points)

    After reading all of this I simply turned the mouse on and off to reboot it.... Works perfectly now

     

    Well done Wolfbyte, sometimes the simplest problems are over looked with our need to over complicate it.

     

    Should have known it would be an easy fix being the ever brilliant apple

     

    Thanks Wolfbyte

     

    I hope this will help others

     

    By the way mine happened after I did an update!!!!

  • DavidNY63 Level 1 Level 1 (0 points)

    Turning mouse on and off worked for me

  • OldManLink Level 1 Level 1 (0 points)

    Well, after the latest update of Lion (10.7.5) the right mouse button started working again, so I guess it was just one of the bug fixes in that release. Case closed for me personally.

  • Waltjg Level 1 Level 1 (0 points)

    Well here we are a year later and STILL the same problem!!!! what is going on? running Maveric now, and still trouble with the right button on the mouse, after clicking it repedially for about a minute it works. What is going on, New Imac, thought I was buying quality!!!!!! w.

  • DougPod Level 1 Level 1 (25 points)

    In case you're still struggling with this - after calling Apple support and gettting the suggestion to take the Magic Mouse into an Apple store to see if the right-click works there, I decided instead to re-install the OS.  After doing so, it worked just fine.  So it's definitely an OS problem.

Previous 1 2 3 Next