8 Replies Latest reply: Nov 21, 2011 5:48 PM by burn4me
burn4me Level 1 Level 1 (0 points)

OS X 10.6.8 - None of my usb flash drives are mounting. They don't show up in disk utility either.  System proflier does show the flash drives.  I've run disk warrior and the flash drives show there as well.  I've tried all of the usb outlets with several flash drives and none of them show up.  I can use the same usb outlets to use my wireless keyboard, mouse and also my ipad.

 

Finders preferences are all checked to show items on desktop.

 

One of my flash drives I tried several times and finally got this screen message. "System extension cannot be used  The system extension "/System/Library/Extension/IOStorageFamily.Kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update.   Non of my other 6 flash drives mount and they do not receive any screen message. 

 

I've also run repair disk permissions several times and the it says permissions repaired so I run it again and the same issued it said it was repaired, it lists again. I've done this several times with the same results.


iMac, Mac OS X (10.6.8)