10 Replies Latest reply: Feb 24, 2014 2:38 PM by askJonathan
supraru Level 1 Level 1 (0 points)

I posted this in multiple forums in which it applies to.


Just looking for troubleshooting suggestions from my wireless N MBPro, to my wired ATV2. Here is the rundown (all devices running latest updates):


1)used to work just fine with old router

2)airplay works in all directions, from wireless devises to the wired ATV2

3)updated to a much newer N router from cisco

4)now, airplay works over Ethernet from itunes to ATV2 (and iphone4s to ATV2), ATV2 plays music from my MBPro just fine

5) however airplay fails to work from itunes to ATV2 over wirelesss

6)all wireless connections are sound, it is not a bandwidth problem, it literally says "connecting to apple tv" and never stops or connects

7)itunes sees the ATV2 just fine over both Ethernet and wireless connections, i can select ATV2 as an output even when on wireless

8)it will even ask for the password once i select it


So, any suggestions? I just dont know where I am going wrong, somehow the wireless aspect is the broken link. As a side note, all wireless clients and wired clients are on the same subnet.


Thanks for any suggestions or help!

MacBook Pro, Mac OS X (10.7.2)
  • Winston Churchill Level 10 Level 10 (88,715 points)
    • Check that your wired and wireless networks are the same network and you get the same IP addresses from both.
    • Check that your new router isn't transmitting on a channel that is used by other networks in your area.
  • supraru Level 1 Level 1 (0 points)

    Thanks for the response! Yeah, wired and wireless are on the same subnet, but the channel troubleshooting recommendation is a good one. I will verify. 


    Guess the only question I have now is if the wireless were broadcasting on a channel being used by something else, would the ATV2 still be able to be seen by itunes as an airplay option? I'll check it out either way.

  • YesMan78 Level 1 Level 1 (0 points)

    I got a similar issue.


    Itunes on windows 7

    2x Airport Expresses v7.6 connecting to WLAN in straight client mode


    My iphones and ipad can all connect to the airport express airplay, works fine.  But itunes basically never sees them.  I think if I reboot everything including router then they come up, but when I restart my computer they disappear out of itunes again.


    I have no fierwalls or network restirctions internally.  win7 firewall is off.


    I have tried resetting airport express to factory and re confinguring.  no change.


    I can't be sure but it seems to have dropped off sicne the update to itunes 10.  rather than the last airport express update.

  • Alley_Cat Level 6 Level 6 (18,680 points)

    Presumably the ethernet cable is unplugged? It disables wi-fi when connected.


    I would recommend restarting all devices including computer and router if you've not already tried this.



  • YesMan78 Level 1 Level 1 (0 points)

    Thanks.  Ethernet is unplugged.  Restarting temporarily fixes until the computer is restarted, as I mentioned.

  • Alley_Cat Level 6 Level 6 (18,680 points)

    Sorry, reply was directed to supraru.  I had read your post and interestingly noted that restarting helped.


    When they disappear from itunes does Airport Utility (if Windows has one) still see the Expresses?


    These issues are always tricky to pin down - may be related to software/software bug, unlikely to be security software as you say firewall is off and they would probably just never appear if something was port blocking.


    Is computer sleeping and maybe getting a different IP address when it wakes for some reason?


    Anything that could be interfering with the wi-fi like microwave, cordless landline phones?


    In my experience AppleTVs have always been poor at re-establishing iTunes connections once it has dropped for some reason - almost like a bug whereby if itunes fais to see an AppleTV (or perhaps an Express) that it has connected to, that it never subsequently rechecks the connection is available again until a restart.


    If itused to work and nothing has changed apart from the iTunes version it's quite a coincidence.



  • supraru Level 1 Level 1 (0 points)

    Hwey Alley Cat, thanks for the tips. The channel interference was a great suggestion but unfortunately it was not hte source.


    I traced the problem to what I believe was a setting on my router (Cisco 4200N).  There is some BS setting for:


    WMM Support

    Wi-Fi Multimedia (WMM) is a wireless Quality of Service feature that improves quality for audio, video, and voice applications by prioritizing wireless traffic.


    I disabled this and so far things have been working 100%. I will update if things change. Its only been working for a slid day so far. But before I changed this setting, I couldn't even get it to work after establishing a WIRED connection first.  So this is very promising.


    I hope anyone having this problem with a 4200N router comes across this thread and I save them some time.

  • Kaylee Frye Level 1 Level 1 (10 points)

    Thanks supraru, that was my exact problem.  I turned off WMM Support and restarted the ATV2 and my macbook's networking and it fixed it.

  • supraru Level 1 Level 1 (0 points)

    No problem.  Glad to help.

  • askJonathan Level 1 Level 1 (0 points)

    I was having similar issues with not being able to use AirPlay over my wireless network. It was working only when connected to my Ethernet. All hardware devices were configured to access the same network. THANK YOU to all of you who posted on this discussion because it helped me figure out that it was an issue with a setting on my Linksys E1000 router.


    If you have a router similar to mine then log into the administration set up area. This is usually defaulted to having to direct connect via Ethernet (I recommend leaving it this way.) Under Wireless/Advanced Wireless Settings, make sure that AP Isolation is set to "Disabled." For some reason mine was set otherwise even though disabled is the default. This immediately fixed the problem and iTunes recognized the hardware (Airport Express & AppleTV) to broadcast to via AirPlay.


    Couple tips I found to be useful:

    • Wireless Channel Width should be 20MHz only. I tried setting it to Auto (20MHz or 40MHz) but it caused everything to just stop and the Internet didn't even want to connect. Not sure why but I just figured that if 20MHz was good for all then it was good for me.
    • AppleTV has a hard time communicating with a non-Apple router via Wireless-N. When I disabled Wireless B/G on my router I could no longer see my Apple TV. This was under the N Transmission Rate drop down menu in Advanced Wireless Settings.
    • In the same Advanced Wireless Settings module, make sure to leave Basic Rate to "default", for some reason the network get's confused and pauses when you have it on anything else. This get's annoying when listening to music or watching a video.
    • When you are working on your router and changing settings or going from page to page, expect your device connectivity to be choppy. I don't know why this happens but would guess that maybe the router is taking a second to see if any changes were applied to notify the user before switching to the next page.
    • My WMM Support is still enabled and all devices are working just fine.
    • Under QoS (Quality of Service) in my router, I went ahead and Internet Access Priority to see if giving iTunes a High priority would allow me less lag time. I added both Quicktime and Skype to the Summary list of Categories to prioritize. We'll see if this helps since I'm messing with it as I write this.
    • Last but not least, I have 50MB of download via my Internet cable service provider. Figured people should know this so that we can rule out speed.


    I sincerely hope this helps some of you out and again thank you for leading me to the right solution. Cheers!