Skip navigation

No sound coming from my iPhone 4s.

578336 Views 219 Replies Latest reply: Apr 2, 2014 4:36 PM by koreabella80 RSS Branched to a new discussion.
  • jbrijpaul Calculating status...
    Currently Being Moderated
    Feb 20, 2013 5:14 PM (in response to Hattie389)

    I tried playing with the setting of the sound option, turning off the phone turning it back on, playing music through the headphone and unplugging it and nothing worked. Finally I tried this and oddly enough this simple step worked. While the phone was unlocked I pressed the home button twice (which brought up all of my running apps), I  scrolled left twice until the volume bar showed up. I then tried to move it (which is didn't) and in frustration locked my phone to try the next fix and finally heard that lock click. Not sure why this works but it helped fix the sound issue on my white iphone 4s. THANKS!

  • Ladyjan Calculating status...
    Currently Being Moderated
    Feb 21, 2013 2:49 AM (in response to szayat)

    Same thing happened to me today. Only ringtone sound on speakers, could hear everything with headphones in. Tried all the blowing, cleaning and re-setting tips. I finally plugged headphones in, listened to a half a song and Hey Presto! it worked again......

     

    Hope this helps.....

  • scf_foto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 21, 2013 8:03 PM (in response to szayat)

    I too had tried all the "fixes" posted in this forum. Some worked for maybe a day but then I would lose sound again. Finally got fed up and jailbroke my phone, followed the videos posted on YouTube under the same topic, and all sound has been restored.

    Clearly a software issue that Apple doesn't want to fix so we all buy new phones. Bleh

  • Dellaone Calculating status...
    Currently Being Moderated
    Feb 24, 2013 3:39 AM (in response to Steven Krause)

    6 days after resetting my iPhone 4S, I still have sound, but with absolutely no apps intalled. I am slowly reinstalling apps from the cloud to see which one sems to trip it up.

  • JasminM Calculating status...
    Currently Being Moderated
    Feb 25, 2013 12:17 AM (in response to szayat)

    I tried everything posted before and didn't work for me. Then I was curious to see if sound trought my Apple TV would work. Than I figured that when you click the apple TV icon to send music there is 3 options: Apple TV, Home and Dock connector. I think sound doesn't work cause in a way the sound to Dock is activited. As this menu cannot show up when you dont have an apple TV most people can't make the change. So I first push the sound to my Apple TV than swicht it back to Home and than everything is back to normal. 

  • Ajetsprt Calculating status...
    Currently Being Moderated
    Feb 28, 2013 11:38 AM (in response to JasminM)

    Same problem no sound after i did the 6.1.2 upgrade

     

    When I go into the ipod I had a selection fo "iPhone" and one for my "Airport Express" after I did the upgrade I have options for "Airport Express" and "Dock Connector"

     

    I just tried changing my option to "Airport Express" and all the sounds on the phone work now EXCEPT the iPod. If I switch back to "Dock Connector" I get no sound at all.

     

    There is no longer an option for "iPhone"

     

    Any ideas??

  • Ajetsprt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 28, 2013 11:39 AM (in response to Ajetsprt)

    Is there a way to roll back to the old version??

  • danilo.goncalves Calculating status...
    Currently Being Moderated
    Mar 1, 2013 10:49 AM (in response to szayat)

    Hi there!

    I had the same problem, from the tip given here, I solved my problem!

    Simply I cleaned the dock (Connector) of the my iphone with a pin, and I noticed that it had a lot of dirt, I cleaned the connector (30-pin), blew, and magically, the volume control is working again.

    Thanks you so much!

  • v.agarwal Calculating status...
    Currently Being Moderated
    Mar 2, 2013 9:28 AM (in response to Steven Krause)

    Guys, lets tweet about this to Apple and related people.. hopefully, if there's enough noise, someone will listen. 

     

    #iPhoneDeadSpeaker

     

    @pschiller

    @waltmossberg

    @cultcast

    @erfon

    @TUAW

    @Macworld

    @ABCNews

    @verge

    @AppStore

    @iTunes

    @algore

    @wsj

    @cue

  • jessecafromkeithville Calculating status...
    Currently Being Moderated
    Mar 3, 2013 1:21 PM (in response to szayat)

    I have been battling this issue for a couple weeks now. I haven't done the last 2 updates though. My solution was I took a toothbrush and dipped it in alcohol, dried most of it off, then used it to clean the 30 pin dock/charger port really good. I then sprayed it out real good with compressed air. Voila it's working again!

  • CookieLove333 Calculating status...
    Currently Being Moderated
    Mar 7, 2013 4:36 PM (in response to szayat)

    Mine too. But mine will play sound then just randomly cut off. I do t know what's going on with it.

  • brexx Calculating status...
    Currently Being Moderated
    Mar 9, 2013 5:17 AM (in response to szayat)

    Driving me nuts.. 3rd time in 2 weeks, now nothing seems to solve the problem.. Tried cleaning, blowing, toggling.. Nada.

  • Caramel Wafer Calculating status...
    Currently Being Moderated
    Mar 9, 2013 11:12 PM (in response to szayat)

    I had the same problem with my 4s since the last update,intermittent sound(mainly no sound),no bars on the ringer logo,no clicks when typing messages etc,it was driving me crazy.I tried cleaning the dock and headphone socket with a tooth brush but nothing helped.

     

    I made an appointment with the Genius bar,told him that this problem just appeared since the last update.The guy told me it was a dock problem.The morning i visited Apple shop the sound was fine,after being off all the previous days,typical! Basically the phone thinks it's in a docking station(docking speaker etc).He claimed it was dust on the connectors and cleaned it with a brush,although he admitted mine's was spotless! If the problem persisted i was to try a full reset or return and the option was a replacement phone at £140 as my phone is now 14 months old.

     

    The problem re-appeared within hours of leaving the Genius Bar.I went home backed up iphone to pc and did a full reset,nothing changed.

    I searched the internet and found this thread and many others and decided i was going to try and replace the dock connector myself.

     

    I ordered the part from ebay,many sell the part for as little as £6 upwards,i ordered mine from a seller who claimed it was a genuine Apple part for £10.I also bought the screwdrivers to open the phone,they cost just £2.

    I followed a guide showing you a step by step guide of how to replace the dock and mic(they are connected) and the upshot is my phone is now working perfectly again.I'm glad all my sounds,clicks and beeps have returned!

    It took me just over 1 hour to do it,a steady hand and patience.

    It is definately a hardware problem!

  • dombpool Calculating status...
    Currently Being Moderated
    Mar 10, 2013 1:00 PM (in response to brexx)

    try going to settings then general then into accessibility scroll down to assistive touch turn it on click the black box with circle in it then press the device icon and it the bell so it says mute the bell should have a line through it this worked for me

  • dombpool Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2013 1:30 PM (in response to brexx)

    go to settings scroll down to general then to accessibility scroll to assistive touchturn on a black n white button appears click the button four icons appear click the device one click the bell icon to the opposite of what it was on then come out of it by turning offassistive touch and hopefully this will do it it did for me .............my icon on the bell now has a line running through it try it

1 ... 8 9 10 11 12 ... 15 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.