Previous 1 4 5 6 7 8 Next 238 Replies Latest reply: Jan 24, 2015 5:23 AM by Ati Zar Go to original post Branched to a new discussion.
  • 4gbpack Level 1 Level 1 (0 points)

    Thanks for all of the great suggestions...I have the Iphone4 (not S), and recently stopped having keyboard clicks and couldn't see the sound level with the side buttons...tried everything, except blowing into the dock connector port!  That did it!  Thanks for the good advice...You rock!

  • 4gbpack Level 1 Level 1 (0 points)

    Thanks for all of the great suggestions...I have the Iphone4 (not S), and recently stopped having keyboard clicks and couldn't see the sound level with the side buttons...tried everything, except blowing into the dock connector port!  That did it!  Thanks for the good advice...You rock!

  • tridarsa Level 1 Level 1 (0 points)

    I think there is a Headphone glitch (bug) in the Os. for me I have to go to Soung settings, and try to change the Ringtone sound in the Settings (until you heard any sounds), then I closed the setting.. everything will be fine..until I pluged the earphone again.. then the sound effect will stuck at (earphones) again.. and again from the top.

  • moidah Level 1 Level 1 (0 points)

    I had this issue; When I unlocked my iPhone (4) I would have sound (unlock and key click sounds were working) for about 5 seconds and then nothing. The volume bar disappeared in the Music app (and other similar apps, e.g. Podcasts, Videos), but in Settings > Sounds you could adjust the ringer volume and the ringtone would play at the chosen volume. If you lock your iPhone, wait 30 seconds and unlock, the sound is back again, but equally temporarily! If these are the kind of symptoms you're seeing, you're most probably stuck in Dock Mode. To fix, clean out as much lint and other nastiness from the dock connector, probably best with a pointy plastic implement of some kind to avoid shorting anything - some people have suggested a DRY toothbrush (you don't want to invalidate your warranty by activating the moisture sensor in the connector!), but that might not work depending on how encrusted your dock connector has become. This did the trick for me

  • masterfahd Level 1 Level 1 (0 points)

    I bought my iPhone 4S in May 2012 and it was working fine but the day I updated it to 6.0.0 version the sound issue popped up. My mobile now workings according to its mood. Sometimes I can hear its typing sound and music sometimes nothing at all. Ringer works but sound has issues. Sometimes volume control do not work at all and sometimes it does. I have from turning on the mute button to resetting the device to formatting and re installing the firmware did every trick but nothing works. It's a moody phone. Now I updated to 6.0.1 as well but nothing has changed. Half of this text was without sound and half with sound.

  • BioWorkZ Level 1 Level 1 (0 points)

    This totally worked. I went straight for the compressed air. Thanks!!!

  • Kathy Palacio Level 1 Level 1 (0 points)

    My phone was wasn't in headphone mode but whenever you would try to turn up the volume with the buttons it would show the vloume icons but not the little squares in the botton going up or down. Instead of pluging in you headphones and pluging them out use the 30 pin connector. I only did it for about 10 times and BOOM my sound was back!- Hope this helped!!!!!

  • campbuds1991 Level 1 Level 1 (0 points)

    So has any REAL solution for this been discovered? Is there a part we can just replace are should we open the phone up and clean it since blowing in it seems to work?

  • Jackie615 Level 1 Level 1 (0 points)

    Same problem here today with a 4S. It's only a few weeks old. All I did was blow air into the headphone jack and the dock connector and the sound all came back on. I'm assuming it got dirty as it's exposed to being in a warehouse with tons of sawdust, even with and Otterbox Defender on it, the dust must still be getting in.


    But no big deal, if I had canned air, I would've used that to be safer. And to my surprise just a little air gave sound back to the phone.


    Hope it works for the rest of you!

  • twoznuf9397 Level 1 Level 1 (0 points)

    I had no problems and all of a sudden I have no bar on my volume display.  I push the volume + all the way up and my phone rings but no sound on videos games, etc.  I did something someone post to blow in the charger area so I actually use my husbands air compressor and blew out the charge insert area and the headset area.  Believe it or not it WORKED!! THANK YOU!!

  • croysterjr Level 1 Level 1 (0 points)



    My iPhone 4S had the same problem and I did what Qsalman recommended and it worked!!


    Currently Being Moderated

    Re: No sound coming from my iPhone 4s.

    Jun 22, 2012 6:08 PM (in response to smoltzfan)


    I had the same problem and came here to try to look for a solution. As I looked on I saw nothing to help. Everyone said get it replaced. So I had a crazy idea. It obviously wouldn't work so I went what the heck, I'll do it. Apparently random button pushing helps, luckily I remembered my randomness. Worked for me so lets hope it works for you. So heres what to do:

    1.) Go to the lock screen(don't type your password in if you have one).

    2.) Press both sound buttons(the plus and minus).

    3.) Try to press the main circle button thing.(Do it)

    4.) Simply slide to unlock.

    At least I think that's what I did. After all it was random. Just try it. I do remember though. Lock screen, don't go on the password screen. Use the screen that says "Slide to Unlock".

  • JacJacDay Level 1 Level 1 (0 points)

    Your "fix", as random as it may have been, was the most appealing one to me to try first. No downloading this or change settings on that. And.........IT WORKED!!!!

    Thank you so much :-)

  • CloudBursters Level 1 Level 1 (0 points)

    Spilled light beer all over the front of my 4S. Sat off for a while then exhibited these symptoms, (no volume bars when pressing side controls, no sound when selecting ringtone sounds but yes when moving volume slider in settings, and no keyboard clocks, lock sound)


    Unsuccesfull with restarting and restting settings.

    Here's what worked for me many hours after incident, (may have been  a combination or just one thing):


    -Thinned out, dry, q-tip in the headphone jack to lightly clean some gunk out -(got this idea from u-tube)


    -used a sewing needle to clean out the gunk from dock connector, and there was LOTS of lint and just crap accumulated. Probably better to use aplastic or non-reactive material but i didnt have anything else handy.


    -blowing into the dock connecter area after lightly poking and rolling the stuff around, getting as much out as possible


    tl:dr version : clean the stuff out of your dock connecetor. sounds came back all normal

  • ray555 Level 1 Level 1 (0 points)

    I have been experiencing the "common sound problem with the iphones". Took it into apple and they told me it wasn't software as I had done the restore and backup about 5 times and it is up to date. They said it was hardware and I had to pay $199 for a new phone. I'm not gonna do that when I am 6 months from my upgrade point. I got this iphone4 from my husband when he updated to the 5. I finally found this site and did the alchol swap, toothbrush, cool hairdryer trick and it worked. I was so happy. Well I was happy for 2 weeks till I had the same problem again starting yesterday. Did the whole process again and it would come back here and there. ANNOYING! So I read more and saw about the canned air thing. I figured 8 bucks for a can of air is worth trying. I tried it and it didn't work right away. Probably did it about 3 times and the sound has come back. There was a lot of dust and junk in the dock/charge port and I had just cleaned it out 2 weeks ago. Well, now I have the canned air on hand when I need to do it again. I almost resorted to jail breaking it cause I was so annoyed that it came back but it is clearly a dock port issue. Dust gets in there and it thinks it's being docked and sound will only work thru the headphones.


    Best of luck, buy a thing of canned air.

  • scf_foto Level 1 Level 1 (0 points)

    I have been having this same problem for a couple days now. After reading many posts and trying canned air, a toothbrush etc I decided to go with the random push all the buttons fix. As I was doing this I got a screen I've never seen before:photo.PNGThis leads me to believe that the phone is stuck in some sort of mute dock connector mode (my phone was not plugged in or docked). Now I just wish someone could tell me how to turn it off. Hitting the cancel button does nothing...

Previous 1 4 5 6 7 8 Next