Previous 1 2 Next 18 Replies Latest reply: Nov 2, 2013 8:47 PM by ishadoe
senseiwa Level 1 Level 1

Hi! I just obtained a brand new free email certificate from Comodo, but I can't make Mail see that!

 

Before Lion I used certificates, but I don't remember how I got Mail to see them.

 

I tried double clicking on the file, and it installs it correctly under "login / All items", but Mail doesn't seem to be affected. I read on the web that the certificate should be placed under "login / My Certificates", but copy/paste doesn't work!

 

Is anyone using Comodo or similar certificates with Lion 10.7.2 and Mail.app ?

 

 

Cheers!


MacBook Air, Mac OS X (10.7.2)
Solved by David Bergum on Oct 30, 2012 10:37 AM Solved
Thanks xtof06!  I was following a "how to" on installing an email certificate from comodo and it had a step to select the certificate in the TLS configuration of the associated email account in Mail.  I see that step is not needed and Mail finds the certificate without configuration.  Nice!
Reply by runger56 on Nov 27, 2011 1:21 PM Helpful
There are three steps to using the certificate: Make sure it is installed.  Comodo sent you an email with buttons, links and password.  I found the button didn't work, and you must use the hyperlink and the password to complete the installation.Next, you must export the certificate.  Using Firefox, go to Preferences - Advanced - View Certificates.  There you will see the certificate from Comodo.  Export it.In Keychain, import it. If you've used certificates previously, everything else remains the same in the Mail app.

All replies

  • runger56 Level 1 Level 1

    There are three steps to using the certificate:

     

    1. Make sure it is installed.  Comodo sent you an email with buttons, links and password.  I found the button didn't work, and you must use the hyperlink and the password to complete the installation.
    2. Next, you must export the certificate.  Using Firefox, go to Preferences - Advanced - View Certificates.  There you will see the certificate from Comodo.  Export it.
    3. In Keychain, import it.

     

    If you've used certificates previously, everything else remains the same in the Mail app.

  • trevorchill Level 1 Level 1

    I can't seem to get this to work either.

     

    I downloaded an email certificate from Comodo.  It saved as a .p7s file, which I double-clicked to install into keychain. 

     

    In keychain, I have an apple certificate with a private key for my apple ID, which is the same gmail address as the address I used for the comodo certificate.

     

    However, there appear to be two separate certificates from comodo: one named for my gmail address, and one named "COMODO Client Authentication and Secure Email CA".  These show up under "Certificates" but not under "My Certificates"...

     

    When I launch Mail and check for TLS certificates in account preferences, I only see the apple ID one listed, not any of the ones from comodo...

     

    Any idea what's going on here?

     

    Thanks,

    Trevor

  • take_the_shot Level 1 Level 1

    I'm having the exact same issue.

    I was fighting with this for hours last night but no matter what I did all I can see in mail is the cert related to my apple id.

    Any help with this would be greatly appreciated!

  • keo604 Level 1 Level 1

    I have the exact same issue with a Comodo issued certificate. Anyone managed to solve this?

  • xtof06 Level 1 Level 1

    Yes, the issue comes from the country.

    When you submit a CERT request to Comodo make sure you select US or UK country, then the Cert will install automatically into your My Certificate.

    If you put other country it might not work (most likely due to regulations)

  • take_the_shot Level 1 Level 1

    I tried using the United States as the selected country, it made no difference, can still only see the apple certificate in "Mail" settings.

  • xtof06 Level 1 Level 1

    There is no place to "see" or "select" a s/MIME certificate in Mail. You can only select TLS certificate which has nothing to do with s/MIME.

    for s/MIME the selection is automatic, when Mail finds a certificate that matches the email address that you defined in your Mail account settings then it offers you the possibility to Sign the message when writing a new mail from this mail address, and if you have the Cert of the recipient the encrypt icon is enabled.

  • David Bergum Level 1 Level 1

    Thanks xtof06!  I was following a "how to" on installing an email certificate from comodo and it had a step to select the certificate in the TLS configuration of the associated email account in Mail.  I see that step is not needed and Mail finds the certificate without configuration.  Nice!

  • corican Level 1 Level 1

    I have exactly the same issue. How did you solve it ?Capture d’écran 2012-12-03 à 00.50.08.png

  • senseiwa Level 1 Level 1

    I just asked for, and installed a mail certificate from Comodo.

     

    Actually, I just followed Comodo's steps, and I found public and private keys in my keychain, under "my certificates".

     

    I had to restart the Mail app, though. Creating a new mail, I saw the "sign email" icon.

     

    That's good!

    signedmail.png

  • corican Level 1 Level 1

    Hi senseiwa, the difference is that I see the certificate under "certificates" but not "my certificates".

    Where did you find these comodo steps ? I got my certificate from tbs-internet.com.

  • corican Level 1 Level 1

    Ok this is solved. I took a certificate from Comodo website, opened it with "keychain", can see it under "My certificates", and my messages are signed.

  • Stewfalcon Level 1 Level 1

    Corican,

     

    I have downloaded and installed the Comodo cert. It shows up in "My Certificates" but I don't have the option to encrypt or sign messages and I don't have it listed under TLS Certicates in my Mail Preferences. Can you describe exactly how  you made this work?

Previous 1 2 Next