Previous 1 5 6 7 8 9 Next 131 Replies Latest reply: May 8, 2015 9:08 AM by PatrickL Go to original post
  • GSVNotInventedHere Level 1 (0 points)

    I had this issue last month.

    Kriya Yogi's fix worked for me.

    Thanks awfully old bean.

  • cchamberlain Level 1 (0 points)

    I am now experiencing what most of you have. I am running 2.4 GHz MBP on Moutain Lion 10.8.4 connected to a TBD. I have had no problems running my peripherials out of the USB ports until today. I've tried a multitude of fixes listed on the threads from deleting preferences from the library to changing up the the individual peripherials using the ports to no avail. I'm feeling this might be a hardware problem and about to take it back to Apple to have it fixed.

     

    Are there any real solutions that have worked for most disgruntled owners using the TBD in the same way?

     

    How many individuals have just returend their monitors as a last resort?

  • Mark TTU Level 1 (0 points)

    I still live with the failings of the TBD. I upgraded from a 13" MBA to a 15" MBPR a few months ago and still randomly have issues with the display part working, but nothing else: no ethernet, no usb, no firewire. When that happens I have to close out all my programs, and try to shutdown my MBPR. Typically I can't get my Mac to shutdown so I just hold the power button until its off and then reboot while connected to the TBD.

     

    Overall I'd say 4 out of 5 times everything works as it should and while I'm not happy about the 20% of the time it doesn't I've given up on Apple actually caring and just learned to live with it. Seems if you're not talking about an iOS device Apple's give a **** is seriously broken these days.

  • woodja8 Level 1 (0 points)

    This is the only thing actually worked for me.  Thanks Kriya!

  • degger Level 1 (0 points)

    Actually I just also had the problem with the thunderbolt display and ethernet simply not connecting anymore, seemingly due to not having a valid MAC address anymore (as can be determined by the empty MAC address field under "Advanced..." in the Hardware tab). Fixed it by selecting "Display Ethernet", hitting the "-" button to remove it, followed by Apply, reconnecting the display, hitting the "+" button and readding "Display Ethernet". Works now again for me.

  • jak352 Level 1 (0 points)

    Thanks degger, that fixed the problem for me using my new Macbook Pro Retina on Mavericks. I want to connect to the network with my Thunderbolt to Ethernet adaptor and I now have the MAC address displayed in the Hardware tab (it was missing before).

  • tbirdvet Level 4 (2,880 points)

    All TB ports work with my 2012 Mini but the USB2 ports run slower with USB2 hardware than USB ports on the Mini but this is a known issue.

  • NStrecker Level 1 (0 points)

    Two years later, this post just solved my same issue- Thanks!

  • TheMatador Level 1 (0 points)

    Workaround:

    I was getting an error that the cable was connected but I didn't have an IP (v4 or 6) address.  If I set the IP address manually (and router, subnet mask, DNS server etc.) then it works fine.

     

    This suggests that it's the DHCP packets that aren't getting through.  Once the IP address is there it works fine.

     

    This suggests that it's nothing to do with the cable.  Also, when I connect directly to the Thunderbolt adapter directly on the Mac it's fine, so it's not an issue with the MBP either.

  • eduasand Level 1 (0 points)

    I had the same problem, so i tried my thunderbolt ethernet adapter. I plugged the thunderbolt ethernet adapter on my display and connect it to a ethernet cable and it is working fine. I don't know why the ethernet port on the display doesn't work, but this trick work for now until apple fines a solution.

  • dmltv Level 1 (0 points)

    This fixed my problem too, I was having the same issue and was worrying that I would have to do a clean install, the issue didn't persist on a freshly installed copy of OS X. Luckily Kriya Yogi's solution saved me the trouble for now

  • PatrickL Level 1 (45 points)

    I am having this issue as well. I enjoyed have a free TB port on my MBPr 15" (use my TB display as a hub), but now have to occupy it with a TB-to-Ethernet adapter, which works just fine.

Previous 1 5 6 7 8 9 Next