Previous 1 2 3 4 5 6 Next 131 Replies Latest reply: May 8, 2015 9:08 AM by PatrickL Go to original post
  • cgq Level 1 (0 points)

    I deleted /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and rebooted.


    I can access Internet even if my Wifi is off. However, in the preferences, it shows that my Display Ethernet is NOT connected but my Bluetooth PAN is connected. I never saw Bluetooth PAN in the list before. I thought that I was connected by Bluetooth to whatever device my workmates had near by, but disconnecting the display disconnects the Bluetooth PAN and turning off Bluetooth does not disconnect the Bluetooth PAN. I conclude that Bluetooth PAN is my Display Ethernet but it has the wrong name.


    I then deleted the file /Library/Preferences/ and rebooted. Same thing, I am now connected with Bluetooth PAN.


    On one hand, it is a success since I am now connected to the display. However, I have the feeling something is missing in the procedure because connexion names are shuffled.


    Time will tell whether the fix works. So far so good.

  • Mark TTU Level 1 (0 points)

    I had a similar experiance except that my display network got renamed USB Ethernet. I just renamed USB Ethernet to read Display Ethernet and deleted the non-functional Display Ethernet. Seems to have done the trick thus far...

  • Endurion Level 1 (0 points)

    Can you see, in your Network Preferences, under the adapter that is actually your Display Ethernet but is misnamed, what it shows for Hardware?


    I am particularly curious what your Bluetooth PAN or your USB Ethernet is showing for Link Speed (100baseT, 1000baseT, etc.) and what your duplex and MTU is.


    Looks like this:


    Screen Shot 2012-02-10 at 11.21.33 AM.png

  • Mark TTU Level 1 (0 points)

    This is what mine looked like both before and after I renamed it. The fact that is was connected at 1000 told me it couldn't be the USB Ethernet since it tops out at 100.

    Screen Shot 2012-02-10 at 11.34.18 AM.png

  • cgq Level 1 (0 points)

    And this is mine.



  • Mark TTU Level 1 (0 points)



    Is your display plugged into a 100 meg switch or a gigabit switch?

  • cgq Level 1 (0 points)

    I asked the technician and he says 100 meg.

  • bochen Level 1 (0 points)

    please execute such command in terminal:


    sudo lsof | grep -i plist


    In macs all prefereces are stored in plist files, i thing there is some cache or other file with description of those devices. This is how i found that blued have to be deleted. Maybe there is something more.


    At last you might use onyx and remove all preferences and system cache.

    I hope this will help.

  • cgq Level 1 (0 points)

    It did help a lot! In what I am concerned, I will wait until Monday morning to see if it still works, and if it does, I consider this problem solved.


    Here is the output of lsof. I hope it helps you improve your solution.


    Thanks a lot for helping me!



    launchd     1           root   42r      REG               14,2         0             4589702 /Library/Preferences/SystemConfiguration/
    launchd     1           root   43r      REG               14,2    607944             4552010 /Library/Updates/ProductMetadata.plist
    kextd      10           root    4r      REG               14,2      2623               34790 /usr/standalone/bootcaches.plist
    opendirec  13           root  txt       REG               14,2    308608             4377466 /System/Library/OpenDirectory/Modules/PlistFile.bundle/Contents/MacOS/PlistFile
    notifyd    14           root   28r      REG               14,2       232               86397 /Library/Preferences/SystemConfiguration/
    notifyd    14           root   41r      REG               14,2       478             4340847 /System/Library/CoreServices/SystemVersion.plist
    notifyd    14           root   42r      REG               14,2      2445             2194968 /System/Library/CoreServices/PlatformSupport.plist
    blued      22           root    8r      REG               14,2         0              327465 /Library/Preferences/
    blued      22           root    9r      REG               14,2         0              327464 /private/var/root/Library/Preferences/blued.plist.lockfile
    loginwind  67         myname    7r      REG               14,2         0              474626 /Users/myname/Library/Preferences/
    loginwind  67         myname    8r      REG               14,2         0              475556 /Users/myname/Library/Preferences/
    loginwind  67         myname    9r      REG               14,2         0              475558 /Users/myname/Library/Preferences/ByHost/
    loginwind  67         myname   13r      REG               14,2         0              775680 /Users/myname/Library/Preferences/ByHost/
    applepush  81           root   12r      REG               14,2         0              474723 /Library/Preferences/
    logind    202           root    4r      REG               14,2         0              327952 /Library/Preferences/
    Dock      246         myname   21r      REG               14,2         0              474608 /Users/myname/Library/Preferences/
    SystemUIS 248         myname   10r      REG               14,2         0              474670 /Users/myname/Library/Preferences/
    Finder    249         myname   18r      REG               14,2         0              474665 /Users/myname/Library/Preferences/
    PhotoStre 274         myname    5r      REG               14,2         0             2301768 /Users/myname/Library/Preferences/
    Alfred    294         myname    6r      REG               14,2         0              946092 /Users/myname/Library/Preferences/com.alfredapp.Alfred.plist.lockfile
    Mail      322         myname    9r      REG               14,2         0              935741 /Users/myname/Library/Preferences/com.druide.Antidote.plist.lockfile
    Mail      322         myname   21r      REG               14,2         0              568270 /Users/myname/Library/Preferences/
    Mail      322         myname   44r      REG               14,2         0             2262534 /Users/myname/Library/Preferences/MobileMeAccounts.plist.lockfile
    Mail      322         myname   47r      REG               14,2         0              475423 /Users/myname/Library/Preferences/
    Mail      322         myname   50r      REG               14,2         0              775680 /Users/myname/Library/Preferences/ByHost/
    iTunes    608         myname    7r      REG               14,2         0              475603 /Users/myname/Library/Preferences/
    iTunes    608         myname   10r      REG               14,2         0              475606 /Users/myname/Library/Preferences/
    iTunes    608         myname   11r      REG               14,2         0              475608 /Users/myname/Library/Preferences/ByHost/
    iTunes    608         myname   43r      REG               14,2         0              924108 /Users/myname/Library/Preferences/
    iTunes    608         myname   44r      REG               14,2         0              955431 /Library/Preferences/
    iTunes    608         myname   46r      REG               14,2         0              478791 /Users/myname/Library/Preferences/
    System    639         myname    4r      REG               14,2         0              522815 /Users/myname/Library/Preferences/
    System    639         myname   10r      REG               14,2         0              775680 /Users/myname/Library/Preferences/ByHost/
    Preview   745         myname    8r      REG               14,2         0              606961 /Users/myname/Library/Containers/
    Safari    812         myname    8r      REG               14,2     14850             3950071 /Users/myname/Library/Safari/Bookmarks.plist
    Safari    812         myname   19r      REG               14,2         0              523394 /Users/myname/Library/Preferences/
    Safari    812         myname   25r      REG               14,2         0              775680 /Users/myname/Library/Preferences/ByHost/
    Terminal  866         myname   14r      REG               14,2         0              605556 /Users/myname/Library/Preferences/
    Terminal  866         myname   15r      REG               14,2         0              775680 /Users/myname/Library/Preferences/ByHost/
  • bochen Level 1 (0 points)

    Nothing unusual there.


    You might try to use onyx for cleaning cache (


    I hope it'll help. If not, sorry. This is time when apple developers should do the rest.

  • cgq Level 1 (0 points)

    The problem is still unsolved. I could not connect to the Ethernet port this morning.

  • Mark TTU Level 1 (0 points)

    Looks like my problem has not gone away either. I had high hopes at the end of last week, but so far this week my computer is back to its old reliable non-functional self. Guess its time to invoke Apple Care....

  • urbicande Level 1 (0 points)

    The problem by invoking Apple Care is that they will send you to a store to have your screen replaced. Not sure the new one will work better. I spoke to an Apple Care representative that told me a new firmware update should be out soon. That will save you a trip with a heavy box to the Apple Store.

  • Mark TTU Level 1 (0 points)

    I love it when they try to send me to a store... closest one is nearly 400 miles away   ...  their desire to never pay for shipping and my lack of proximity to a store always creates a bit of dilema for them.


    I don't really have time to call them this week anyway so maybe they will have this sorted out soon. If not I'll add my voice to the list of folks upset at the performance of my new setup.

  • Mark TTU Level 1 (0 points)

    Finally broke down and called Applecare this morning. Went through the normal stuff and then they sent me a diagnostics tool to grab all the system info about my MBA and display. Sent them back the diagnostics info and they're kicking it up to engineering to get a solution worked out. I imagine the more people who can take the time to call and send in diagnostics info the easier it will be for their engineers to pinpoint the problem.

Previous 1 2 3 4 5 6 Next