Previous 1 4 5 6 7 8 9 Next 131 Replies Latest reply: May 8, 2015 9:08 AM by PatrickL Go to original post
  • Mark TTU Level 1 Level 1

    I've got a 13" MBA with 1.8GHz i7 w/ 4GB RAM and a 480GB SSD and have probelms as well. I never have to reboot the TBD to get things working.


    What I've found that works 100% of the time is a reboot of the MBA while its connected to the TBD.


    If the MBA is off sometimes it won't power up at all while connected to the TBD so I have to power it up, connect it to the TBD, then reboot the MBA.


    I agree 100% that Apple needs to fix this. Have you called them about it yet? Have you sent them a diagnostics image of your computer so they can try to pinpoint the issue? The more we all bug them the faster they will find a solution; especially if we all send in the diagnostics data to help their engineers figure out where the bug is.

  • pkrnjevic Level 1 Level 1

    StephenM54 had an interesting suggestiion regarding manually configuring the TBD Display Ethernet via the Hardware settings tab (System Preferences -> Network -> Display Ethernet -> Advanced -> Hardware).


    It is probable that in "Configure: Automatically" mode, "Duplex" is set to one of the "energy-efficient-ethernet" modes, which will turn ethernet tranceivers on and off to save power depending on network use. Perhaps this gets stuck in the wrong state when (un)plugging TBD to Mac.


    Stephen didn't mention (though Urbicande discovered) that you have to get your ethernet working again (by rebooting Mac) before you can set the Hardware properties.


    I've set mine manually and will report back whether or not this provides a viable workaround.

  • urbicande Level 1 Level 1

    I'd be interested to see how that goes. On my side, Apple replaced the dual cable (power & thunderbolt). I'll get the display back tomorrow and report back within a few days.

  • Mark TTU Level 1 Level 1

    I just set mine to manual and 1000 full duplex. We'll see if that solves the problem over the next week or so...

  • Anthony Buckton Level 1 Level 1

    I'm a network engineer and I've never come across of a "power saving mode". Typically the opposite is true where the network stays active whilst the rest of the machine goes to sleep thus enabling "Wake on LAN".


    If we have to set the NIC to a specific setting rather than using "automatic" that infers that the Ethernet chip set is not being driven correctly by software. Yet this stuff has been "plug and play" for at least 10years in other environments (including USB) and even longer for Apple.


    My problem crops up if I disconnect the Thunderbolt ("go mobile") and plug the Thunderbolt back in with the machine active. If the machine is asleep when I plug in the Thunderbolt  its reliable.


    There must be something in the enumeration (ie discovery) of the devices (Ethernet in this case) as the Thunderbolt interface comes up in an active environment.

    Unfortunately, all of this points back to Apple's Thunderbolt driver and the way that it presents the display Ethernet to the networking stack.... Apple ?


    Could I poll the group to see if plugging in whilst the Mac is sleeping (in my case the lid is shut) makes a difference?



  • urbicande Level 1 Level 1

    In my case the probem always appears when connecting back the computer while sleeping, lid closed.

  • Endurion Level 1 Level 1

    I began testing Mountain Lion 10.8 as soon as the beta became available, and I have not had a problem ever since.


    I regularly had this problem as I would frequently move my MBA back and forth from the Cinema Display, sleeping and waking frequently.


    My routine has not changed, and since the upgrade to 10.8 I have not seen this issue repeat.

  • pkrnjevic Level 1 Level 1

    And mine fails at random whether reconnecting while my MBA is asleep or awake, perhaps 25% of the time. I sure hope this manual setting idea works - don't feel like waiting until Mountain Lion is GA.

  • pkrnjevic Level 1 Level 1

    I'd never head for energy-efficient-ethernet (from the Network Preferences dialog).

    A quick google produces this wikipedia page:

    And this caught my attention: 


    "The power reduction is accomplished in a few ways. In 100 Mbit/s, 1 gigabit and 10 Gbit/s speed data links energy is used to keep the physical layer transmitters on all the time. If they could be put into "sleep" mode when no data is being sent that energy could be saved.[4] By sending a low-power-idle (LPI) indication signal for a specified time the transmit chips in the system can be turned off."


    This all sounds nice, but I'm curious how well it plays with older commodity switches, like the junk I have kicking around my house.

  • tgaffney Level 1 Level 1

    I just bought a TBD today for my 2011 MBA and tried to connect it to Ethernet. It could not find it. I read this thread and did not understand most of it, but in network diagnostics, where it says "Configure IPv4," I changed it from Using DHCP to "Off," then back to "Using DHCP" again. Suddenly it worked. I have no idea what this means. I am running Lion 10.7.3, the MBA firmware is up to date and I have not used Time Machine on this computer.

  • pkrnjevic Level 1 Level 1

    Sad to report that setting the hardware settings manually made no difference. I still randomly can't connect via TBD ethernet when reconnecting my MBA 2011.

    Apple, please fix this - I'm tired of rebooting.

  • ShenLung Level 1 Level 1

    Yes - it just does not work.  I have a thunderbolt display at my office and it works fine evey day - but the one I purchased for my home does not seem to want to work at all.

  • pkrnjevic Level 1 Level 1

    What's the difference between the two TBD?

    I hope Apple is paying attention to this issue.

    I find unsettling the fact that Apple makes no comment on issues like these.

  • tomeng0101 Level 1 Level 1

    Just bought the TBD for my 2011 MBP 13" on Sunday and the display ethernet has never worked; however, I have not tried all the rebooting suggestions here (haven't found time from my development).


    Although, I will say, doing EXACTLY what "tgaffney" said 3 posts above worked perfectly (under Network settings, switch Configure IPv4 from DHCP to OFF and back again to DHCP).  Nice work and thanks!


    I imagine I'll have to do this after disconnecting/rebooting/etc, which is not a reasonable long term solution for several grand - just trying to get that $97B reserve up to a nice full $100B ;-)


    6 pages of comments and a year out, this should be fixed permanently.

  • pkrnjevic Level 1 Level 1

    I called Apple Support regarding this issue, as it has progressed to where the TBD ethernet never works without rebooting my MBA.


    They walked me through resetting SMC followed by resetting PRAM and NVRAM. Below are links to each procedure:



    Lo and behold this morning the ethernet works fine. Go figure.


    I'll let you know if/when this breaks

Previous 1 4 5 6 7 8 9 Next