Previous 1 2 3 Next 131 Replies Latest reply: May 8, 2015 9:08 AM by PatrickL
uribejm Level 1 (20 points)



I have a 1.8 GHz Core i7 Macbook Air connected to a thunderbolt display.


Some days the displays Ethernet port works and some other days (now the majority) the Ethernet Display shows no connection (red dot, s if the cable was not plugged in). I have tried different cables and different connections (I have a 100 Mbps port non powered and a 1000 Mbps port non powered) all with the same result. I know the ports are working because I have tried different computers and peripherals and they all work.


Has anybody seen this issue?


Can it be fixed?


I recently applied the latest firmware update from apple.







MacBook Air, Mac OS X (10.7.2), Core i7
  • cgq Level 1 (0 points)

    Same problem here. Installing the latest firmware does not solve the problem. However, rebooting the computer "solves" it.

  • David Mikulin Level 1 (20 points)

    Sometimes after going to sleep and then waking, my Thunderbolt Display Ethernet does not work.  My 2011 MBP thinks the connection is okay (green dot) and I appear to even be able to renew my lease.  But the connection is useless - I have to reboot my Macbook to get it working again.

  • IdleWander Level 1 (0 points)

    Has anyone here restored from Time Machine before the issue occured. I have depolyed 5 of these displays with new machines and only the systems which had Time Machine restores are having this issue. The others work fine.

  • cgq Level 1 (0 points)

    Yes, my external hard drive, on which Time Machine stores the backups, is plugged to the display. I will unplug the hard drive and let you know whether that solves the problem.

  • jschaffe Level 1 (0 points)

    I got my wife a 2011 13" MacBook Air and recently added the Thunderbolt display.  She absolutely loves it, but has problems getting the ethernet port to work after sleet and/or disconnecting the display and reconnecting it later.  She applied the firmware update, but she's back to using the USB ethernet adapter, negating one of the main advantages of having the display, using it as a docking station.


    I haven't had time to play with configurations and such, but it should work more reliably that it is!

  • pmaheshwari Level 1 (0 points)

    I totally agree , I am having the same issue , only rebooting the macbook air solves the issue.


    I have applied the latest firmware fix as well.


    If there is any update regarding this , kindly let me know !

  • DDD-MAN Level 1 (0 points)

    Thank goodness i'm not the only one.  Drives me nuts!

  • pmaheshwari Level 1 (0 points)

    yes but whats the solution for this ? I mean after spending $1000 , i expect some sort of support !


    And is this only wrong with out devices or its something wrong with all the thunderbolt models

  • Endurion Level 1 (0 points)

    I've been having this exact same problem from the beginning. I have the latest MacBook Air 13". No amount of unplugging or powering down the monitor will work - only a full reboot of the Mac.


    I frequently unplug my Air and plug it back in as well as putting it to sleep multiple times throughout the week. At some point it simply no longer activates the Display Ethernet.

  • 2200xl Level 1 (0 points)

    I too am experiencing the same problem.  11" MBA.

  • uribejm Level 1 (20 points)

    I have been following the thread and attempting different modes of reboot, with no avail. It seems that after the last firmware update the Ethernet port is just plain useless.

  • JohnsonHH Level 1 (0 points)

    I have the same issue that sometimes after I put my MacBook (early 2011) to sleep and wake it up again the ethernet connection is broken (1 of 10 times). In the system preferences the network has a green dot but the allocated DHCP adress is wrong, completely strange IP. Only a reboot resolves this issue.


    I installed all the firmware updates for the display but the only way around this is prevent standy while on the display.


    I also had issues with TimeMachine Backups to a NAS getting corrupted because of the ethernet issues. If anyone can provide information how to fix this I would be very happy.

  • nate the dog Level 1 (0 points)

    Same issue here. Have updated the display with the latest firmware and 13" MacBook Pro (spring 2011) with all updates (I'm running OS X Lion 10.7.2.) When I "dock" the laptop I have the same problem. Ethernet connection to back of the Thunderbolt display is not recognized. Red dot with message "cable not connected." I've tried renewing the DCHP lease and it doesn't help. If I plug the ethernet connection directly to the MacBook it connects immediately. Like others above I have to restart the machine to get the Thunderbolt connection to work. Since I'm running VMFusion for Windows 7 this also has to be shutdown which is a further hassle. As everyone else as noted this kind of defeats the purpose of using the TBD as a "docking station."


    I also had a problem with my USB Mac keyboard connecting through the display. I was not able to wake up the Mac via the keyboard....had to use the mouse. Once the Mac was aawke the keyboard still didn't work. I had to unplug/replug the USB connector. I ended up removing a 2nd connected USB hub and this seemed to solve the problem. It takes a while but I can now wake up the Mac with the keyboard.


    I contacted Apple about the keyboard issue and they seem to be aware of the keyboard problem. Not sure about the ethernet connection issue. They told me they wanted to "capture" my MacBook/TBD combination and replace them with new ones. I told them "I don't think so." The machine is for both work/home use and it would take days to reload all the software and set up a new one.

  • Endurion Level 1 (0 points)

    I have a few observations to report.


    I seem to have been able to cause the issue to stop occuring if I follow these steps:


    When setting up my MBA at my Display, I start the MBA up and log in before connecting the Thunderbolt port. So far, when plugging the port in after booting, I do not have the inactive port issue. It seems the issue occurs when plugging in the Thuderbolt connection prior to booting the MBA up from sleep.


    Also, the following suggestion may help:


    If your Display Ethernet is inactive even though it is physically connected, try the following:


    Open up Terminal. Type:


    sudo ifconfig en4 down

    sudo ifconfig en4 up


    That should force the OS to shut the interface down and bring it back up manually, without the help of the main user interface.


    Disclaimer: In my case, the Display Ethernet seems to be en4 usually, but for others and in different circumstances it may be possible for it to be either en1, en2 or en3.... but en0 should always be your WiFi interface.

Previous 1 2 3 Next