5 Replies Latest reply: Oct 25, 2013 2:20 PM by Btebb59
nida_mac Level 1 Level 1 (0 points)

Hi,

 

I have a mac pro with Mac OS X version 10.6.8, 2.4 GHz inter Core 2 Duo processor and 4 GB memory. My laptop was working perfectly fine last night but in the morning it wasn't connecting to the internet. Its shows that it is connected to the internet but whenever i try to open a webpage on safari, this message pops up "You are not connected to the intrenet". I tried network diagnosis.. and it says that my airport and airport setting are fine but my network settings,ISP,Internet, server failed. My wifi connection/router is working perfectly fine because i can use the wifi on my iphone and other laptops. I even tried connecting to the university internet but no luck, it shows the same problem. My airport card is working perfectly fine too, i checked. I dont know what to do. PLEASE HELP


MacBook Pro, Mac OS X (10.6.8)
  • lesliefromwalpole Level 1 Level 1 (0 points)

    I have the same problem. Did you figure it out? If so, please share!

  • FrenchToast Level 3 Level 3 (645 points)

    You usually just need to go into System Preferences under Network, to select Airport in the left pane, then to click on Advanced, then in the next screen, to delete your current network in the left pane, to add it again. You'll have to enter your passphrase, of course, but it's usually the best option. That and restarting Airport from the Menu bar.

     

    If you can't connect again after recreating your network in System Preferences, enter a dollar signe before your passphrase to fool the Keychain app.

  • iforgotu2 Level 1 Level 1 (0 points)

    Found this fix didn't work for me; though didn't try putting dollar sign in password, (couldn't imagine it would work). Fix did however, after rebooting through recovery disk (10.8) and 'repair permissions/disk' from 'disk utilities'. It now doesn't seem to hang on network settings after coming out of sleep mode: which had become a norm. Maybe a combination of above (resetting network settings) and fixing disk permisions is a possible solution.

    Worked for me

  • Atman shah Level 1 Level 1 (10 points)

    Well,

    Try these steps,

    Unplug everything on your mac except power cord ethernet cable to..

    Now  Make sure you have battery less than 98 %.Once the power cable is plugged hold Command +Option +R and pressing this buttons press the start button and you will see the power light on power cord connected to your mac goes green for some seconds and then becomes orange now,Dont boot and press command+option+p+r and holding these buttons boot onto system,Yeah youll listen startup chimes two time and then it will boot on to the os next follow these steps,

    You usually just need to go into System Preferences under Network, to select Airport in the left pane, then to click on Advanced, then in the next screen, to delete your current network in the left pane, to add it again. You'll have to enter your passphrase, of course, but it's usually the best option. That and restarting Airport from the Menu bar.

     

     

    Thanks Atman,

    GOOD LUCK :-)

  • Btebb59 Level 1 Level 1 (0 points)

    Thanks for the solution French Toast. I had to go through the process of using the $ (dollar sign) in order to make it right. But it worked! We are back up and running!