3 Replies Latest reply: Nov 24, 2011 8:57 AM by noondaywitch
slappy56 Level 1 (0 points)

I am running 10.5.8 on my Mac. But I need to upgrade to 10.6.8 to use iCloud with my new IPhone 4S. Can I update? If so, will it affect existing software? Affect anything else negatively? Is there a downside? thanks


iMac, Mac OS X (10.5.8)
  • Level 8 (41,760 points)

    What iMac do you have?  If it is an Intel machine, yes you can update to 10.6.8. 

  • rkaufmann87 Level 9 (55,218 points)

    Here are the minimum specifications Apple has for Snow Leopard.

     

    System Requirements

    • Mac computer with an Intel processor
    • 1GB of memory
    • 5GB of available disk space
    • DVD drive for installation
    • Some features require a compatible Internet service provider; fees may apply.
    • Some features require Apple's MobileMeservice; fees and terms apply.
  • noondaywitch Level 6 (8,135 points)

    slappy56 wrote:

     

    I am running 10.5.8 on my Mac. But I need to upgrade to 10.6.8 to use iCloud with my new IPhone 4S. Can I update? If so, will it affect existing software? Affect anything else negatively? Is there a downside? thanks

     

    Yes, it likely will affect some software; here's a list of applications and how compliant they are with SL;

    http://snowleopard.wikidot.com

     

    Any PPC apps you're using will need Rosetta; it's installed by default in Leopard, but you may have to select it in the additional installations when installing SL.

     

    Other stuff includes printer and (especially) scanner drivers. Check the vendor for updates, and/or Support Downloads for the latest drivers.

     

    Otherwise, SL is pretty well OK. I wouldn't say it was dramatically better than Leopard though.