Previous 1 2 3 4 5 Next 74 Replies Latest reply: Oct 6, 2013 8:39 PM by Dino Penguino Go to original post Branched to a new discussion.
  • Exitcomestothis Level 1 Level 1 (5 points)

    Well this is very furstrating that this issue is still present in 5.1, as I was hoping this would be the fix.  At this point, I think most proactive thing we can be doing is to get apples attention on this issue.  I've read that the most effective way of doing this is to call Apple directly, and go through the necessary support channels, or to have this issue looked at by an Apple genius, as they have the baility to escilate issues like these.

     

    When talking to Apple about this, it's very important to mention this thread to them, and let them know that this issue is being experienced by more than 1 user.

     

    I will keep this thread updated with my findings and correspondence with Apple.

     

    Good luck everyone!

  • Exitcomestothis Level 1 Level 1 (5 points)

    Over the past few days, I've noticed some other quirks around this issue, unfortunately none of them are good.  First thing I've noticed is that the 4S will not automatically receive a picture message when it's sent.  If someone sends me an MMS message, I have to restart my phone for the message to actually be delivered to my phone.  The interesting thing about this, is that after my phone receives the MMS, cellular data fails to work with the pop-up error "Could not activate cellular data network.".

     

    Looking at field test mode after the MMS has been received, and cell data failing to work, the PDP Context values are in the same state as when an APN profile isn't installed (see my post on page 1 for info on this).  PDP Context 2 has an IP address assigned to it, but Context 0 DOESN"T have an IP (this is the context that lists the APN I'm using), and with no IP address, it's a no brainer why cell data fails to work.

     

    A quick fix for this is to enable airplane mode, wait about 30 seconds, and then disable airplane mode.  Once this is done, Context 0 HAS an IP address, then low and behold, cell data miracuously works!

     

    What led to this discovery was a battery drain issue.  I'd noticed one day that the phones battery was draining at an alarming rate, about 1% every 5mins.  This was highly unusual, as I'd never had this issue since I'd owned the phone.  I don't have any push notifications, location grabbing apps, or any downloads going, so I closed EVERY app that was running, but the battery continued to drain.  So, as a last resort, I rebooted the phone.  Upon the phone starting up again, I was greeted with 5 picture messages, one right after the other, leaving me with no cell data.  After this, battery life returned to normal.

     

    It seems as if the phone was continually trying to download the MMS messages, but was failing (probably due to no IP for context 2), and was eating up battery life trying to do so.  I wonder if this is possibly related to the "batterygate" issue that's plaguing some 4S owners?

     

    APPLE PLEASE FIX THIS ISSUE!

  • Tragopogon Level 1 Level 1 (5 points)

    I also have a 4S (unlocked version) and my experience with this issue has been nearly identical- rapid battery drain and not receiving SMS/MMS/iMessage messages sent to my phone (push notifications were never affected).  Even with the phone on standby, the battery was draining way too fast.  As I'm using an AT&T GoPhone account, I'm using an APN for wap.cingular.com.

     

    I tried closing all open apps then hard/soft resetting the phone, which did nothing to solve the problem.  As my actual time using the phone was only about an hour a day, I thought the reason might be some program preventing the phone from sleeping.  Looking at the standby/usage counters, I noticed both times increasing at the same time which didn't make sense- a phone that is being used isn't in standby and vice versa.  I waited on that screen and actually watched standby and usage click up at the same time.  AppleCare suggested the problem was merely the usage counters getting 'confused' and suggested letting the phone fully recharge in order to reset them.  It did indeed fix the counter problem for a bit, but within a few hours (at most maybe half a day), they'd be increasing at the same time again.  Full charge had no effect on the rapid battery drain.

     

    Still convinced something was something preventing the phone from sleeping, I installed a console log viewing app to see if I could find out what might be responsible.  Lo and behold, the message

     

    CommCenter[17] <Notice> MessageCenterModel is telling PDP context 2 to go active.

     

    kept popping up repeatedly, even during times I had the phone in standby.  I haven't paid too close attention to it, but it seems this chain of notices is preceded by a console message that says

     

    CommCenter[17] <Error?: Error (204) activating PDP context 2 that supports types 4: ???, last_auto_trigger: [no]

     

    If I hadn't used the phone for half a day, there would be literally pages and pages of the 'PDP context 2' message, every 30 seconds or so.  After some digging around in field test mode (*3001#12345#*), I realized the message had to do with my data connection, so I tried uninstalling my APN for wap.cingular.com.  Problem fixed- the 'PDP context 2 notices' instantly stopped coming, and a backlog of undelivered messages popped up in my phone.  Great, except now I had no cellular data access.  Reinstalling the APN fixed that, but now I'm in a situation where the phone will work great with my APN for about a day or so, then at some point those console notices start up again and battery life and message delivery goes out the window.  I've relied on uninstalling/reinstalling my APN- but I'm going to try the airplane mode trick to see if it works.

     

    My next thought is to contact AppleCare, though I'm a little nervous seeing other's experiences so far.  For me, this issue isn't a dealbreaker (yet), but it is a major pain to have to keep flipping my settings after noticing my battery life going down- and unfortunately I don't see that I've been missing messages until after I reinstall the APN!

  • infamous12550 Level 1 Level 1 (0 points)

    So I am running an iPhone 4s on IOS 5.0.1 with Verizon service, I was having the same issue & I wound up figuring it out last night after days of calls & visits to Verizon & Apple.  What was causing the issue on my phone was restoring from a back up of a previous 3GS (jailbroken & unlocked).  I wiped my 4S clean in settings, then restored it as a new iPhone in iTunes & only used my Cloud for contacts & camera roll.  If you try to restore from cloud after the wipe of your phone you will have the same issues.  You need the iTunes software directly from your mac, or PC.  My mms works perfectly.  Hope this helps anyone still having the issue.

  • henwy Level 1 Level 1 (0 points)

    I am having the same issue. MMS works fine with no APN profile installed but once a profile is added MMS does not work. Removing the APN profile returns functionality of MMS

  • Exitcomestothis Level 1 Level 1 (5 points)

    The only way this issue is going to get resolved is to bring it to apple's attention.  Unfortunately, the best way to bring it to their attention is to call Apple care, and complain about the issue.  Additionally, it doesn't hurt to make a genius bar appt, and bring this to their attention as well.  I'll be stopping by our local Apple store to do this very thing later tonight.

  • Tragopogon Level 1 Level 1 (5 points)

    I'm glad others here are having this issue when using an APN that duplicates their default "official" network settings- though apologetic, the AppleCare rep I spoke to today said escalating my complaint wouldn't get any further as GoPhone is an unsupported carrier: were I using a supported plan, they would escalate it.  Of course this could have nothing to do with my using GoPhone, but I can understand why Apple isn't going to chase something they think rightly or otherwise is due to factors outside their control. 

     

    Over the course of my conversation, I did recall that AT&T's regular post-paid service plans do have a specific option for iPhone 4S data- which makes me wonder if cellular data support for the various PDP contexts is something that has to be enabled on the carrier's side. 

     

    Another possibility is that in my system log there are occasionally error messages saying there are PDP context 0 activation errors.  Interestingly, there is also a message that says

     

    ... CommCenter Throttling PDP context activation on context [0] after 3 activation errors. Next timer fire: 347486551.827428 [now: 347486311.827459]

     

    When PDP context 2 has an activation error however, it keeps retrying at 30 second intervals until I uninstall my APN as I noted in my other post.  I wonder if there's a setting in the APN file that allows one to adjust the retry threshold for PDP 2 so it throttles back retries after a certain number of unsuccessful attempts?

  • Tragopogon Level 1 Level 1 (5 points)

    So, some updated news.  After speaking with GoPhone customer support which was of little use, I was eventually directed to contact AT&T's tier 2 tech support (866-246-7344).  On their website, AT&T has some help documentation alluding to different services being available through different APNs- not surprising as they have separate postpaid iPhone 4, iPhone4S, Blackberry etc. plans.  However according to the tech support person I spoke with, wap.cingular only supports one PDP context at a time which would explain why the PDP context 2 activation fails and the absence of an IPv4 address for it in field test mode.

     

    Why trying to open PDP context 2 without ever giving up would be a specific problem to the 4S/iOS 5.0.1 I have no idea.  The annoying thing is that the phone seems perfectly happy without that second PDP context.  It would be great if there is a way to have it simply not try to make the extra connection.

     

    I'm wondering if someone with a contract AT&T or other provider GSM 4S using APN-less data can go in to field test mode and confirm whether or not they have IP addresses for more than one PDP context?  Perhaps this could shed some light on whether or not that second context is truly needed/used or if there's possibly some default configuration behavior for AT&T or supported networks that accounts for and accordingly limits the number of reconnect attempts (long shot)? 

  • Exitcomestothis Level 1 Level 1 (5 points)

    I can test this later this evening with a friend that has an iPhone 4 with ATT.  Just to confirm what I'll be testing, we need to verify if both PDP Context 0 (the one that cell data goes through), and PDP Context 2 (the one that MMS wants to use) both have IP addresses when using the default APN that the 4S is set to?

     

    Another good question is why does the 4S have 4 PDP Context's, but the 3G,3GS,4 only have 1?

  • Iphone4s304 Level 1 Level 1 (0 points)

    Geezus there's quite a few people having this problem including myself

    Very irritating. Only Internet with apn profile installed no mms. Uninstall

    Apn profile and immediately it starts to work again.

    I guess we have to choose one or the other till someone(apple)

    Figures this out. Had the 4,I was so excited to get the 4s. My job requires

    a lot of mms sending and This *****. No way to edit apns or turn off 3G ***** to.

    I always have to find free wifi while I'm out to install

    Unlockit.co.nz so I can get Internet to work. Praying I'm not missing any pics

    Coming in or needing to be sent.

    ***?

  • Exitcomestothis Level 1 Level 1 (5 points)

    Has anyone been able to test whether this issue is still present in beta 3 of ios 5.1?

  • onecount Level 1 Level 1 (0 points)

    I just tested beta 3. Unfortunately, the problem still there.

  • Exitcomestothis Level 1 Level 1 (5 points)

    Well, that's disappointing. The APN that your using with your phone, do you know if it's able to support multiple PDP Contexts? I'm not sure how/if it's possible to allow our private APN to do this, as it seems the real root of the problem is the APNs inability to allow multiple contexts.

  • mikesoul Level 1 Level 1 (0 points)

    Yes yes yes, just having moved into iphone 4S  joy from an old telstra blue tick country phone... i too am having no luck sending MMS photos with SMS. i am on telstra next G '3G'.  just spent 1 hour on phone with telstra, no luck. they say all is good at their end. Just read all these posts above and have tried sending with 'MOBILE DATA NETWORK APN taken off and still no luck! I do however get MMS from a friends iphone 4.... any clues, any updates...? Live in the country so it is difficult to get into an apple place... hopeful

  • onecount Level 1 Level 1 (0 points)

    yes, mikesoul, this is something we are all trying to figure out. It happens in places around the world, I have trouble believing that it is APN problem everywhere. Ok, so the iphone4S supports mutiple ports to have multiple concurrent IP addresses for multiple concurrent PDP sessions. This is new for the 4S, no iphone had this before. Now, we are saying that the APN is apparently unable to secure a second IP address (for a second concurrent PDP session) to the same client (iphone4S device). But in all settings I have seen, the cellular data APN and the MMS APN are the same.

    If this is the case, then how come the commercial (with contract) AT&T iPhone4S does not have this issue? I do have a commercial AT&T iphone4S with contract. I guess I need to execute this field test people have been talking about. So, how do I activate and de-activate this field test mode and where do I see the log?

    Finally, if the iphone4S is going to work this way, maybe Apple should provide the ability to set MMS APN from the Iphone Configuration Utility as well.