Previous 1 2 3 4 5 Next 74 Replies Latest reply: Oct 6, 2013 8:39 PM by Dino Penguino Go to original post Branched to a new discussion.
  • macCrucial Level 1 (0 points)

    Just out of curiosity, are you on a standard consumer plan, with the 'iPhone' Unlimited Data plan? I only ask this because I am on an unlimited smartphone plan, but not the iPhone plan, which causes problems.

  • breebauer1 Level 1 (0 points)

    I'm on the 4S unlimited data plan.

  • macCrucial Level 1 (0 points)

    Did you install a data profile? If so, why did you have to? The profile should automatically install from AT&T, if you have to manually install it then you will have problems.

  • onecount Level 1 (0 points)

    as I understand it, the MMS issue is resolved in iOS 5.1 that became commercially available last Wednesday. Upgrade to 5.1 and it should work. It worked for me; I installed an APN profile and MMS worked this time fine (with iOS 5.1 on the 4S device).

  • macCrucial Level 1 (0 points)

    Are you on AT&T?

  • onecount Level 1 (0 points)

    Yes, I am. If you look at other, older posts from me, I have a regular, commercial ATT iPhone4S device, purchased from ATT.

  • breebauer1 Level 1 (0 points)

    I'm also on AT&T- phone also purchased from AT&T.

    I tried installing profiles since nothing else worked.

    But they didn't work either.

  • macCrucial Level 1 (0 points)

    I'm curious why you guys were manually installing profiles to begin with?

  • BYY Level 1 (0 points)

    the main problem apple does not know telecom.

    mms uses cellular data network for sending and receiving mms.

    if your cellular data is off, you can not receive or send.(assuming correct apn is configured by apple)

    turn on your cellular data and try again. but how you will know whne you will receive mms, you can not keep the cellular data always on! this is the problem.


    solution was so easy from apple but they missed it even on 5.1.

    one toggle to swithc between 3G only, dual, GSM only. but his toggle should not effect the mms related setting.

    another toggle for cellular data on/off.

    when the mms is setted as on from messaging setting, even the cellular data is off, mms APN should be allowed.

    but as apple does not have enough telco experience, they can not think this!!!!

    similar problem for video call via cellular data network. not supported.

  • BigKev80 Level 1 (0 points)

    I myself have tried numerous methods to fix this problem. Installing the profile gives it an hour fix if that. I had to keep uninstalling and reinstalling to send pics. I finally gave up then today I looked on here and read where someone deleted the profile and used wap.cingular and it worked. I tried that still no luck with either mms or data. So all I did is go settings>general>cellular data network and changed both apn's to AT&T.mvno. Worked for me and hope it works for you.

  • BigKev80 Level 1 (0 points)

    Att.mvno. Sorry

  • PSMac Level 1 (0 points)

    There seems to a lot of folks out there with the same issue, and it seems to me this is a service that we pay for, no matter the carrier. Well if I am only getting half the service no matter who's fault it is (Apple/carrier) shouldn't I only have to pay at the very least half price for the service? I think this is something we should all start demanding, it may force someone (ie the carries) to force Apple (if this issue is a IOS issue) to fix it a little faster. Unfortunately if this were Apple's only problem, we would not be hearing so much about Apple's sub par product quality across the board. Apple appears to becoming the very thing they supposedly never wanted to be. A money hungry conglomerate that pumps out sub par product for outlandish prices, only to fail to stand behind it, or deny the blatently obvious flaws they are aware of.

  • mreen16 Level 1 (0 points)

    It appears this is an intentional "feature" of the iPhone4s, as a data plan must be turned on to receive photos:


    Device RequirediOS RequiredConnectivity RequiredRecipient Types AllowedContent Types Allowed
    SMSiPhone1.0 and laterCellularPhone numberText only
    MMSiPhone 3G and later3.1 and laterCellular dataPhone numberText, audio1, photos, and video
    iMessageiPhone, iPad,               or iPod touch5.0 and laterCellular data or Wi-FiPhone number or  email addressText, audio1, photos, and video



  • Lost in Texas Level 1 (0 points)

    Getting MMS to work with PureTalk ......

    After a little searching and trying things out ......

    Here is how to get the iPhone 4S to do MMS with IOS 6.0 on PureTalk Network

    (it may also enable iMessage but not sure yet.)


    Get a T-Mobile Sim card (doesn't have to be an active account).......(doesn't work with AT&T, I tried)

    1.) A T-mobile micro sim card or cut one down to fit.

    2.) Start iPhone and let it boot up on the PureTalk network. Then take out the PureTalk sim card

    3.) Place the T-mobile sim card in and let it connect to their network. It will say No Service but that's OK.

    4.) Under Settings>General and Cellular there isa  Cellular Data option

    5.) Under Cellular Data you will now see fields for Data APN and MMS that wasn't there before with the PureTalk sim.

    6.) At this point double hit home button and then at the bottom will be some app icons. Open Notes or some other app. Which one doesn't matter.

    7.) Then take out T-mobile sim and place the PureTalk sim card back into the phone. (Leave the phone on when doing this)

    8.) Right away, double hit Home key and pick Settings icon at the bottom to go back into General>Cellular

    9.) Turn OFF Cellular Data and then back on.


    10.) There will now be visible the APN settings. Scroll down to the Data APN and MMS settings. The iPhone 4S will have connected to Straight Talk by now. Then Enter in this info below in the correct fields:

    ..................Check for Typos !!

    11. When done entering, go back out of the Cellular settings to General and then the Home screen. That should do it. It might take 2 tries at this, altho it only took one for me.

    Remember this for PureTalkUSA.


    - Under Cellular Data Option

      APN: att.mvno




    - Under MMS Option

      APN: att.mvno 




      MMS Proxy:

      MMS Max Message Size: 

      MMS UA Prof URL: 

    This worked for me as I had a T-Mobile sim card left over from an old phone that I cut down.

    The APN changer doesn't make MMS work except to stick in a Profile that makes the iPhone work otherwise. If there is a Profile APN, delete it.

    Evidently the iPhone 4S specifically (and maybe the iPhone 5) has this issue with off brand carriers. Straight Talk has the same problem and I took some of their directions for fixing this and used the PureTalk settings.

  • Dino Penguino Level 1 (0 points)

    Thank you, Lost!


    There are dozens of MMS fixes for various MVNO's, and each of them has *slightly* different procedures. I tried a bunch of them, but yours was the only one that worked! Thank you so very much---I was pulling my hair out with this one!


    I was trying to configure with RedPocket. I had the correct settings, but the settings would disappear, or revert back to the previous settings, or revert to "phone" (under APN) when I clicked to enter test into the next field.


    Other RedPocket can get the configurations settings at:


    ...but you probably already knew that. The trick is being able to enter those settings.


    Thanks again!


Previous 1 2 3 4 5 Next