9 Replies Latest reply: Nov 25, 2011 6:12 PM by baltwo
bruckner7th Level 1 Level 1 (10 points)

In all previous OSs I've been able drag items to the Trash, or select an item and press Command-Delete to move it to the Trash WITHOUT deleting it. That is, the item would be moved to the Trash can, the Trash icon would then appear to "have something inside it," and that item or items could remain there indefinitely, be moved out of the Trash or even returned to their original location if "undone" immediately.


Currently, on my iMac running Lion, either dragging an item to the Trash, or selecting the item and choosing Command-Delete, results in this message: "Are you sure you want to delete [name of item]? This item will be deleted immediately. You can't undo this action."


I've looked for a Trash Can preference to change this behavior and searched Help and the Knowledge base and found nothing I can do to alter this behavior. Perhaps there's a Finder plist or Trash Can plist that needs to be deleted?

iMac, Mac OS X (10.7.2)
  • alexbird Level 4 Level 4 (1,230 points)

    Some files are too big to drag to the trash and have it sit there.  Have you tried a small file?

  • bruckner7th Level 1 Level 1 (10 points)

    Yup. A 4 KB TextEdit file will not be moved to the Trash unless I'm willing to delete it permanently.

  • alexbird Level 4 Level 4 (1,230 points)

    I found this information on another site.  It might have to do with a different version of operating system, but take a read and see if it helps you in any way.


    Files dragged to the Trash "will be deleted immediately" alert

    When dragging files to the Trash from removable media or a shared network volume, it is common for Trash to inform you that the files will be deleted immediately. This appears to have been a design choice due to every writable volume having its own hidden Trash folder. If you ejected the removable media or shared network volume before emptying the Trash, the files you thought were deleted would still be in .Trashes folder at the root (top) level of that volume. Hence Mac OS X immediately deletes files moved to the Trash from removable media and shared network volumes. This also depends upon the firmware of the device informing Mac OS X that it is a removable media device. Some removable storage devices identify themselves as hard drives, meaning that items remain in the .Trashes folder if the removable storage device is ejected before the Trash is emptied and will reappear in the Trash when the device is again connected to your Mac.

    If you are not dragging files from removable media or shared network volumes to the Trash and are informed that files dragged to the Trash "will be deleted immediately," there are three possible causes:

    1. You are either no longer the Owner of your Home folder, do not have Access of Read & Write to such, or both.
    2. Your account's Trash, i.e. your ~/.Trash directory, has been deleted.
    3. You no longer are the owner of your account's Trash.

    To resolve this problem, proceed as follows:

    1. Assure you are the Owner (Mac OS X 10.4 and earlier) and have Access (Mac OS X 10.4 and earlier) or Privilege (Mac OS X 10.5 and later) of Read & Write on your Home folder:
      1. In Finder, press the Command-Shift-H keyboard shortcut. A Finder window opens showing the contents of your Home folder.
      2. Press the Command+I keyboard shortcut. The Info window for your Home folder opens.
      3. Select the Info window.
      4. Open the disclosure triangle for the Ownership & Permissions panel (Mac OS X 10.4 and earlier) or the Sharing & Permissions panel (Mac OS X 10.5 and later) in the Info window.
      5. If using Mac OS X 10.4 or earlier, open the disclosure triangle for the Details panel within the Ownership & Permissions panel.
      6. If you are not listed as Owner (Mac OS X 10.4 and earlier) or under Name (Mac OS X 10.5 or later) or do not have either Access (Mac OS X 10.4 and earlier) or Privilege (Mac OS X 10.5 and later) of Read & Write, then correct these issuesusing the instructions in the "Setting Permissions" Mac Help document corresponding to the version of Mac OS X you are using.
        1. Warning: When using the instructions in the Mac Help document, do not use the Apply to enclosed items option, if available.
        2. Note: Users of Mac OS X 10.5 or later can start up from their Mac OS X Install DVD and use the Reset Home Directory Permissions and ACLsfunction of the Reset Password function of the Utilities menu.
      7. Close the Info window.
      8. Try to place objects in the Trash. If so, the problem is solved: stop here. Otherwise, proceed to the next step.
    2. Verify that your ~/.Trash directory exists:
      1. Open Terminal, located in the Macintosh HD > Applications > Utilities folder.
      2. At the Terminal prompt, type the following command exactly as written:
        1. ls ~/.Trash
      3. Press Return.
      4. If the response contains "No such file or directory" then:
        1. Either log out of your account or restart your Mac.
        2. Log in to your account. You should now be able to add objects to the Trash: stop here.
      5. Otherwise, proceed to the next step.
    3. Empty and recreate your account's Trash.
  • David M Brewer Level 6 Level 6 (9,335 points)

    Go to the Finder in the Menu Bar... Finder Preferences... Advance tab... Uncheck 'Show warning before emptying the Trash'...


    001-Screen Shot 2011-11-24 at 10.09.11 PM copy.png

  • bruckner7th Level 1 Level 1 (10 points)

    No, this has no affect whatsoever. The answer above that is closer to the situation, but didn't solve it for me. It appears I am not the "owner" of my computer! Very odd.

  • bruckner7th Level 1 Level 1 (10 points)

    Your reply is getting close to the situation and hints at some of what's wrong, as I see it. As I mentioned in my reply to David M Brewer, it now appears that I'm not the "owner" of my new computer! If, for example, I select my home folder and choose Get Info, under the Sharing & Permissions heading, the name column doesn't have my admin name at the top of that column, as it does in other instances. Instead I see "Fetching..." as if it's looking for the owner. No name (owner) ever appears, regardless of how long I leave the Info window open. It just continues to say, "Fetching..." The Privilege column states "Read & Write" as it should, but it obviously doesn't recognize me as its owner and administrator. As I see it, I need to take ownership of my root directory, or home folder, or whatever it is. I'd probably need to delve into Terminal or something and I don't have the experience and know-how for that. I may have to carry this to my Apple Store. Phooey.

  • jsd2 Level 5 Level 5 (6,200 points)


    I would run the procedure described in the "No Disk - Lion" tab of the following article:

    Reset home folder permissions

  • bruckner7th Level 1 Level 1 (10 points)

    I will give this a try. Thank you!


    [Off to day-after-Thanksgiving gathering with wife's side of the family now.]