8 Replies Latest reply: Mar 12, 2012 2:54 AM by louisel
sancastelazo Level 1 Level 1 (0 points)

I know that this has been posted several times already, but none of the threads really solve my problem.

 

I live in Mexico, and I have several phone lines with iPhones, and about two weeks ago, the carrier (Iusacell) changed all of the sim cards for new ones, saying that those would work better with the wireless network. After upgrading them, I'm not able to activate iMessage on any of the lines. It says "Waiting for activation..." and it stays like that for a few hours, and then it says "Error".

 

Is there anything I can do?

 

Thanks a lot!!


13-Inch Macbook Pro, Mac OS X (10.7)
  • KiltedTim Level 8 Level 8 (42,330 points)
  • sancastelazo Level 1 Level 1 (0 points)

    I've tried that. They say they have no idea what the problem is. They said to contact apple.

  • eberner Level 1 Level 1 (0 points)

    I received confirmation by a Iusacell customer service representative that Iusacell has blocked iMessages. For me it also stopped working with the old SIM card. According to her Telcel will also block iMessages.

     

    I don't know if this has happen in other countries...

  • McGowanD Level 1 Level 1 (0 points)

    I just had the same problem a minute ago and wound up here looking for solutions. I live is Georgia (USA). I've been using iMessage for a few months now and even used it on the IOS 5 Beta, however all of a sudden it went away. When I went into the settings it just says waiting on activation. Uhh I have no clue what to do. I will be calling apple in the next half hour and I'll get back to you guys if I find a solution.

  • McGowanD Level 1 Level 1 (0 points)

    Success! Just go to iMessage settings. Then receive at. then sign out and re enter your email address. I just messed around with that for a while and it eventually worked.

  • Mel2159 Level 1 Level 1 (0 points)

    I had the same problem.  Nothing here fixed it.  My iMessages used to work, then suddenly stopped and I was not able to sign in iMessages.  After wracking my brain, I remembered disabling FaceTime about the same time my iMessages stopped working.  I went to Settings-General-Restrictions and turned FaceTime back to ON for Allow.  I was automatically signed back in to iMessages.  I really don't like this, as my cheek is always trying to FaceTime everyone I talk to... =/  And no where does it say that FaceTime restrictions also restrict iMessages!

  • Akela011 Level 1 Level 1 (0 points)

    I had the same problem with my iMessage.  I also deactivated the facetime and thats about the same time that it stopped working.  When I went back and reactivated my Facetime I was automaticly prompted to sign into iMessage and Facetime.  Now my iMessage works just fine!  I think that its stupid that the two are connected.

  • louisel Level 1 Level 1 (0 points)

    Okay so after reading through a lot of posts I finally found the solution. I had an error message saying "An error occured activating account. Please try again." and I tried all the solutions posted on other threads with no luck. Finally I thought i'd log onto iTunes and connect my iPhone to see if it needed updating (which it didn't because I did the update 2 days ago). For some reason when I clicked onto my Apple ID to log on it displayed "Your account has been disabled. Please click reset to reset your account". Why my account was disabled in beyond me but I had to change my password. Using my new password I activated Facetime and iMessage - please note that both did continue to display Waiting for activation... until I sent a message to someone - and BOOM it works :-) hope this helps!!