Previous 1 2 3 Next 252 Replies Latest reply: May 14, 2013 10:36 AM by SuperSchatje
Folbo Level 1 (5 points)

I am being frequently warned of my wireless connection to my TC as being 'Interrupted', by frequently I mean every 15 minutes or so.


The TC has been in the same location for two years, my MBP (18 months old) is suffering in all locations around the house, locations where it has always worked in the past etc.


The problems have appeared only over the last few weeks, either since the latest TC firmware upgrade, or the latest Lion patch ... I do not know which to blame !


Any suggestions as to where to look would be good or what to test would be good.


BTW. When I have searched for this in the last few weeks I keep getting hits back to 2009 ... a different OS on different hardware ... is there any simple way of searching these forums, or setting them up so that 'suggestions' do not lead me to old discussions ... it is extremely fustrating and, I would suggest, not nescesary.





Macbook Pro 2010, Mac OS X (10.7.2)
  • LaPastenague Level 8 (48,802 points)

    If the TC is older than 2years, it could be starting to die.. !! Especially the firmware update has triggered a few that were on the edge to go over. If wireless is dying every 15min or so.. is it auto recovering??


    Lion also seems to have many more networking issues, even with the latest patch.. but that is only reading posts here, as I have no computer running lion.


    A couple of things I would do..

    1. Figure out is the issue only wireless connection or the TC.. so connect at least one computer up by ethernet.. and see if it has the same dropout problems. (assuming you don't already).


    2. Set the wireless to manual.. lock the channel and change the 5ghz wireless name.. connect to whichever works better for you but accept for testing you are going to keep things locked to find out if it is wireless channel swapping in the TC.. or band swapping by the airport card in the Mac.


    3. If neither of the above work, see if airport utility actually loses connection to the TC. If it does, is it automatically rediscovering it or do you need to reboot the TC.

  • Adam Albright Level 1 (85 points)

    Do you actually lose connectivity when the message appears?

    We did a firmware update on an Airport Extreme (about 14 months old) with an external USB drive attached, and I'm getting this message all the time now. However the wireless connection continues to work fine and the drive continues to remain accessible, so clicking 'Ignore' keeps things going until the message pops back up again, some time between 5 minutes and an hour later.  I doubt the AEBS was just "about to die" (it's not that old, and isn't having any trouble with connectivity, unless they are just very momentary troubles that I'm not able to notice).   Also, Time Machine backups work fine (i.e., by auto-mounting the drive and dismounting when done, with no errors during backup). I just get the errors periodically when I have the drive mounted through the Finder.


    I'm running Snow Leopard and there haven't been any relevant recent updates, so I know for sure that this was precipitated by a firmware patch to the Airport Extreme.

  • Adam Albright Level 1 (85 points)

    A quick follow-up:  I found that by using the Airport Utility to disconnect all users and then unplug/restart everything, I was able to make the error messages go away (at least, I haven't had one in 9 hours, whereas before they were usually several times an hour, at least).  Since I have an Airport Extreme with an external USB drive, I was also able to disconnect the drive while rebooting and then reconnect it, but I don't know if that part was crucial.  So, although I suspect you probably did already try rebooting the TC, maybe it's worth a shot first using the utility to disconnect all users before hard rebooting it?

  • Cthulhu Level 1 (60 points)

    I have had the same problem since the last firmware update. I am connected to the TC via Ethernet, and I don't actually lose connection when it happens.  Rebooting etc. did nothing for me.


    I have the log sent to a mac over Ethernet, and I don't see anything in OS X's or the TC's log other than a sudden "AFP session from (user)@(ipaddy) closing" then all the madness ensues about afpfs_DoReconnect etc. etc. and it all works fine, meanwhile I see the dialog. Sometimes as often as evey two minutes, sometimes an hour goes by. It's almost as if if the reconnect happens fast enough, nothing happens, and if not, I see the dialog.


    In fact, I have been doing a copy from the drive and seen the dialog, and the copy continued with no issues.


    This is not a case of hardware suddenly starting to die, this is a bug introduced by the latest firmware update, as too many people are seeing this. As a firmware engineer myself, I can't imagine that an update makes things start to die (no disrepect at all to LaPastenague).

  • SBeattie2 Level 1 (85 points)

    I did the firmware update to 7.6 on my 2TB TimeCapsule a few weeks ago and I am frequently seeing this warning.  I believe I am seeing it on every Mac - whether connected wirelessly or wired.  All Macs are currently on Lion 10.7.2.  It does not appear that any connectivity is actually lost - but seems to appear only when the finder has the drive mounted and it seems to appear only after the Mac has been inactive - but not necessarily sleeping - for a period of time.  It also happened once while I was copying my iTunes library to the Time Capsule - wirelessly - and it I believe it appeared at the end of the copy operation or immediately after the copy completed.  The copy was successful.  The TimeCapsule is about a year and a half old.  In the past - (on Snow Leopard) I would receive this warning - once in a great while - and usually only after the Mac had been sleeping for a day or two - or where I had actually done something on my network that might have caused the disconnect.  The warning is now more frequent - I have seen it at least 5 times since the firmware update to 7.6.  The warning never occurs during a Time Machine backup.  I believe this is some type of bug introduced by the 7.6 firmware update.

  • Ray Allen Level 2 (395 points)

    Im getting the same a you only in the last few week. And like you I'm not sure if to bame lion or the TC firmware.


    I also get it with a USB HD on the back of my TC, at first I thought perhaps the HD was the issues but the TC hd and external HD are showing same problem I would assume not the HD's


    sometime I can get it to stay connected for hours, and then I update say my Aperture Vault over to the TC and in mins the connection is dropped.


    I might roll back the FW on the TC at the weekend to try and pin this down, I shall report back.

  • Cthulhu Level 1 (60 points)

    Well, I am on Snow Leopard, so I can confirm this is not a Lion issue. Since the 7.6 upgrade, I have been unable to keep a reliable connection, so I downgraded, and now all is well. All problems are gone. To me, that proves it is a bug introduced by the firmware.


    However, following Adam Albright's advice of using Airport Utility to disconnect all users and then unplug/restart everything worked for at least one Leopard machine (an old TiBook) connected over Ethernet.


    Another thing I noticed is that I have some older PPC machines that watched movies off this drive. After the update, my users (ahem, my kids) complained that video was choppy. Now we are all back to normal.


    I know this is not a helpful comment, but between this, all the Lion issues, and the last update broken S/MIME on my iPhone, I have to wonder if Apple even tries these things anymore before pushing the updates. There seems to be a serious quality control issue in the last 6-8 months.

  • Ray Allen Level 2 (395 points)

    UPDATE: down graded the firmware on the TC and it's been solid. No issues so far.

  • MotoBarsteward Level 1 (0 points)

    Ray Allen, how did you force the downgrade?

  • LaPastenague Level 8 (48,802 points)

    Wrong person but the answer is simple.



    MotoBarsteward wrote:


    Ray Allen, how did you force the downgrade?

    As with most hidden mac dialogues, hold down the option key.. on the main menu bar go to the firmware upload option.. a drop down window will present all the versions available for your model.. if very recent it might only be current and the one before.. on series 1 there are about 6 different firmware. Select the one you want and update.

  • MotoBarsteward Level 1 (0 points)

    Yes, I found this out just after posting. In fact, if you select 'load firmware' without holding the option key, it gives you the choice of uploading the current(latest) or previous. I just reloaded 5.2.1 and, so far, the warnings have gone away. I'm not sure if this is an OSX or TimeCapsule issue. I shall try to report it this weekend.

  • Ray Allen Level 2 (395 points)

    UPDATE: I think it maybe with Lion now.


    After 3 days of solid use on older FW I did get the message again, the connection is not broken, if you click ignore it's carrys on OK.

  • Cthulhu Level 1 (60 points)

    Ray - before you blame Lion, I am on Snow Leopard, and downgrading the firmware fixed it for me 100%. However, it may cause a problem with maintaining wireless connections in Lion.


    Can you try Adam's suggestion of using the Airport Utility to disconnect all users and then unplug/restart the unit? Then, to ensure your wireless stays up, you can use an Applescript or terminal command, whichever you like. To make it insanely easy, I posted a small, really basic Applescript for you here:



    It's a little invisible Applescript that pings every five seconds and seems to keep Lion's wireless alive. You can add it to your Login items if you like and log in and out, or just launch it manually and see if it helps. Note that to quit it, you need to force quit it using Activity Monitor. Open Activity Monitor, search for ping and pingApple, and kill them.

  • Ray Allen Level 2 (395 points)



    I have just applied the "disconnect users and reboot hardware"


    I also downloaded the script, thank you.


    I'm going to not run it now and see how the connection goes after the reboot of my AP setup.


    If I get the problem I will run the script.


    I shall report back



Previous 1 2 3 Next