Previous 1 2 3 4 Next 252 Replies Latest reply: May 14, 2013 10:36 AM by SuperSchatje Go to original post
  • SBeattie2 Level 1 Level 1 (60 points)

    I tried the disconnect all users - powered off TC - it did not solve the problem.  My problem seems to be predominatly that my wired Macs are having this issue more so than my wireless ones.  What seems to trigger the message is when I have a share mounted on the TC - and I do a significant data transfer - either to or from the share in Finder - such as copying my iTunes library or iPhoto library - upon completion of the copy - or shortly thereafter - the Discconect message will pop up.  A Time Machine backup - however - does not seem to cause this problem.  But, once the message pops up - it will continue to pop up periodically (even without any data transfer taking place) and then eventually stops after 6 hours or so.

     

    I have not yet tried downgrading the firmware.  I am not (and was not) having wireless issues either before or after the firmware update (at least that I am aware of).  I am not sure why continuously pinging a web address would resolve this issue - so I did not try that script.

     

    Based on what I observed today - the message seems to occur only after a large copy operation to or from a share on the TC - while the finder has it mounted and while the share is open in finder.

     

    Just out of curiosity - has anyone tried mounting the TC via smb://  vs the default of afp://?  Or - has anyone tried mounting a share on another NAS drive (non TC) via either AFP or SMB to see whether the disconnect message pops up for those drives as well?  I have two other NAS drives (one of which supports AFP) and the other does not.  I will try this tomorrow - and see if I can get the message to pop up.  If it does - that would indicate that the problem is Lion and not necessarily the TC firmware update.  I will report back in a day or so - and possibly try the firmware downgrade.

     

    I included a screen shot of the message that I get - to ensure we are all talking about the same issue.

     

    Screen Shot 2011-12-05 at 10.06.06 AM.png

     

    ~Scott

  • LaPastenague Level 8 Level 8 (44,125 points)

    I am now getting the same server interrupted Scott and that is on SL.. and it only started since I upgraded firmware on the TC, as I was happy to let other people do the guinea pig stuff. Interesting first few days after the upgrade it was ok, but is now regular like every few minutes.. and is painful in the extreme.. especially as finder still has the TC listed. And I can easily access it. TC is listed in the ARP table and has not changed IP or anything as it is in bridge.

     

    The log from the TC is full of disconnections. And the connection is ethernet.

    Dec 06 20:50:29    Severity:5    AFP session from  H@192.168.2.78 closing.

    Dec 06 20:52:30    Severity:5    AFP login OK from  H@192.168.2.78.

    Dec 06 20:52:30    Severity:5    AFP session from  H@192.168.2.78 closing.

    Dec 06 20:54:30    Severity:5    AFP login OK from  H@192.168.2.78.

    Dec 06 20:54:30    Severity:5    AFP session from  H@192.168.2.78 closing.

    Dec 06 20:56:31    Severity:5    AFP login OK from  H@192.168.2.78.

    Dec 06 20:56:31    Severity:5    AFP session from  H@192.168.2.78 closing.

    Dec 06 20:57:56    Severity:5    AFP login OK from  H@192.168.2.78.

    Dec 06 20:58:47    Severity:5    AFP session from  H@192.168.2.78 closing.

     

    I have tried a few different things but no luck.. what is difficult is this happened on another TC I had.. two series 3 1TB and I could never figure out the error but when I put another one in, it never gave me trouble so I forgot about it. So this issue may have been in the background for a while.. but I am pretty well convinced I need to go back to earlier firmware.

     

    I have another NAS which is SMB, no issues with it. It is purely the TC.

     

    I am going to return to older firmware and if the TC flashes for updates again it can go to blazes.

  • Ray Allen Level 2 Level 2 (395 points)

    This is the same message as me, the pop up is the same as the screen grab.

  • SBeattie2 Level 1 Level 1 (60 points)

    I see exactly the same login/closing messages in my log - on or around the time of the Server Disconnect popup as well as constantly throughout the day.  I am starting to wonder if these are normal - and not necessarily the "cause" of the disconnect message. I believe that I also see a "key rotation" message in my log as well. I will still test with my other drives (as well as SMB on the time capsule - just out of curiosity).

  • Cthulhu Level 1 Level 1 (60 points)

    Scott, I think if you downgrade the firmware you will be much happier, but for me I also disconnected all users and rebooted after the downgrade.

     

    The script will do nothing for you, as you are connected via Ethernet. For Lion users connected via WiFi, it seems to solve the intermitent WiFi issue, which can also cause these interrupted connections. WiFi users on Lion should try it.

     

    I can also confirm even after the downgrade I still see the same closing/login messages in my log, but it does not seem to impact anything, and I do not see the dialog with the older firmware.

  • Adam Albright Level 1 Level 1 (85 points)

    I've also downgraded now— it turns out that rebooting alone was at best a temporary solution, since the error (yes, same as the image above) returned after a couple days, and was as frequent as before.  I reverted to the previous firmware, and so far everything has been fine.  (I'm running Snow Leopard)

    It sounds like a general problem, since I have an Airport Extreme, not a TC, but the recent firmate update did exactly the same thing to it...

  • SBeattie2 Level 1 Level 1 (60 points)

    Okay - Here are my results of extensive testing today - repeatedly copying my iTunes and iPhoto Libraries to the TimeCapsule (SMB and AFP) , to a D-Link DNS-323 NAS (SMB only) and to a Western Digital MyBook Live 3-TB NAS (AFP and SMB).

     

    I had these copies going in all directions - two different Macs (iMac and MacBook Pro) - wired - all day long - but only to shares mounted via SMB - to my various NAS drives including the Time Capsule.  There was not one occurence of the Disconnect popup during 6 hours or so of copying (iTunes library about 30 gig - and iPhoto about 12 gig).  I disabled Time Machine backup during this testing to avoid having it confuse the test results.

     

    In the middle of the afternoon the - I switched over to AFP mounted shares - I did an AFP mount on the MacBook Pro to the WD MyBook Live drive - copied the iPhoto library over to it.  No popup.  Then on the iMac - I did an AFP mount to the Time Capsule and copied the iPhoto library to the Time Capsule.  Copy was successful - but within two or three minutes of the copy completing - the Disconnect warning dialogue popped up on the iMac (not the MacBook Pro) and continued popping up at the following times:  14:58, 15:31, 15:50, 16:00, 16:17, 17:48, 18:17 and 18:57.  No messages in the TC log.  No active transfers to or from the TC during the subsequent popups.  Currently I have logging level set to 6 (Info) - now setting it to 7 (Debug) and will try again tomorrow.

     

    Obviously my test results are pointing to the issue being with the Time Capsule and/or the firmware upgrade (since SMB all day long did not have an issue on the TC or the DNS-323 - with constant data transfer occuring over a wired connection - as well as AFP and SMB working fine to the WD MyBook Live).

     

    I believe that Apple made some type of change in the AFP specification starting around 10.6.8 (Snow Leopard).  Not exactly sure what they changes were - but could be a factor here - meaning that Macs on the latest (and last) version of Snow Leopard may be seeing the impact of the AFP changes.

     

    My MacBook Pro and MacBook Air are typically connected wirelessly and usually through the TC vs my other access points.  This week I have the MacBook Pro wired (with Wifi disabled).  I did initially notice some wireless issues with Lion - but those seem to have disappeared with OS X 10.7.2 - or at least I am not noticing.

     

    I believe I now know how to reproduce the Disconnect popup - and hopefully logging level 7 may show something when the Popup occurs again.

     

    ~Scott

  • SBeattie2 Level 1 Level 1 (60 points)

    I am assuming that reverting to a previous version of the firmware is going to result in the LED continuously flashing orange beause of the detection of an available update?  Can anyone confirm this?  If I remember correctly - I believe the Time Capsule forced me to upgrade to the 7.6 firmware and wouldn't allow me to do much until I performed the upgrade.

  • LaPastenague Level 8 Level 8 (44,125 points)

    Mine has been back to earlier version of the firmware for a day now..

    No popups.. no server disconnected messages.. and so far still green..

    Most messages you can just turn off.. perhaps after you upgrade and downgrade again it will leave you alone.

     

    So with your testing it is pretty conclusive Apple bombed on this firmware.

  • SBeattie2 Level 1 Level 1 (60 points)

    That is good to know - that the LED is staying green after downgrading.  I haven't decided to go back to the previous version just yet.  I did not have much time to work on this today - but I did get the pop up - one more time today - on the same iMac - and nothing much was happening - as it was sleeping most of the day - and Time Machine backups are disabled.

     

    I checked the log again (this time with logging set to severity level 7 (debug) - and still no additional info in the log.  The only messages I see are the same level 5 messages that I always see.  I was really expecting to see a lot more detail on other operations.

     

    It should be noted - that the TC is only generating the popup when a share is mounted via AFP (the default) and not via SMB - at least in my case.  I wonder if Apple is monitoring theses thread and is aware of the problem?

     

    Since I have Apple Care - I can probably log a support incident - however - that can prove to be time-consuming.  I will update this thread when I have more to report.

     

    ~Scott

  • LaPastenague Level 8 Level 8 (44,125 points)

    In the menu called options.. just type options into find a setting.. turn off check for firmware updates.. sigh.. It is set to one week by default.. that is why it blink..darm hidden options.

  • Jesper Wille Level 1 Level 1 (5 points)

    Thanks all for an informative thread - I had this issue too, what with a log filled with AFP sessions closing and opening every two minutes or so. I've even heard the drive spinning up at night, after I'd logged off, shut down the laptop and gone to bed.

     

    Tried switching channels, which put off the next occurance about an hour and a half, after which the every-two-minutes rate was back (really weird if you think about it, this change in behavior caused by a channel switch), and then I downgraded to 7.5.2 and now I have close to 12 hours without AFP incident - just normal rotation of TKIP key once and clock syncronisation every hour.

     

    So, for my money: - the recent firmware version is bugged.

     

    Thanks again.

     

     

  • coopsinbristol Level 1 Level 1 (0 points)

    I am also experiencing the same issue and have regularly seen the screen grab since the new firmware release.

     

    I have just downgraded as suggested and hope that this will do the trick.

     

    Thank you to everone who has provided information on this issue.

     

    Hopefully Apple will correct the position ASAP.

  • Ray Allen Level 2 Level 2 (395 points)

    OK after doing the disconnect and reboot, the message stayed away for five days. But it come back.

     

    To reacap I downgraded the firmware after I was getting the message with the new firmware.

     

    So it seems the firmware does not matter.

     

    It's starting to look like a Lion issue for me.

  • Cthulhu Level 1 Level 1 (60 points)

    Ray - Remind us if you are connected via Ethernet or WiFi. If your are using WiFi, you may be seeing the Lion WiFi bug instead of or in addition to the firmware bug.

Previous 1 2 3 4 Next