Previous 1 2 3 4 5 Next 252 Replies Latest reply: May 14, 2013 10:36 AM by SuperSchatje Go to original post
  • Ray Allen Level 2 Level 2 (395 points)

    Hi,

     

    Using WiFi. 10.7.2

     

    I have two TC and one AE, all have HD's attached and the issue seem to start when I did the FM in all airport, aftr downgrading it seemed to go away. But it did show again after a few days.

     

    So last night I put the airports back up to latest FW and tried the disconnect method.

     

    I have drives mounthed OK at the moment, I shall see how that goes.

     

    If I get chance I shall run a cable and try with Ethernet to try and pin point if Lion WiFi bug.

  • SBeattie2 Level 1 Level 1 (60 points)

    I see the firmware bug via Ethernet moreso than Wifi. But it does occur on both. On Ethernet I can almost always produce the pop up disconnect warning by doing the following:  mount a share on the time capsule (ago). Drag and drop either your iTunes library or iPhoto library to the share. As long as it is a large amount of data. Shortly after the copy completes - the disconnect popup will appear. It may even appear at the tail end of the copy. It will then continue to appear periodically for a number of hours - provided the share is mounted.

     

    Also - I am not seeing the Lion wifi bug on any of my 3 macs. In the very beginning after installing Lion 7.0.- I believe I experienced some wifi instability - but after the 7.1 or possibly after 7.2 - the wifi connection seems to be quite stable.

  • SBeattie2 Level 1 Level 1 (60 points)

    Correction to typo in previous post. (ago) should have been (AFP).

  • Ray Allen Level 2 Level 2 (395 points)

    OK connected with ethernet and set my machine copying my aperture lib,

     

    Got home and the connection was lost, no message but the mounted volume was not on desktop, I was unable to see the TC drives at all, in fact I was not able to see the TC with Airport utility, rebotted TC and it come back up.

     

    The backup seemed to copy about 200 gb or so be fore it dropped.

     

    Going to repeat again over night.

     

    I shall report back.

  • SBeattie2 Level 1 Level 1 (60 points)

    Interesting - when I do the copy my iTunes library is only about 22 Gig.  Your copy stopped after 200 gig.  When I get the failure - it is almost always several minutes after the copy completes.  I don't lose the drive icon on the desktop and the TC seems to be active and mountable when I go to check it after the popup warning occurs.  Even the finder window that was open at the time the popup occurred seem to be responsive.  Other than the fact that the popup is displayed - I would not have any other indication that connectivity to the drive has been "temporarily" lost - and I never have to do anything to regain connnectivy.

     

    The problem never occurs during a Time Machine backup.  TM Backup always completes successfully and unmounts the TC immediately after.  I am wondering if the immediate unmount of the the TC after TM backup is what is avoiding the popup disconnect warning?  Just a thought.

     

    Also I had shares mounted only via SMB - for several days - and never once saw the popup.  It has to be something with recent changes to AFP combined with some behavioral change introduced on the Time Capsule by the latest firmware update.  Additionally - I can mount a share (via AFP) to my WD MyBook Live - and I don't see the popup - under any circumstance (I believe I previously reported this a few days back).

     

    ~Scott

  • Ray Allen Level 2 Level 2 (395 points)

    dont actually use my TC as a TM backup point (1 TB TC is not big enough)

     

    As of this morninng the copy is still going. My Aperture Lib is just over 600GB and my iTunes is around 1.2TB

     

    So far so good.... I shall report back over the weekend as I'm going to try and copy my iTunes folder, that will take some time to move if completes OK.

  • Tuzarupa Level 1 Level 1 (0 points)

    I went back to firmware v. 7.5.2 and the message disappeared. A few days later it reappeared. When I went to the AP Utility I saw that my AE had (magically since I am the only Admin) set itself back to v 7.6. No kidding.

    It's the AP firmware update as I had no issues with Lion 10.7.2 (or previous itterations) prior to the Airport firmware update.

    I have a WD USB external HD connected to my AE. IT does have "nergy saving" features so I am going to try connecting an "always on" USB drive. This may reveal if the sleep feature of the external drive is triggering the message.

  • SBeattie2 Level 1 Level 1 (60 points)

    I am about to go back to 7.5.2 - however - I have some additional troubleshooting results to report.  What I am noticing is that the problem surfaces after a significant amount of data - such as >10 gig - has been transferred to or from the time capsule via an AFP-mounted share (the default).  Within a few minutes after the transfer completes - the time capsule attempts to go to sleep and spin down the drive.  If I watch the console for a few minutes after the transfer - I can see where the TC shuts down - and right at that point - the disconnect window pops up.  There are also some unusal (and slightly concerning) message that appear in the console referencing an "invalid volume" or something like that.  So it does seem to be related to the time capsule going to sleep.

     

    If I watch the console at the end of a time machine backup to the time capsule - I see the same strange invalid volume errors - but I don't get the disconnect popup - because the Time Machine backup unmounts the TC as soon as the backup completes - but before the TC reaches its inactivity limit (of several minutes) and goes to sleep.

     

    To complicate this a little bit further - I have also been experimenting with a WD MyBook Live NAS drive - which supports AFP as well as Time Machine backups.  A couple of weeks ago I had been testing for the disconnect popup by copying large amounts of data to the MyBook Live drive via an AFP share - and I was not receiving the disconnect popup at all.  Recently WD provided a firmware update to the MyBook Live drive - and now - if I copy the same large amount of data from the TimeCapsule to the MyBook Live drive (or vice-versa) I now get both the Time Capsule share as well as the MyBook Live drive share listed in the diconnect popup.  So this is telling me that it is not just the TimeCapsule having this issue - because I am now seeing the issue with the MyBook Live drive.  The important thing to note here is that when I see the popup for the MyBook Live - it is only when the tiem caspule and the MyBook Live have done a large data transfer from or to each other.  The MyBook Live drive does not go to sleep as frequently as the Time Capsul does.

     

    I will try again - with just the WD MyBook Live drive to see if I can get the pop up when referencing only the WD MyBook Live in a large data transfer - but without the Time Capsule in the mix.

     

    I have seen the problem on Lion - as well as on Snow Leopard 10.6.8.  I believe that 10.6.8 was when Apple introuduced changes in their AFP implementation.

     

    ~Scott

  • Folbo Level 1 Level 1 (0 points)

    Hmmm ...

     

    In addition to my TC, I have two synology servers, an old CS407 (2007) and a DJ210 (2010!). Synology has recently released yet another DSM update. The ar effectively OS updates for the server, and are generally excellent in their aded facilities.

     

    OK ... to get to the point ... recently Synology has stopped upgrading the 2007 box with all the latest features ... and one of the casualties is using it as a TM backsup target. I seem to remember that one of the reasons cited was that Apple have changed the way that AFP works ... to increase security or something ... and the change is a Lion change ...

  • ashforma Level 1 Level 1 (0 points)

    I am having the same problem as the rest of the post chain, regular appearances of "Server Connection Interrupted".

    My occurrence is slightly different. I have three Time Capsules, on my network, they are all wireless off, connected to a Cisco switch via Ethernet. There is an Airport Extreme Base Station and two Airport Express. All TCs and the AEBS and AEs were purchased within the last 6 months of 2011.

     

    Previous to the "Server Connection Interrupted" messages appearing I used a Cisco RVS4000 to manage DHCP, and firewall etc on the network. The AE was used as a WAP. In this config, I never saw the "Server Connection Interrupted".

     

    After upgrading my DSL account to get higher bandwidth I removed the Cisco device and reconfigured the Airport Extreme to be a full feature WAP, router etc. The firmware on all Tcs and the AE was 7.5.2, in this config the "Server Connection Interrupted" didn't appear. I upgraded the TCs and AE to the latest firmware, 7.6, and the warning boxes started appearing regularly.

     

    The "Server Connection Interrupted" warning only seems to appear on TCs that are not being accessed or have not been accessed for a period of time, I am not sure how long that period is. I would look at the WAPA Group Key Timeout on the Wireless Network Options tab of the AE first, the default is 1 hour. It would be interesting to note whether the appearance of the dialogue "Server Connection Interrupted" dialogue is around the time the Group Key changes?

     

    Perhaps the DHCP server in the AE is treating a drive as disconnected because it is not responding properly when the AE polls it after the key has changed.

    It could also be that the 7.6 firmware on the AEBS is not managing the polling of attached but inactive devices properly. I have downgraded the firmware to 7.5.2 on one of the TCs that regularly report the "Server Connection Interrupted" error and the AEBS. So far, the two TCs running firmware 7.6 are reporting disconnected periodically, the TC that was downgraded to 7.5.2 has not!

     

    As I changed the firmware on a TC and the AEBS at the same time it is not possible to pin the problem to the AEBS firmware or the TC, but I am going on the assumption that it is the TC and am downgrading all three TCs to 7.5.2.

     

    M

  • SBeattie2 Level 1 Level 1 (60 points)

    My TC is acting as a bridge.  It is connected to my Netgear gigabit switch via a wired ethernet connection.  The netgear switch is connected to a Linksys WRVS4400N Wireless gigabit router.

     

    My wired Macs are connected to the Netgear gigabit switch as well.  My wireless Macs predominantly connect to the 5GHz access point on the TC and slower devices such as iPhone connect to the 2.4GHz access point on the TC.  Wireless devices on my network can connect to any of my 4 access points.  Regardless of how any of my Macs connect to the TC (wired or wireless) I still get the popup dialogue - but with less frequency in a wireless scenario.

     

    If I factor AFP out of the picture - (by mounting a share on TC via smb://) the popup never occurrs.  The problem seems to be related to a combination of AFP, Lion and something in the 7.6 firmware on TC.

     

    I am going to try disabling the wireless access points on the Time Capsule to see if this changes the behavior of the popup.  I will report back with the results.

     

    ~Scott

  • SBeattie2 Level 1 Level 1 (60 points)

    I disabled the wireless access point on the Time Capsule - and the disconnect popup warning did not appear at all - after repeated attempts during the day to try to get the server disconnect popup dialogue to appear by copying large amounts of data to the Time Capsule.

     

    This would tell me that something is not quite right with the wireless changes that were introuduced in the 7.6 firmware.  Even though my connections were "wired" to the time capsule - something was happening with regard to other wireless connections on the Time Capsule such that it was impacting the active wired connections to the Time Capsule where AFP mounts were involved.

     

    As stated by ashforma in the previous post - it could have something to do with the timing of the rotation of the group key (which was not happening today in my testing because wireless was disabled on the Time Capsule.

     

    I will now reinstate the wireless access point(s) on the TC and see if the problem resurfaces.

     

    ~Scott

  • SBeattie2 Level 1 Level 1 (60 points)

    Well, the Disconnect Warning dialogue popped up again - quite a number of hours after the last large file was copied to the Time Capsule.  The popup is now behaving a bit differently than previously when the wireless access point was enabled.  Disabling the wireless access point on the TimeCapsule did NOT resolve the disconnect popup issue - it simply changed its behavior.  Now the popup is much delayed and less frequent.  It only occurred on one of three Macs.

     

    I have now downgraded to firmware 7.5.2.  I will report back with results after some more testing.

     

    ~Scott.

  • ashforma Level 1 Level 1 (0 points)

    Following my previous post and the two by Scott, I have done a little more research and note changes in my current experience.

     

    All Apple TCs, AEs, and the AEBS are all now on firmware7.5.2. So far, the Server disconnect warning has not reappeared at all. However, that maybe because it is a holiday and I am not using the system long enough, as Scott noted, the error message appearance behavior has changed, not gone away.

     

    Another factor I omitted, all the TCs are signed in as partof the login process; System Preferences > Users & Groups > Login Items, previous, to the firmware upgrade, they had been logged in as part of the Finder Connect Server process.

     

    Signing in to the TCs as part of the Sign In process causes a Finder window popup for each TC minimizing these Finder windows leaves them in the dock. After a period of time they disappear!

     

    Clicking on a TC’s dock icon while it is still in the dock gives me access to the TC very quickly, after the icon has disappeared, Ihave to go through the Finder where the TCs show up in the Shared section. Clicking on a TC there takes some time for the files and folders to appear. Clicking another folder soon after brings all files and folders up almost immediately.

     

    The behavior of the TC is similar to another NAS device I had where it went into an energy saving mode and powered down the disks and the disk[s] had to spin up when a request was madeto them. I don’t see an option in the TC menus to select an energy saving mode or control settings.

     

    But on this Apple Site,

     

    http://www.apple.com/ca/environment/energy-efficiency/

     

    there is a description of a “Wake on Demand” service on AEBS devices and TCs:

     

    “… Bonjour Sleep Proxy running on your AirPort base station or Time Capsule and the Wake on Demand…. “

     

    I had a NAS a while back that would go to sleep in an Energy saving mode. If I set the threshold for energy saving incorrectly, it would go into energy saving and appear to the DHCP server to disconnect from the network.The energy saving settings on that device were manually configurable; I don’tsee any energy saving settings in the TC menu that can be changed.

     

    Going into an energy saving mode may also explain why the TC icons disappear from the dock after a period of time and I have to access them through the Finder and the files and folders take time to appear but are then immediately available for a period of time.

     

    If the DHCP server in the AEBS is treating a TC in energy saving mode as disconnected that could also cause our warning message to appear. If the TC failes to Wake on Demand when the AEBS tries to access it would also result in it appearing to be disconnected.

     

    M

  • ashforma Level 1 Level 1 (0 points)

    More on the Bonjour Sleep Proxy and Wake on Demand, Wireless Wake on Demand, and for me, "Portable Macs: About "closed clamshell" mode and Wake on Demand"

     

    http://support.apple.com/kb/HT3774

     

    M

Previous 1 2 3 4 5 Next