4 Replies Latest reply: Dec 30, 2012 11:30 AM by .zaph.
TheMadMacMan Level 1 Level 1 (0 points)

This issue dates back to when I first bought one of the (Early-2011) 17" MacBook Pro's and has been a thorn in my eye ever since. By "the issue", I mean the faulty SATA III (6Gbps) implementation in the 15" and 17" MacBook Pro's. Curiously enough, the 13" MBP's, both the (Early-2011) as well as the (Late-2011) work just fine with SATA III in all bays!

 

I have been through a 15" (Early-2011) MBP and when the (Late-2011) MBP's came out, I thought "Finally! Apple must have fixed it at long last" and I immediately upgraded to a 17" (LATE-2011) MBP (still MBP 8,3 identifier, by the way), but referred to as (Late-2011) MBP by Apple itself.

 

Unfortunately, after numerous EFI updates as well as other software updates, both the 15" and 17" models still do not work correctly as far as operating a SATA III (6Gbps) in the optical drive bay! After a lengthy conversation with Tech Support, and because I wanted to go back to a 17" MBP, I went all out and bought the "anti-glare" model and the only anti-glare (matte display) model that they carry in the Retail stores conveniently only comes upgraded to the higher CPU and yet another $50 to get a 7200rpm drive instead of a 5400rpm one. Fine by me I thought, even though the first thing I would do was to take out the hard drive and put a SATA III SSD into the hard drive bay. Thing is, I have two of the OWC Mercury EXTREME Pro SATA III SSD's and the second one goes into the optical drive bay, and after using Apple's software RAID 2.0, which works great, by the way, I usually get upwards of 900MB/s (and over 100,000 IOPS) in any Mac mini, and strangely enough, this works just fine in the 13" (Early as well as Late-2011) MacBook Pro's.

 

That's right, perhaps the most infuriating part is the fact that the 13" MBP works just fine with SATA III SSD's in *both* bays! Why wouldn't it? They're both SATA revision 3.0 bays on Intel's 6 series chipset. Incidentally, yes, I do realize that Apple not only has never advertised the fact that SATA III drives can be used since its (Early-2011) MBP models, but they haven't even so much as mentioned it in any of its marketing materials either, but that's no excuse. Tech Support (AppleCare) is fully aware of this issue and they keep promising me that it will be fixed "...in the next firmware update".

 

So...what do you think? Is there a "third-party" fix that I don't know about or perhaps the SATA cable running from the optical drive is improperly shielded?

 

Thanks for reading this and I know this is not an "everyday" issue, but I know that I'm not the only one who is affected by this.


MacBook Pro, Mac OS X (10.7.2), (Late-2011) 17" MacBook Pro
  • p8guitar Level 1 Level 1 (0 points)

    Same problem here with my MacBook Pro 8,3. I installed an OWC mercury extreme pro 6G with data doubler into the optical drive. This didn't work at all, I could not write any data.

     

    Then I installed a crucial m4 in the optical drive, with the OWC "data doubler" (optical to SATA drive converter bracket solution). This crucial m4 works sometimes, but there are severe problems - the drive stops working for several seconds now and then I think, which makes working with video impossible.

     

    I should have read the "special compatibility notes" on the OWC website before buying my MacBook Pro and the OWC ssd:

    "Testing has demonstrated that the 6Gb/s optical bay interface in 15" & 17" models is not consistently reliable. If your 15" or 17" model's optical bay has the 6Gb/s interface, we do not recommend the use of any OWC Mercury 6G SSD or other brand 6G SSD in the optical bay at this time. We only recommend the use of a 3Gb/s SATA 2.0 drive into 15" & 17" 2011 MacBook Pro optical bays.

     

    13" Macbook Pro models with the 6Gb/s optical bay interface have been tested compatible with all OWC Mercury 6G SSD's."

     

    A comment from Apple would be nice when they will solve this problem.

  • samterm Level 1 Level 1 (0 points)

    I was able to get SATA III 6Gb working reliably in the optical bay.

    My work: https://sites.google.com/site/themacbookproproject/


  • Way-dee Level 1 Level 1 (0 points)

    Has there been any real solution to this.  I plan on doing some testing on my late 2011 2.5ghz 17" MacBook pro, with dual owc mercury extreme pro 6g 480gb sad drives.  I don't plan on using the data doubler from owc as it Has been tested and it doesn't work.  Given the theory that there could be a cable shielding or shielding in general kind of problem, I am going to try using the drive caddy I got from eBay which encases the sad in aluminum mostly, and I try and work out some kind of shielding for the cable and see if this works.

     

    Has anyone come up with a permanate solution to this performance killing problem.

  • .zaph. Level 1 Level 1 (0 points)

    Is it only SATA III problems?  Does a SATA II drive work?  I would be ok purchasing a SATA II SSD drive and sticking it in the bay if I know that it works.

     

    I've tried an Intel SATA III SSD in the optical bay of both a late 2011 MBP 13" and a late 2011 MBP 15".  Both laptops were unable to write to the drive.  I was able to format it using FAT though.

     

    There are some cheap-ish SSDs still that operate on SATA II (maybe some that can be set back to SATA II with a jumper?).  I'm thinking they might be worth buying as they'll still be better for battery, noise and vibration than any other HDD that I could put in there.  I'm thinking they'll also be faster, just not sure by how much.  Thoughts?