Previous 1 2 3 Next 44 Replies Latest reply: Jul 25, 2012 10:09 AM by donlon Go to original post
  • J-a-x Level 3 Level 3

    What a nice suprise today. Aperture randomly went back to the "do you want to use photostream"? thing when I clicked on Photostream (no reboot), and I was pretty annoyed because I needed ot grab a photo form there and I didn't want to wait for it to re download everything. So I though I might as well reboot before re-enabling photostream otherwise I'd have to download 1000 photos, then reoot them do it again (I hadn't rebooted in a long time).

     

    Turns out that after reboot, Photostream magically turned itself back on and didn't require re-downloading anything - all of my already downloaded photos were there!

     

    This is really weird behavior though and it really shouldn't be taking Apple this long to fix it.

  • J-a-x Level 3 Level 3

    Okay so I figured it out. In order to fix it, one simply has to delete ~/Library/Application Support/iLifeAssetManagement

     

    Once deleted, I rebooted, turned Photostream back on in Aperture, and everything seemed to work after that between reboots. At least so far (2 reboots). Something was corrupted in that directory I think, because I got to the point where I couldn't even turn PhotoStream on period. I'm surprised its an iLife related folder that was causing the problem, but if you look in that folder you'll see that all of your photostream iamges are in it.

     

    Let me know if this helps other people!

  • J-a-x Level 3 Level 3

    I just wanted to add that I clicked "correct answer" on the wrong post by mistake, and there is apparently no way to undo that. So just to let you know, the post before this one is the correct answer, not the one listed as the correct answer. Sorry. I can't believe Apple gives us no way to undo that.

  • Gilles99 Level 1 Level 1

    Happy that this worked for you

     

    It ain't for me

     

    Everytime I log out and log back in I have to enebale photostream again on Aperture

  • J-a-x Level 3 Level 3

    I just rebooted again and it's still working. Did you install the 10.7.3 update yet? I wonder if that makes a difference.

  • Gilles99 Level 1 Level 1

    Yes 10.7.3

     

    well I am not a big user

    but it bothers me,

    I tried everything except re-insatlling after totally erasing my disk drive

    Not ready to do this, too long

  • Mark Bellville Level 1 Level 1

    for those that are still having the issue, do you have spotlight disabled by chance? I had spotlight disabled via the mdutil command for an unrelated issue and I've been having the photostream problem after every reboot since I installed Aperture. Recently I discovered the spotlight problem (Backblaze) and turned spotlight back on, to my surprise my photostream is enabled and working in Aperture after every reboot. I have recreated the problem by disabling spotlight and cleared it again by enabling it.

  • J-a-x Level 3 Level 3

    Ugh, it was working for me for a long time between reboots until today. I installed the new iMessage beta and on reboot my Aperture now forggot about iCloud.

  • Hana Level 2 Level 2

    Same problem here.  Definitely a bug of some sort.  Apple please submit a fix!!

  • Since2001 Level 1 Level 1

    I have to same problem too.

     

    Aperture randomly turns off Photostream requiring me to download all of my photos again. Usually over some crummy hotel WiFi in the middle of nowhere.

     

    You would think Apple could fix this (instead of keep denying the problem exisits, as is there way).

     

    It's their MacBook Pro, their OS X, their Aperture and their iCloud with their PhotoStream. They can't blame this one on Microsoft or Adobe.

     

    I think personally that Aperture is much too slow and much too buggy a program.

  • J-a-x Level 3 Level 3

    I have not had any more problems with Aperture 3.2.3 and Mac OS 10.7.3. Maybe you need to update your OS / softare?

  • scottinhawaii Level 1 Level 1

    I'm on 10.7.4 & 3.2.4 and this happens to me every time I reboot.

  • Machist Level 1 Level 1

    Same problem here..

    Aperture 3.3 Mac OS X 10.7.4

  • scottinhawaii Level 1 Level 1

    I reported this problem via the Aperture Feedback and they asked me to send them several files as a followup.

  • Machist Level 1 Level 1

    I reported this problem too (Aperture Feedback).

    Waiting for answer now..