Skip navigation

Photostream turns off in Aperture on reboot

6703 Views 44 Replies Latest reply: Jul 25, 2012 10:09 AM by donlon RSS
  • palessi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 25, 2012 6:04 AM (in response to Machist)

    I'd just like to add that I'm having the same problem.

  • Uberhamster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 28, 2012 1:55 AM (in response to palessi)

    Same deal here.

  • Machist Calculating status...
    Currently Being Moderated
    Jun 28, 2012 11:55 AM (in response to Machist)

    No answer to Aperture Feedback.

    I just love Apple products, but every time i need support i disappoint

    You get support if you pay.. Everything else is easy but you don´t get support.

     

    Once I would have needed help whit iPhoto, I expect an answer even now (two years ago).

     

    This makes me sad

  • donlon Calculating status...
    Currently Being Moderated
    Jul 9, 2012 8:23 AM (in response to J-a-x)

    I have the same problem :-(

     

    It started with the latest update, don't know if the problem is in thet update but if it isn't it triggered it

  • ee Calculating status...
    Currently Being Moderated
    Jul 10, 2012 7:37 AM (in response to J-a-x)

    Same problem over here and it was annoying the **** out of me… but after a restart Little Snitch asked me permission to access 'PhotoStreamAgent'. Aha… I thought and gave it permission to allow any connection with this server. Opened Aperture… and boom! the stream was turned on again!

     

    So a possible solution could be to not block the 'PhotoStreamAgent' in any kind of way with Little Snitch or similar tools.

  • Machist Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 11, 2012 12:13 PM (in response to J-a-x)

    I turn off filevault and now photostream seems to work

    So I think filevault is causing this problem.

     

    its causing problem also with 1password (helper won't start)

  • donlon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 12, 2012 7:27 AM (in response to Machist)

    I don't use Filevault and have never done

  • hambonehead Calculating status...
    Currently Being Moderated
    Jul 13, 2012 5:25 PM (in response to Machist)

    I have both the PhotoStream in Aperture and the 1 Password problem and I use FileVault 2. I could understand a 3rd party app being weird but Apple apps have no excuse... if FileVault 2 is the problem, I sure would like a fix. Both problems exist on my iMac and my MacBook.

  • AlterEgo Level 1 Level 1 (55 points)
    Currently Being Moderated
    Jul 13, 2012 5:47 PM (in response to ee)

    Finally, after months of following this thread and trying many suggested solutions, ee made a comment regarding Little Snitch that caught my attention. I was beginning to wonder if something was fundamentally changed in my Internet connections, although I have not been running software of that type for quite awhile. But I used to use Little Snitch and also Hands Off! for a time. I had been able to verify that the problem with Aperture not remembering that PhotoStream was turned on after any reboot was 1) consistent for all my users and 2) worked fine if I created a brand new user. Thus it wasn't a problem strictly with a particular user's configuration or 3rd party software; it had to be something that could affect the Admin users as well.

     

    I reinstalled Little Snitch and went through the startup and when it asked for permission to PhotoStreamAgent I said yes -- forever. Since then, each system reboot and relaunch of Aperture has PhotoStream settings remembered.

  • ee Level 2 Level 2 (165 points)
    Currently Being Moderated
    Jul 17, 2012 9:09 AM (in response to AlterEgo)

    I did not experience this problem again, so I guess allowing the PhotoStreamAgent to make aby connection it needs to make is a solution. I'm glad it worked for you too!

     

    Cheers!

  • joshua773 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 17, 2012 5:01 PM (in response to J-a-x)

    I have the same problem.  Photostream in Aperture 3 randomly turns off. 

     

    I have a 2009 13'' MacBook Pro running Lion.  My software is up to date.

  • Uberhamster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 20, 2012 2:01 AM (in response to J-a-x)

    Hey everyone!

     

    I wanted to share what seems to be working for me, based on about a month of okay-ness so far.

     

    I tried nearly everything listed in this (and other) threads, and was disappointed to see photo stream get turned off reboot after reboot.

     

    Then I read one post (I forget where) the problem was fixed after rebuilding spotlight. That didn't fix it for me either, but I noticed that for a short time after rebooting, my mac would say it was reindexing some stuff.

     

    As long as I started Aperture while that indexing was taking place soon after boot, photo stream would not be on. A lot of the helpful suggestions people have posted involve rebooting, and of course we all launch Aperture immediately after to check. I think this is why a lot of us keep encountering this problem!

     

    Since then I've only turned Aperture on a good couple minutes after my mac reboots. (On OSX > = Lion this means making sure Aperture is closed when you restart, or that you turn off the option to have applications automatically relaunch when restarting.

     

    I hope that's useful to someone out there.

  • Machist Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 24, 2012 9:24 AM (in response to Machist)

    Problem came back today.

    1password helper won't start and photostream turn off again

  • donlon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 25, 2012 10:09 AM (in response to J-a-x)

    My problem is gone, after ML update and the latest Aparture update

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.