1 2 3 Previous Next 44 Replies Latest reply: Jul 25, 2012 10:09 AM by donlon
J-a-x Level 3 Level 3 (730 points)

Nearly every time I reboot my Mac, Aperture asks me if I want to use Photostream in Aperture when I click the Photostream icon. I'm not sure if this is an iCloud bug or an Aperture bug but it's really annoying because each time it has to re-download all of my photostream photos. Does anybody know about a fix?


MacBook, Mac OS X (10.7.2), Unibody MacBook 2.4 Ghz, 8 GB Ram
  • 1. Re: Photostream turns off in Aperture on reboot
    Carolyn Samit Level 10 Level 10 (89,725 points)

    You have Photo Stream selected in System Preferences > iCloud ??

     

    iCloud: Photo Stream / Aperture Troubleshooting

  • 2. Re: Photostream turns off in Aperture on reboot
    J-a-x Level 3 Level 3 (730 points)

    Yes.

  • 3. Re: Photostream turns off in Aperture on reboot
    beweaver Level 1 Level 1 (0 points)

    I have the exact same problem. Aperture Photostream seems to turn itself off randomly. In Aperture's Photostream preferences I have unticked "Automatic Upload" as I don't want Aperture to automatically send, say, my latest batch of 300 imported 12 mpx RAW pics to the cloud. Could have something to do with that.

  • 4. Re: Photostream turns off in Aperture on reboot
    J-a-x Level 3 Level 3 (730 points)

    Same here. I don't want a few gigs of photos to be uploaded to photostream every time I import from my SLR.

     

    I don't think that should be a problem though...

     

    Here's what happened to be last time. I went on a trip back home to Canada, took maybe 300 photos while I was there with my iPhone which were all uploaded to photostream (I could see them in photostream on my iPad - cool). Then when I got home I went on my Mac, opened up Aperture in hopes of being able to import the photos that were in photostream but photostream showed no new photos since I had left. I restarted Aperture a few times, and still nothing, despite my iPad showing all of the new photos in photostream. So then I decided to reboot. On reboot, Aperture asked me if I wanted to use photostream, I said yes, and it started from a clean slate, re-downloading my entire photostream, including new photos. Not the smoothest process.

     

    So anyways, it seems like the Aperture forgetting Photostream bug seems to happen after a reboot when photostream gets stuck for whatever rearson. Not sure if this helps us understand the bug or not but at least I know that a reboot may be required when Photostream is acting up...

  • 5. Re: Photostream turns off in Aperture on reboot
    J-a-x Level 3 Level 3 (730 points)

    I'm still having the same problem after the latest Aperture update last week. Has anybody had any luck figuring it out? I've had my photostream turn off twice this weekend in Aperture.

  • 6. Re: Photostream turns off in Aperture on reboot
    Mike Kornienko Level 1 Level 1 (0 points)

    Just want to chime in that I was having this problem from the very beginning of using Photostream on Aperture (meaning from the first day Aperture started supporting iCloud). Photostream just turns itself off without any reason at all..

    No idea what might be possibly happening, but that's a very annoying problem.

  • 7. Re: Photostream turns off in Aperture on reboot
    beweaver Level 1 Level 1 (0 points)

    Same here. Problem persists after updating to 3.2.2. Apple claimed the problem appeared when you reached the 1000 pics limit and that it was fixed in the update. But obviously it wasn't (or there are multiple issues that need to be fixed).

  • 8. Re: Photostream turns off in Aperture on reboot
    J-a-x Level 3 Level 3 (730 points)

    I have 679 photos in my photo stream and it keeps turning itself off for me, so it's definitely not due to the number of photos.

     

    It happened to me twice yesterday and I only rebooted once so it also appears it might not be just related to rebooting.

     

    Re-downloading 678 photos just to get a few new ones each day is really annoying.

  • 9. Re: Photostream turns off in Aperture on reboot
    J-a-x Level 3 Level 3 (730 points)

    Has anybody had any luck figuring out this issue yet? It's getting really frustrating, especially now that I have ~1000 photos in my photostream.

  • 10. Re: Photostream turns off in Aperture on reboot
    AlterEgo Level 1 Level 1 (55 points)

    It continues to be a source of frustration for me. I use Aperture daily, and I was and am still looking forward to Photostream becoming a useful part of my workflow. But for now, it's hit and miss and mostly miss.

  • 11. Re: Photostream turns off in Aperture on reboot
    J-a-x Level 3 Level 3 (730 points)

    I tried a bunch of things today like deleting Aperture prefs, turning off i Cloud, rebooting, turning it back on, waiting for 1000 photos to sync, and then rebooting. Even with all that, PhotoStream is STILL off after the reboot.

     

    Does anybody know any case where Photostream does not turn off after reboot? I am wondering if this bug is affecting ALL Aperture users (in which case there's no point in trying to find a fix) or if it's only affecting some users.

  • 12. Re: Photostream turns off in Aperture on reboot
    Gilles99 Level 1 Level 1 (60 points)

    Hello,

     

    I have Aperture, latest version, and my wife uses iPhoto, atest version as well

     

    on our iMac, it does not happen, Aperture or iPhoto Photostream don't turn off after a reboot or a log out

     

    On our MacBook Pro, it is very different, both photostream (aperture and iPhoto) turn off after logging out,

     

    Tried everything as you did, no solution yet

     

    Can't see the reason why I have the problem on one machine and not the other

     

    iMac is 2009, MBP is 2011, system is 10.7.2

     

    To answer your question !

  • 13. Re: Photostream turns off in Aperture on reboot
    aledco Level 1 Level 1 (0 points)

    Same problem here. It doesn't always happen, I'd say maybe 60% of the time I reboot. Can't say whether it happens with iPhoto too since I don't use iPhoto, but Aperture's Photostream compatability appears to be horribly broken.

     

    Sort it out Apple!

  • 14. Re: Photostream turns off in Aperture on reboot
    Do I look like a joker? Level 1 Level 1 (0 points)

    Helo.

    I donl't have a fix but this issue is going to cause logistical problems with pix missing. Or, slightly less awful, duplicates all over the place.

    I think I shall turn it off and ask Apple to email me when they get it working.

1 2 3 Previous Next