11 Replies Latest reply: Jan 1, 2014 5:59 PM by rscharuk
Huub Toussaint Level 1 Level 1

I have the strange situation that sending and receiving mail works from mail.app, but webmail is giving 'connection to imap server failed' using the same username and pass. I also can login using these credentials in the wiki. Apparently the link of the webmail to the mail-database is wrong. How to proceed?

Solved by Huub Toussaint on Dec 5, 2011 5:19 AM Solved
I finally solved the issue ...I thought I really searched the discussions on the lion server but I overlooked this thread:Lion Server Webmail not reachable via https URLfrank124 says:Have a look in /usr/share/webmail/config/appleoverrides.inc.php,should point to your local servername instead of $hthe original  $h will be replaced by your external fqdn which is not enabled in mail. $rcmail_config['default_host'] = 'tls://macserver.examle.com'; and that solved my problem
  • colin-SA Level 1 Level 1

    I'm having the exact same issue ... anyone got any ideas?

  • Huub Toussaint Level 1 Level 1

    apparently the webmail interface does not connet correctly to the mail database. I guess that one way or antother the DNS is not configured correctly and/or the secure certificates are not correct (my server has another name than the name on the certificate)

    regarding DNS:

    it is on LAN on machine 10.0.1.5

    so my reverse zone is 5.1.0.10.in-addr.arpa

    10.0.1.5   Reverse Mapping server.X.com.

    then I have

    X.com     Primary Zone

    -caldavs.tcp.   service server.X.com.:8443

    mail.server.X.com.     Alias server.X.com.

    server.X.com.           Machine     10.0.1.5

     

    is this correct or should this configuration be altered?

  • Huub Toussaint Level 1 Level 1

    I finally solved the issue ...

    I thought I really searched the discussions on the lion server but I overlooked this thread:

    Lion Server Webmail not reachable via https URL

    frank124 says:

    Have a look in

     

    /usr/share/webmail/config/appleoverrides.inc.php,

    should point to your local servername instead of $h

    the original  $h will be replaced by your external fqdn which is not enabled in mail.

     

    $rcmail_config['default_host'] = 'tls://macserver.examle.com';

     

    and that solved my problem

  • dhirendrabrissy Level 1 Level 1

    Hi I have similar problem that I can't fix. Until yesterday I was getting my emails without any problems, but now I get the message saying my username or passed is incorrect. Now when I re enter my password the username or password for imap.gmail.com is incorrect. Can anyone help please?

  • Mark23 Level 3 Level 3

    In Server Admin goto Mail-->Settings and take a look at the SSL section. There is no point in setting SMTP SSL to Required because servers don't normally communicate with each other using SSL, if webmail is used and IMAP and POP SLL is set to required, you'll most likely get the message that the connection to the IMAP server failed. They should both be set to Use in most cases.

  • xlikman Level 1 Level 1

    Hi, I'm running Lion Server 10.7.3, but I can't find the file as mention "/usr/share/webmail/config/appleoverrides.inc.php".

     

    I don't seems to have this usr folder or the webmail folder. But I can access my webmail on local network. Outside connection, I get "connection to IMAP server failed".

     

    I have tried everything else. Only left with this method untried, because I can't find this file.

     

    Divine help needed.

     

    "It just Don't work"

  • xlikman Level 1 Level 1

    OK, I managed to show hidden files. I'm now trying it out.

     

    Alright.

     

    IT JUST WORKS

  • Andrea P. Level 1 Level 1

    Hi,

     

    I have the same problem, I try to change configuration in appleoverrides.inc.php like you said but nothing happens... Still webmail refuse connect users...

     

    Any ideas?

     

    +Thanks...

  • xlikman Level 1 Level 1

    Are you able to get the "Welcome to Apple Webmail" page?

  • Andrea P. Level 1 Level 1

    Yes...

     

    finally I solved the problem, it seems that the only domain accepted it's the first one, the domain with you configure initially the server (in my case a fake domain "mydomain.lan")...

     

    Thanks.

  • rscharuk Level 1 Level 1

    What about for telus email? I keep getting the msg "username or password for IMAP is incorrect"