Previous 1 2 Next 18 Replies Latest reply: Aug 21, 2014 1:20 AM by TXCopper
Hesei Level 1 Level 1 (0 points)

STILL getting "No AirPrint Printers Found"


First of all, yes this is an AirPrint printer.


So, I picked this up despite everything in my head telling me I didn't need it.  Well, I'm tired of emailing things to myself to print, so to heck with it.


I've used Artisan printers in the past and know their quirks, but this is my first bout with anything AirPrint.


Full disclosure - Wondows 7 user.  I have an iPad 2 and iPhone 4S running the latest iOS (5.0.1, right?) - just checked and there were no updates.


Artisan 837 is on and connected to my WiFi.  I can print just fine.  I have the latest drivers and went to Epson's AirPrint "support" page to get the latest firmware.


I went to the printer's IP on my network through a browser and setup Google Cloud print and AirPrint.  Google is working just fine.


Here is the AirPrint setup...


Bonjour Service Name    - Artisan837 (ususally "EPSON Artisan 837")


Bonjour Location            - is this like a workgroup?  I've tried it blank (defaults to Epson's own thing) and with a custom name


Top Priority Protocol       - two choices, both of which I've tried.  "Port9100" (default and current) and "IPP"


I've also used the browser interface to check for firmware updates - I'm using the latest version!


Despite all of this, time and time again, I get "No AirPrint Printers Found."  And I'm printing from standard iPhone applications - pictures, email, Safari, etc.

Does anyone have any idea what's going on?


Epson's guides make NO mention of AirPrint.  The only way I knew to check the FW was an orange insert they taped to the printer.  Their site is undergoing maintainance right now and I can't get to any support numbers... not sure they'd help me much, anyway.


Any help would be greatly appreciated.  I've been at this for a while, and am... very irritated to say the least.

iPhone 4S, iOS 5.0.1
  • Joe Z in VA Level 2 Level 2 (435 points)

    Note that Apple might not list your printer on AirPrint setup. When AirPrint first came out, it's HP.

  • Hesei Level 1 Level 1 (0 points)


    I did go through that link you posted.  I've already done everything EXCEPT contacting Epson (impossible at the moment).



    This is a recognized AirPrint printer by Apple.


    Thanks for trying, though.


    Does anyone out there own an Artisan 837?  Reviews are very positive and even claim to love the AirPrint feature!   Could this be an issue with the iOS update?  I know that iOS 5 made some changes to AirPrint, causing problems, though that was specifically for a Windows sharing workaround.  I assume firmware updates were required for other printers?

  • Hesei Level 1 Level 1 (0 points)

    Well, I just got off the phoe with Epson, and it looks like I'm not crazy: this thing is defective.  And by that, I don't mean just mine, but ALL Epson 837 printers are defective!  There is a hardware issue that keeps these things from updating their firmware.  Again, this is a hardware defect, so NO updates will fix this.  So I would be able to print to this if I was using version 4.x of iOS, but not 5 or higher.


    Real disappointment.  At least I can still return it to Staples.  To their credit, while I did need to get to tier-2 support, they did offer to honor the warranty... which I guess means they'd refund me or offer me some other unit?  I dunno.  I'll return it in the morning, so no worries.


    I think it's crazy that I could not find any mention of this on the web!  iOS 5 has been out for a while, now.

    Anyway, thanks to the folks that took notice, but at least this issue has been explained and that there is no resolution.


    Find another printer for AirPrint, folks!

  • Specimen001 Level 1 Level 1 (0 points)

    I've had the Epson Artisan 837 running for a few months now.  I have been so impressed with it's performance, reliability and functions that I've installed a continuous ink supply system (which is also running brilliantly).  I've also dumped my hp and canon printers, compared to the Epson, they're nothing but money suckers.


    "Well, I just got off the phone with Epson, and it looks like I'm not crazy: this thing is defective.  And by that, I don't mean just mine, but ALL Epson 837 printers are defective!  There is a hardware issue that keeps these things from updating their firmware.  Again, this is a hardware defect, so NO updates will fix this.  So I would be able to print to this if I was using version 4.x of iOS, but not 5 or higher."   -   Although I do believe this comment was probably made by an Epson employee,  I completely dissagree, however not surprised.


    First thing I did when taking it out of the box was update the firmware.  That was easy, no problems at all.  Didn't fail and it only had to be done once because the firmware updated as expected the first time (unlike some apple and samsung firmware updates).


    AirPrint set up was a total breeze, as was the rest of the printer set up.  The printer is visable to every device (and there is a lot) on my rarther large convoluted network covering mutiple houses and half a street.

    Every model iOS device works flawlessly with airprint - including every model iphone except the 3G (all running iOS 5.0.1).  There are quite a few flavours of windows machines and a couple of macs (iMac & Mac Pro) and all of the have flawless access to pretty much every feature of the printer. 


    The one problem I MAY have found, a user on my network mentioned difficulty printing using windows, IE9, however once the user switched to firefox the problem ceased to exist.  I have not verified this because I don't really care, just thougt I'd mention it because I cannot find anything else to fault with this model.

    I'm sorry people here have been having difficulties with this printer - for me it has been a dream.  I'll never buy another hp or canon now I've been using this Epson printer. 

    The desk space, money, ink, maintenance time and paper saved by using the Epson over the other printers/scanners has been immeasurable.


    Don't buy a HP!

  • Hesei Level 1 Level 1 (0 points)

    Well... that's very frustrating to hear!  Glad it's working for you, though.  Maybe it was only a chipset from a particular manufacturer or something.  Pretty annoyed they told me all units had a hardware issue, but that just may be their understanding.  This was from a tier 2 tech talking to her superiors, but I'm glad yours is working well.


    A quick note from my experience: firmware updates did not show any failures or errors.  It was always reported as successful.


    I have to agree that these printers are great and far superior to HP.  I have never had an issue until now.  However, rather than chance it, I'll wait for the next generation of models in 2012.  Thank you for the info, and I hope all continues to go well with your Epson.

  • Scott Kendall1 Level 2 Level 2 (340 points)

    I to had the same problem with my new Artisan 837 printer, until I read over the Airprint docs and it says that a local connected printer via USB will NOT serve up Airprint functionality.  You must disconnect any physically connected printer and connect to it over WiFi.  After I did that, my Artisan works perfectly on my iOS 5.11 devices.

  • lcheng Level 1 Level 1 (0 points)

    Hi - if the firmware is the latest and greatest WB13C4 36.36  then do the following as mentioned above:


    1) Ensure it is not connected via USB to any devices - only Wifi

    2) Go into you mac's system preferences and select "Print and Scan"

    3) Select your Epson printer and then select "Options and Supplies"

    4) Click on the "Open Printer's Webpage"

    5) Click on "Airprint Setup" on the local webpage that comes up

    6) Where it says Bonjour Service Name, it usually states Epson Artisan 837, remove the text and simply put Artisan837

    7) Click Ok and go back to your iPad or iOS 5 device.  It should show up now.


    I am guessing somewhere along the line either at Apple's or Epson's end, they did not protect the print queue's data field properly so it would show up as Epson_Artisan_837 as it used to. 


    Hope this helps you.

  • jimmyb30_ohio Level 1 Level 1 (0 points)

    I'm very frustrated myself! ESP reading this thread! I JUST bought the artisan 837 month or so ago because it had the greatest reviews.


    When I first set it up, my iPad & iPod touch ..,running ios 6....found the printer via AirPrint perfectly fine.


    What I'm finding now is that sometimes my devices will have it there when I try & print. And sometimes if I haven't printed anything for doesn't come up & I get the "no air printers found"


    ICHENG: does your fix really work?! How can I perform it in a WIN 7 COMPUTER???


    Thanx every1

  • jimmyb30_ohio Level 1 Level 1 (0 points)

    I figured out how to get into bonjour settings. However, when I change the service name to Artisan837 but then go back into the settings it is changed back to EPSON artisan 837



  • davep2726 Level 1 Level 1 (0 points)

    I had a problem with the 837 not showing up on my iDevices. I went to the setup menu on the printer and changed file sharing from USB to wifi (even though there is no USB connection). The Epson immediately appeared as an Airprint option on my iDevices.


    Dave P.

  •  Sonia Level 1 Level 1 (0 points)

    its the ipad, not your printer. i can access my epson all the time with its ip address, yet the ipad can never find it. no problem with mac pro. get rid of your ipad and buy a galaxy note 10

  • deggie Level 9 Level 9 (51,675 points)

    What model Epson do you have? Do you think after 2 years this person is waiting for you? You don't think they solved their issue (in this case the firmware upgrade did it).


    Your MacPro is not an iOS device and the printer driver, fonts, etc. is in the computer. With Airprint all that information is carried on the Airprint compatible printer (where it really should be). There are now 639 Airprint compatible printers. Millions of people use them with no issues.


    Your pouty posts will just get you banned.


    Do you actually want to fix your problem or do you want to pout like a child?

  • kriste66 Level 1 Level 1 (0 points)

    So to answer Hesei question above I was in exactly the same situation as Hesei. I tried everything that Hesei tried and tried it about 50 times (no kidding).This morning I went into the Airprint setup one more time and finally something caught on and I got my Airprint to work with my Epson Artisan 837 that was freaky after so many tries just magically it catches on and now I am printing from my iPad generation 3 with no problems whatsoever. It works perfectly fine. Yes I changed the Bonjour Service Name to Artisan837 and used Top Priority Protocol as Port9100 and entered Bonjour Location as Home. Then I clicked on the arrowat the top of that same web page for selecting to PRINT at the top of web page and finally I see my printer in there as Artisan837. Finally it all works! Hope you can get it to work like this Hensei........

Previous 1 2 Next