7 Replies Latest reply: Jun 29, 2012 7:44 PM by FrustratediphoneuserinGA
Mark1154 Level 1 Level 1

I composed an iMessage to a friend. We've texted before so I know iMessage should be working as all previous texts have been in iMessage "blue". Today, in this latest message, I was waiting for the screen to turn blue as I was composing but it never changed. I have an iPhone with IOS5 and my friend has the same. The text was sent in "green" as a text. It never changed to "blue". I had my friend check her settings and her iMessage menu was "on". So I'm wondering why this situation has changed for us. Cost me $.20 with ATT b/c I dropped my 200 msg plan!


iPhone 3GS, iOS 5, Main syncing computer is MacBook
  • kennethfromshawnee Level 1 Level 1

    iMessage only works over wifi.  If you were in cell coverage, iMessage wouldn't have worked.

  • KiltedTim Level 9 Level 9

    This is absolutely NOT true.

     

    iMessage works over a data connection. Either WiFi or cellular data. If there is a problem delivering the message for some reason, if one or both of you are out of contact with both WiFi and the cellular data network (if you're in a dead zone for example) or in the case of another problem on the Internet that prevents the message from being delivered, it will automatically fall back and send it as SMS.

     

    Cancelling the messaging plan was probably not a wise move. Unless you have SMS blocked entirely on your account, which I believe you can do with AT&T smart limits for $4.95 a month, there is no way to completely prevent iMessage from sending (or receiving) an SMS message.  Your only option now is the $20 monthly messaging plan.

  • kennethfromshawnee Level 1 Level 1


    I was wrong, it does work over 3g as well.  Only 3g is mentioned specifically, don't know about EDGE or other cell data connections.

  • Conrad Taylor1 Level 1 Level 1

    iMessage is free between iDevices running iOS 5 or higher.  Also, it can be used on both WiFi and cellular data connections like 3G.  Thus, you should not be paying ATT anything for text messaging if you canceled this service with ATT and communicating with another iOS 5 user.  Please take a look at the following reference:

     

    http://www.apple.com/iphone/built-in-apps/messages.html

     

    In short, you're simply using your data plan instead of the ATT text plan when communicating with iDevices.

  • modular747 Level 6 Level 6
    expertise.iphone
    iPhone

    iMessage may not work if internet connection is  not properly detected in both phones due to server delays.  The message will then default to SMS if you have that option enabled in your phone.  I suggest:

     

    Settings > Messages (with iMessage ON) > Send as SMS > OFF

  • Conrad Taylor1 Level 1 Level 1

    @modular747  Very good point and I'm switching mine off now.

  • FrustratediphoneuserinGA Level 1 Level 1

    Modular747,

    You saved the day!  You are the ONLY PERSON in 6 months to solve my iMessage dilemma! THANK YOU, THANK YOU, THANK YOU!!!!