12 Replies Latest reply: Jan 6, 2012 6:55 AM by danbi84
jessikafrombrighton Level 1 (0 points)

My friend and I have not been able to connect via text even though both of our phones have iMessage on and SMS on. When her phone hasn't been able to send as an iMessage, I receive her message in green, as a text.  When I respond back to her, my phone goes into iMessage, sends my response in blue as an iMessage, yet never says it was delivered, it doesn't get converted to text, and she never receives it. In the meantime everyone else I have contacted via iMessage or txt at the same time is able to receive and respond to my messages. The only thing that has worked is if I turn off iMessage in settings, she can get my responses via text. While I think that her work building in NYC makes it difficult to receive iMessages, in the past the messages have just automatically sent to her as SMS instead (like it's supposed to). Why now suddenly would this change?? Quite frustrating.

iPhone 4, iOS 5.0.1
  • stevejobsfan0124 Level 2 (310 points)

    You are sure that you have Settings > Messages > Send as SMS ON?

  • jessikafrombrighton Level 1 (0 points)

    Yes. Believe me I am pretty technology savvy and have double checked all the basics on both of our phones. I've tried everything I think! It seems to be only her phone and my phone. Both have the most current software update and all of our setting are the same...

  • jessikafrombrighton Level 1 (0 points)

    The only thing that has worked has been holding down the undelivered iMessage bubble until the option to "send as text" appears and then re-send as a text.  This alleviates the issue of having to turn off iMessaging in Settings in order to contact this one friend, but I guess I don't understand why it's a repeat problem between our two phones and not with anyone else that I message or text. And why it has to be done manually instead of automatically as it is supposed to.

  • iAmDanielM Level 1 (10 points)

    You didn't mention what troubleshooting that your friend did on her end to verify that her phone can receive iMessages successfully.  Maybe you have already tried these steps with her, but ask her to verify that iMessage is switched on in Settings and verify that the address(es) she has listed where she can be reached at for iMessages is the same address you have programmed in her Contact on your iPhone.

  • jessikafrombrighton Level 1 (0 points)

    We have successfully and smoothly iMessaged before and I asked her to check all of her settings. That's why it is strange. I guess what bothers me is why it is not automatically converting to a text? I'm trying to figure out if there's some setting that is off which is preventing it from happening.

  • alain le loupiot Level 1 (0 points)

    I got a similar problem but my wife has just a basic telephone, without WiFi connection, not an IOS5 device. On my iPnone 4S, all my messages to her are sent as iMessage (in blue) and of course she never receives them. I can, of course, send it as text after having disabled iMessage but this is not the point.

    The point is that a message sent as an iMessage may not be received since the phone of the receiver can be considered as an IOS5 device while it is not.

    No one can be sure that a message sent as iMessage has been received or not. Therefore, this disqualifies iMessage. Apple becomes Microsoft like ...

  • EasyA Level 1 (0 points)

    Hi, I have a very easy solution. It took me only 3 seconds. Go to Settings>messages, activate iMessage and deactivate sms. Next time you send a text, it will automatically send as iMessage!

    If the wireless network is down, then it will automatically send as sms wherever

  • alain le loupiot Level 1 (0 points)

    I fully disagree. The problem is not solved this way as indicated by jessikafrombrighton in response to stevejobsfan0124. In addition, if the wireless is down, the message IS NOT automatically sent as SMS. Many other posts mention this problem.

  • PeterPom Level 1 (0 points)

    Same issue here. I have sent an iMessage to a colleague yesterday when he was connected through WiFi.
    He has no data plan. We i try today to send him messages, iphone send iMessages instead of SMS and he does not receive anything..

  • PeterPom Level 1 (0 points)

    Looks like if after some minutes the iMessage is finally converted to a standard SMS when the receiver has no DATA. I suppose this is the SMS fallback feature.

  • ckuan Level 7 (29,476 points)

    Try putting a prefix on the phone numbers (like +1 for america)

  • danbi84 Level 2 (280 points)

    had issues setting up my parent's imessage settings.  The ONLY thing I did different - and not sure if this is the reason it worked, but a simple test for y'all to try - is for you to log into www.icloud.com.  imessage wasn't working on my parent's phones before i logged into their accounts on the web site, once i logged off (didn't do anything else after logging in) imessage suddenly worked on their phones