Previous 1 3 4 5 6 7 Next 123 Replies Latest reply: Jan 18, 2015 1:04 AM by Jaydude Go to original post
  • jacypoo808 Level 1 Level 1 (0 points)

    Posted by “yacoboy” in another forum:

     

    “Hi, i had the exact same problem as everyone else on here.

     

    I have managed to fix it!

    I was trying to import an album folder (.mp3 format) but itunes just didn't respond when i tried to add them to the library.

     

    anyway i managed to fix it by going to file --> preferences --> general --> import settings

     

    then i changed my import encoder to MP3 (i then selected higher quality but this doesn't make a difference)

     

    itunes then cooperated with me and imported the files!

     

    finally, i spent hours on this problem and i found out it was just some simple settings.

     

    well i hope it works for everyone else.

     

    Thanks”

     

     

    THIS ALSO WORKED FOR ME.

     

    My problem:

    imported CD (thought I did).

    CD appeared to be imported - green checks by each song when import was done

    looked at my library - nothing

    tried to import again - iTunes said I was duplicating music already in library

    looked again and couldn’t find it

    rinse / repeat.

     

    went into all the forums related to my problem - nothing worked.

    didn't want to attempt uninstall / install of iTunes - not all my stuff is in cloud yet (and I’ve lost a ton of music in the past doing stuff without knowing consequences)

     

    finally tried the fix from yacoboy (above) – worked!

  • Michael Allbritton Level 6 Level 6 (16,785 points)

    Hm. I highly doubt changing that setting is what caused the added files to show up in the library. The only tracks the import settings affect are tracks ripped from CD. Those settings have no affect on files being added to the library.

  • Pangono Level 1 Level 1 (0 points)

    I'm kind of surprised myself but it does seem to have worked. Don't ask me why as it doesn't make much sense but the files that I had previously imported are now showing up.

  • Jeffbabble Level 1 Level 1 (0 points)

    This is A BUG BUG BUG BUG BUG BUG. Come on Apple, pay attention. Should be able to purchase music and have it show up in your library (as we have 'forever') without searching and implementing workarounds.

  • Parracule Level 1 Level 1 (0 points)

    Thanks! Seems to solve my problem,up to now. Not a great thing from iTunes, but at least a solution

  • StevenMacD Level 1 Level 1 (0 points)

    This is such an annoying bug

     

    I just downloaded some music, and it's only viewable in the Recently Added playlist - although when you search the library it is listed under albums and artist, but whenever you click on it nothing happens.

     

    So frustrating!!

  • Destronin Level 1 Level 1 (0 points)

    I suppose I should just give a quick two cents.

     

    I was having a similar problem where I would be importing my own music from garageband into itunes. The music would be in my playlist but it was not coming up in my music library.The song was playable. Searching for it in itunes it said there were zero results. If i searched my mac it was right where it was supposed to be.  (in my music folder) I tried several different things.

     

    -restarting my computer

    -deletiing and reimporting the file

    -taking it out of my music folder and readding it that way to itunes library

    -changing the name of the file before i imported it

     

    nothing worked.

     

    So after about an hour or so of looking on the internet and not really finding anything that worked I was about to give up. I have alot of music on my external HDD that I have from my old Mac. Some of which i added to this new Mac. So some of the files had little cloud w/ arrows in them symbols between Song title and Song length that I never noticed before. I clicked on them and it was what i guess to be a redownload of some of the songs i purchased. ( i thought this odd considering the files came from my external HDD). Whatever, after I did that for some reason the garageband song showed up. ::shrugs::

     

    I hope this helps some. 

  • K3ith Level 1 Level 1 (0 points)

    After having no issues with iTunes on my MBP I bought some albums a couple of days ago. They showed up in the "Purchased" playlist, but not in Library. When I would search for the artist iTunes would say there was no artist by that name till I hit "return" and the album would show up without artwork and say "Unknown Artist" (the songs would play as they should). When I would right click the song and choose "Get info" the location of the file was where it should be.

     

    I quit and restarted iTunes and songs, artist and album artwork showed up just as it should in my library. I know this may not work for everyone, but it was a quick and thankful fix for me.

  • MartyMCZ Level 1 Level 1 (0 points)

    i just fixed the same problem:

     

    go to "recently added"

    mark all songs you have problem with

    right click and choose in menu "create MP3 version"

     

    i had some problem with certain MP3 files i have imported, but if i did it above described, it helped

  • mingsai Level 1 Level 1 (30 points)

    Hi all,

     

    I had a similar problem after trying to add music purchased via Amazon. After importing successfully for many albums, the import simple stopped. I have over 25k songs stored on a NAS. To fix I simply started Genius on the library. This forced the Genius component to rescan my system (I think faster than iTunes Match). Music appeared as the Genius was running. In the past I have had iTunes turned on but not on the machine from which I was having this problem. BTW - I am running iTunes 11.x only on the one machine. Genius corrected the problem in my case.

     

    Hope that helps.

  • kyallan Level 1 Level 1 (0 points)

    This worked perfectly for me. So annoying that I had to do this at all - not sure why it didn't just show in the library when I downloaded it from iTunes. Very frustrating, but a great fix.

  • Jamie Saloff Level 1 Level 1 (35 points)

    After never having any problems, we downloaded an album paid for in iTunes and, like above, it showed up as purchased, but not in the library. We tried many of the fixes mentioned above and none seemed to work. Note that we are not on iTunes Match and do not have iCloud set up. However, we went into our purchased list, selected all of the items from the album that would not show up, went to settings and chose "Convert to ACC version" (which is what matches our set up as mentioned by Yacoboy above. (We had never changed this from the default, and still haven't.) Almost instantly, the album showed up with the art.

     

    HOWEVER... we now have TWO of every song of that album showing up. I presume one is the ACC version and one is another type. Not sure which is which, but at least it is now there and we can play it.

  • MartyMCZ Level 1 Level 1 (0 points)

    get info and see the source file, correct file (converted) will have at the end of its name number 1, thats how you recognize which song you can delete

  • Michael McCarty Level 1 Level 1 (5 points)

    I solved this problem by turning off Match, and turning it back on again.  As soon as I turned off Match the newly purchased albums showed right up.

  • Jamie Saloff Level 1 Level 1 (35 points)

    MartyMCZ, we went into the iTunes music folder, deleted the second copies... believe it or not... the double copies STILL show up in iTunes. (That seems impossible!) BUT... at least now it's in the music library. (sigh)

Previous 1 3 4 5 6 7 Next