Previous 1 2 Next 18 Replies Latest reply: Feb 3, 2012 11:34 PM by colin i
Lost Shaker 2 Level 1 Level 1 (0 points)

Every time I launch iTunes 10.5 in my Windows XP, I get an error that reads, "APSDaemon.exe has encountered a problem and needs to close.  We are sorry for the inconvenience."

 

I believe this is the reason I'm unble to sync via wi-fi with the 4s.  Has anyone got the same issue and better, has anyone been able resolve it?


iPhone 4S, Windows XP
  • b noir Level 9 Level 9 (72,020 points)

    APSDaemon.exe is an Apple Application Support file. (Apple Application Support is where single copies of program files used by multiple different Apple programs are kept.)

     

    Let's try something relatively simple first. Restart the PC. Now head into your Add or remove programs control panel, select Apple Application Support, click "Change" and then click "Repair".

     

    Does that clear up the message?

  • reyes468 Level 1 Level 1 (0 points)

    hi i am getting the same error meassge i am running on windows xp on itunes 10.5 when i connect my ipod it shows up on my computer but it doesnt even show up on itunes and i get that error message i have tried reparing it but it still doesnt work.

  • b noir Level 9 Level 9 (72,020 points)

    Let's take a closer look at the error message, then.

     

    Generate another of those error messages and click the "Click here" link in the error message box. What modname and modver are showing for the error? (Precise spelling please.)

     

    If the error is a BEX and thus doesn't show an modname or modver, let us know what P1 through P9 items are showing for you instead.

  • reyes468 Level 1 Level 1 (0 points)

    the modname is: apsdaemon_main.dll the modver is: 2.1.10.1

  • b noir Level 9 Level 9 (72,020 points)

    Perfect, thanks.

     

    the modname is: apsdaemon_main.dll the modver is: 2.1.10.1

     

    It's another Apple Application Support file. But the version number looks wrong. I checked mine, and I've got a version 2.1.14.3. (Granted, that's on a Windows 7 64-bit system rather than XP.)

     

    Here's the hypothesis. When Apple Application Support has been updating for you, the apsdaemon_main.dll has not been updating. So when the APSDaemon.exe has been trying to run, it's seeing an old version of the apsdaemon_main.dll file ... and everything turns to custard, producing the error.

     

    If that's what is going on, the following procedure may be of some assistance.

     

    Preliminaries

     

    Download and save a fresh copy of the iTunesSetup.exe (32-bit installer file) to your Hard drive. (Don't run the install on line, and don't start the install just yet.)

     

    http://www.apple.com/itunes/download/

     

    Quit any recent version of the QuickTime Player, Safari for Windows and/or the MobileMe Control Panel for Windows if you have them installed and open. (They all use Apple Application Support, and may interfere with the AAS uninstall if they are open.)

     

    Uninstall Phase

     

    Head into your "Uninstall a program" control panel. Uninstall iTunes. Uninstall Apple Application Support.

     

    (From this point onwards, recent versions of QuickTime, Safari and the MobileMe Control panel will not launch, until we get AAS reinstalled by reinstalling iTunes.)

     

    Next we'll remove any left-over program files and folders.

     

    In "Computer" open "Local Disk C:" (or whichever drive you have your program files installed on).

    Open the "Program Files" folder.

    Right-click on the "iTunes" folder (if it still exists) and select "Delete".

    Open the "Common Files" folder.

    Open the "Apple" folder.

    Right-click on the "Apple Application Support" folder (if it still exists) and select "Delete".

    Empty your Recycle Bin.

     

    Reinstall Phase

     

    Restart the PC. After the PC restarts do not open any applications. Disconnect from your network and/or the internet. Now switch off all your security software (firewall, antivirus, antispyware).

     

    Now start the reinstall by doubleclicking the iTunesSetup.exe file you downloaded earlier. (This should also reinstall Apple Application Support.)

     

    Reenable all security software prior to reconnecting to your network and/or the internet.

     

    Did the reinstall seem to go through properly? If so, does iTunes launch properly for you now?

  • reyes468 Level 1 Level 1 (0 points)

    it worked at first but when i reconnceted to my network the message popped up again

  • b noir Level 9 Level 9 (72,020 points)

    What modname and modver are we getting for the error this time, reyes?

  • Lost Shaker 2 Level 1 Level 1 (0 points)

    OK, Catching up.... I did what you said, and still get the same. 

     

    AppName: apsdaemon.exe     AppVer: 2.1.10.1     ModName: apsdaemon_main.dll

    ModVer: 2.1.10.1     Offset: 0000cfe3

     

    I reallly appreciate your help.  Other thoughts?

  • reyes468 Level 1 Level 1 (0 points)

    alright the modname is: apsdaemon_main.dll the modver is: 2.1.10.1

  • frankfickel Level 1 Level 1 (0 points)

    Exactly the same here.

     

    Frank

  • woz11 Level 1 Level 1 (0 points)

    Same here.. what's going on??? I can't get it to load properly....!!

  • lynfromearlville Level 1 Level 1 (0 points)

    Same is happening to me.  The owner of the computer is not having the problem, but as the shared user I'm having this same APSDaemon.exe error even though I'm accessing itunes from the shared folder.

  • Mazzydan Level 1 Level 1 (0 points)

    My problem is very similar I'm running Windows 7 X64 and in order for itunes and outlook to work and not stay frozen I have to go into the task manager and kill apsdaemon.exe.  I've tried setting it up as compatible with xp and running as admin and no luck.  I've also tried suggestions in other forums.  This is messed up that its not allowing outlook to launch properly or itunes to work without me doing that first.  Please make this a priority.

  • lyskamm Level 1 Level 1 (5 points)

    Same is happening (after updating to iTunes  10.5.1.11) on my PC running Windows XP. iTunes won't even start if first I don't kill APSDaemon.exe. with Task Manager.

    Pretty annoying to do this every time I want to run iTunes

     

    On the contrary in my other PC running  Windows 7 (x64), no problem whatsoever.

    I believe that APSDaemon.exe is conflicting with something else in some configurations (not depending on window versions) but so far I have not been able to track it down.

Previous 1 2 Next