Previous 1 2 Next 21 Replies Latest reply: Aug 18, 2013 12:44 PM by davehamo
marcco Level 1 (0 points)


i bought me a magic mouse half year ago. yesterday I wanted to turn it on, but nothing happend.. so i changed the batteries. nothing. the magic mouse didn't turn on. it didn't fell down or other things..

can you help me?

Magic mouse, Mac OS X (10.7.2)
  • Tomo 2 Level 3 (555 points)

    1. Make sure the switch is all the way forward (somtimes it looks like it is, but it needs to be pushed farther).

    2.  Unlike ordanary electronics, the batterys both go the same direction.  You probably already know that, but I'm just makeing sure.



    Have you used it before yesterday?

  • VTWINCRAZY84 Level 2 (185 points)

    Or possibly try SMC or pram reset

  • marcco Level 1 (0 points)

    that doesn't work! it's forward and the batteries are right. yes i'ver used it yesterday too 

  • marcco Level 1 (0 points)

    excuse me, what do you mean?

  • marcco Level 1 (0 points)

    but i think the problem is the mouse not the mac?

  • Tomo 2 Level 3 (555 points)

    If you do not get a green light on the bottom of the mouse, then it is a problem with the mouse. If it will not connect, it could be either.

  • Tomo 2 Level 3 (555 points)

    Here is a article on resetting the pram on your computer.  If the mouse won't turn on, this will be no help.

  • marcco Level 1 (0 points)

    thank you. but its a problem with the mouse hardwear. i will set it back to apple:)

  • X423424X Level 6 (14,215 points)

    Try cleaning the battery contacts in the mouse and also the batteries own contacts as well.  Use a tissue or soft rag.  With the battery cover off try turning on the mouse and see if you get the green light.  If not try rotating the batteries inside the mouse compartment to see if you can click the switch and get the green blinking light.


    The theory here is based on a combination of possibilities.  First the contacts just plain get corroded so cleaning them makes a better contact with the batteries.  Second, a number of posts in these discussions about skipping MM's have led to the theory that not all batteries are created equal in the sense that the height of the little positive pole of the batteries varies just enough from one make to another that the close tolerances of the MM battery compartment are enough to actually make the batteries loose contact. 


    While I don't have any problems with my Sayno Eneloop rechargeables in my MM my neighbor had the problem with his non-rechargeable (don't recall the make at the moment).  I looked at his mouse and even with brand new batteries I couldn't get the green light.  I did what I described above and eventually got it to work.  But even now if he shakes the mouse he can get it to loose connection.


    I've seen descriptions of people adding a small piece of aluminum foil to make better contact or piece of paper to push on the batteries to keep them from moving when the cover is on.  My neighbor hasn't done any of these (yet).  He just has to remember not to shake the thing!

  • MrUltraSensitiv Level 1 (0 points)

    I also couldn't get MM to connect after having it work the day before. I assumed the batteries were dead so changed them but there was nothing. I fixed by fitting small pieces of aluminium foil at the top of the batteries where they fit into the holes inside the MM. It worked. I can't believe that companies such as Apple and Duracell couldn't come up with a better system to make  them work.

  • AlleyCatSmith Level 1 (0 points)

    I wouldn't have believed this but I saw it with my own eyes.


    I have always used Wegman's AA in my MM. I've had it for over a year and it has always worked fine.

    Wegman's was out of batteries 3 weeks ago so I bought Evereadys instead.


    Started getted lost connections and no green lights. Rotating the batteries sometimes worked. Started looking at new mouses then I saw that somebody here said that all batteries are not created equal. Some have longer thingies on the positive end. Shorter batteries "fall out" and lose the connection.


    Today my mouse didn't work so out of one last chance I put in some Wegmans AAs. Turned right on and worked.

    So I compared the different batteries. Yes Wegmans are definitely longer and have a bigger positive end thingy than Evereadys.


    Size does matter. AAs are not the same.

  • Insert Name Level 1 (0 points)

    It's not the mouse. And tutorials on how to install batteries isn't helping. It's disappointing that an Apple person won't come on and field questions.


    It's the software. My mouse has decided that it won't light up either. I have reset pram and all that nonsense to no avail.


    The only thing that I know to do is to reformat the entire system. Somewhere an upgrade or going to Lion or something has introduced this problem.


    A few months ago my machine decided that what it wanted to do was take 15 minutes to start up. So I did everything to fix that and nothing worked for that either.


    No answer, Apple? This guy has a problem. Are you going to answer him or not? I am beginning to think that I do not need this hassle.


    While we're on the subject, I also resent not being able to replace my laptop battery independently (as if I'm a child). I don't want to talk to your geniuses, make trips, or wait on phone calls. It's a computer, not a way of life.

  • alexfromnsw Level 1 (0 points)

    Ok I've been playing with this magic mouse for days I think I have found the solution.  Its starts the moment your install the batteries.


    1: Push the batteries into place make sure cover is as farword as it can possibly go or the on/off switch will not go all the way to on!


    Keep pushing the batteries it will take a few cycle of "lost connection" but it will work.


    Seems like a simple design fault in the battery..

  • alexfromnsw Level 1 (0 points)

    Try this it worked every time.  Push the battery cover as forward as it will go. Give the on/ff switch as much room to go to the on position.


    It seems that the rechargable batteries in the magic mouse stop the switch from going all the way to the on position. 

Previous 1 2 Next