10 Replies Latest reply: Dec 4, 2011 9:22 AM by ankhank
ankhank Level 1 Level 1 (0 points)

Mini (mid-2011, 2.3, Lion) -- hasn't been stable, ever.

 

Today I tried TinkerToolSystem Release 2

It only found one problem:

-- System Maintenance Diagnostics

----Check File Copy Operations  (between internal and external drive, both directions)

------Test 2:  "Copying files with emulated extended attributes" failed

 

Result:  "Mac OS X 10.7.2 Build 11c74 has been tested.  It has failed in at least one test.  Be prepared for corruption of file attributes or failure of the copy operation when using the Finder to copy between file systems of type HFS and HFS"

 

My guess-- file corruption since when I first copied files onto this Mac (Migration Assistant from a 2007 Mini)

But -- is this an OSX problem?  A hardware problem?

 

Anyone have any ideas?   I want to back up before taking the Mac to the Apple Store.

 

I haven't gotten for-sure trustworthy backups since I bought this Mac.

 

This is the only hint I've found at a verified problem -- but I don't know what the problem is.


Mac mini, Mac OS X (10.7.2)
  • Kappy Level 10 Level 10 (244,785 points)

    Have you tried:

     

    Reinstalling Lion Without the Installer

     

    Boot to the Recovery HD: Restart the computer and after the chime press and hold down the COMMAND and R keys until the menu screen appears. Alterhatively, restart the computer and after the chime press and hold down the OPTION key until the boot manager screen appears. Select the Recovery HD and click on the downward pointing arrow button.

     

    Repair the Hard Drive and Permissions: Upon startup select Disk Utility from the main menu. Repair the Hard Drive and Permissions as follows.

     

    When the recovery menu appears select Disk Utility. After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the main menu.

     

    Reinstall Lion: Select Reinstall Lion and click on the Continue button.

     

    Note: You can also re-download the Lion installer by opening the App Store application. Hold down the OPTION key and click on the Purchases icon in the toolbar. You should now see an active Install button to the right of your Lion purchase entry. There are situations in which this will not work. For example, if you are already booted into the Lion you originally purchased with your Apple ID or if an instance of the Lion installer is located anywhere on your computer.


  • ankhank Level 1 Level 1 (0 points)

    Yes, I have done exactly that several times.  It hasn't helped.   It doesn't seem to fix whatever the problem is.

  • Linc Davis Level 10 Level 10 (147,405 points)

    Before doing anything drastic, or anything at all for that matter, why don't you ask the developer of that third-party application what the message means? I don't think it means your system is corrupt. It means the Lion Finder is not copying some extended attribute, which may be perfectly normal.

  • ankhank Level 1 Level 1 (0 points)

    Aside, I've actually been using Macs since the 512k 'fat mac' -- my old email provider went away and so I've had to create a new userid and Apple can't connect my old numbers to the new userid.  But I"m not new at this.  I've not found any problems with the internal or external drive, I"ve run memory tests for multiple passes without any problem.   Never saw this permissions/file corruption stuff until now, but I've read the many threads about permission/ACL troubles going back to OSX 10.5 -- and tried pretty much everything that's been suggested.

     

    If I can get a good backup of the files I've worked on since I bought this Mini, I'll take it back to Apple and not worry if they have to replace the drive.  But I'm hesitating for fear of losing a few months work -- I can't yet be sure whether I have good backups, or if they were corrupted.

     

    Hoping someone else has seen this error report.

  • Linc Davis Level 10 Level 10 (147,405 points)

    You don't have one single particle of evidence that something is wrong with your drive or anything else. You don't have a usability problem. All you have is an ambiguous test result from a third-party utility, and you're going to take back the machine?

     

    I have a prediction. When you get the new machine, or the new drive, or whatever, and run the same test, you'll get the same result. If it were possible to make bets on this site, I'd be in for $1000.

     

    This is why I warn people to stay away from "utilities." They're all crap.

  • Kappy Level 10 Level 10 (244,785 points)

    Since TinkerTool System does not actually determine any system failures I would simply ignore the message. Chances are it's really a bug occurring because it isn't fully compatible or you happen to be using an older version of it.

     

    There is really only one reason to use TinkerTool System - clearing caches. That you can do easier by using Lion Cache Cleaner.

  • ankhank Level 1 Level 1 (0 points)

    Why I suspect something might be a little odd:

     

    Console System Diagnostic -- for example, just  since Nov. 30 (fairly heavy use, hours each day every day)

    lists

    7 application crashes

    4 spins

    10 hangs

    7 shutdown stalls

     

    Worse than usual few days, but then, it's been slowly getting worse since the day when I transferred files with Migration Assistant .  O the first day --  I got a handful of empty folders in random places -- only a few dozen out of thousands, but significant large  photo files -- and from then on immediate permission problems.

     

    The ACL and permission fixes help for a while each time.

     

    But I've had continuing failures, kernel crashes every day or two, the Mac freezing completely. 

     

    I've pursued each problem as it occurred through the relevant discussions, followed the suggestions from people here, gotten some results for a while, and had continuing/recurring problems.  I've done the system reinstall.

     

    If anyone has seen this error report, they'll find this thread when they search for it and respond.

  • Linc Davis Level 10 Level 10 (147,405 points)

    The single answer I've gotten from any tool that suggests an identifiable problem --- is this one.

     

    You've seized upon the one piece of information that is least likely to be related to your problems. Kernel panics call for a specific troubleshooting procedure. If you haven't already done so, I suggest you start a discussion that addresses the issue directly. Include the most recent panic log.

  • jsd2 Level 5 Level 5 (6,200 points)

    I also have TinkerTool System and I have a dual-boot SL-Lion setup.

     

    I just tried that test in both systems,  using a newly formatted USB flash drive containing only a single newly-created "empty file"  as one target  for the test, and a new empty Desktop folder as the second target. I got the same result as you did for both Snow Leopard and Lion -

    "Copying files with emulated extended attributes" - failed

     

    While running the test, I could see a brief Finder copy-window that said "Moving TestFile.png to "untitled folder".

    I have no such TestFile.png file.  I think it probably is supplied by TinkerTool System itself when it tests the copying of "files with emulated extended attributes". In other words I think that particular test probably says nothing about one's own files - it is just trying to measure Finder's copying performance, using its own file.  And as I said, it reported failure in both my SL and Lion systems.

     

    Operationally, both of my systems are working OK. I doubt that this means much of anything  - I would ignore the result.

  • ankhank Level 1 Level 1 (0 points)

    That's a helpful answer, jsd2, thank you. 

     

    I'm still getting varied behavior from the originally installed OSX on the internal drive (which I've now reinstalled several times via USB stick/Internet without improvement) -- but booting from another copy installed on an external drive, I'm not seeing the same problems.  So I'm more inclined to erase the internal drive once I know I have good backups.

     

    Still getting bad files intermittently when booted from the internal drive, and seeing Console items like this (just since yesterday) including another kernel panic.   These kinds of thing are what have me asking whether there's a real problem here somewhere, and looking for some idea how to identify the problem.  Since several reinstalls with USB stick haven't helped, and hardware test finds nothing, I'm a bit perplexed.

     

    12/3/11 8:56:11.762 PM spindump: Saved hang report for Finder version 10.7.1 (10.7.1) to /Library/Logs/DiagnosticReports/Finder_2011-12-03-205611_Mac-mini.hang

    12/3/11 8:56:33.718 PM Dock: Failed to write crash history to file://localhost/Users/.../Library/Application%20Support/CrashReporter/_430ABED 4-D896-5BB1-8816-7153E600815C.plist.

    12/3/11 8:56:37.208 PM Dock: Failed to write crash history to file://localhost/Users/.../Library/Application%20Support/CrashReporter/_430ABED 4-D896-5BB1-8816-7153E600815C.plist.

    12/3/11 8:56:41.679 PM Dock: Failed to write crash history to file://localhost/Users/.../Library/Application%20Support/CrashReporter/_430ABED 4-D896-5BB1-8816-7153E600815C.plist.

    12/3/11 8:57:23.000 PM kernel: 0        0 AppleUSBCDC: start - initDevice failed

    12/3/11 8:57:23.000 PM kernel: USBMSC Identifier (non-unique): 68DB0057467CE 0x1234 0x5678 0x100

    12/3/11 8:59:01.414 PM spindump: Saved hang report for TinkerTool System version 2.85 (2.85) to /Library/Logs/DiagnosticReports/TinkerTool System_2011-12-03-205901_Mac-mini.hang

    12/3/11 8:59:06.000 PM kernel: IOSCSIPeripheralDeviceType00::setPowerState(0xffffff8013cabe00, 1 -> 4) timed out after 100841 ms

     

     

    Many thanks for actually checking what I asked about and letting me know what you found.  That is helpful.