9 Replies Latest reply: Feb 13, 2013 8:00 AM by Renaissance Man in Taiwan
OBE2011 Level 1 (0 points)

Hi,

 

I can't change the brightness of my 27" cinema display. I have no brightness fader on the settings. I have tried it with my MacBook Pro (Sow Leopard) and my MacBook Air (Lion). On both devices the same problem.

 

The display is too dark and I would like to brighten it up.

 

I have searched the forum and tried several things without luck.

The USB cable is plugged in.

 

Any help is highly appreciated.

 

Thanks,

OBE2011


Cinema Tools, Mac OS X (10.7.2)
  • donaldo777 Level 1 (20 points)

    Plug in the USB tentacle that comes out of the display, crazy but that is needed in order for the System Preferences to enable the Brightness slider. I know, it took me about 2 hours of drilling through doucmentation to find this.

     

    http://support.apple.com/kb/HT4293

     

    Additional Information

    This software updates the System Preferences pane where you can change Ambient Light Sensor settings.  Enable the option "Automatically adjust brightness as ambient light changes" to turn the ambient light sensor on and off.  Use the slider to adjust the brightness level.

    Display System Preferences pane after applying this update

    Note: You must have the cinema display's USB cable connected directly to your Mac to access this functionality.

  • kkkkvvn Level 1 (0 points)

    Thank you very much for this. I was getting frustrated following the Apple documentation that failed to point out the importance of plugging in the monitor USB plug

  • Nick F-J Level 1 (0 points)

    Thanks for this, I am in the same boat however I am runniing 10.7.3 and that update will only work on 10.6.

     

    Any suggestions on where to find a newer patch would be awesome.

     

    Thanks - Nick

  • Nick F-J Level 1 (0 points)

    Fixed it - download and run the EIDID Reset Tool if you are on 10.7

     

    http://download.info.apple.com/Apple_Hardware_Test/EDID_Reset_Tool.dmg

  • Renaissance Man in Taiwan Level 1 (0 points)

    Thanks Nick F-J! This is what solved my problem. I recently had my LED 27" Cinema Display repaired. They replaced the logic board. However, they apparently didn't know or forgot to reset the EIDID. Using the link you provided to download the EDID_Reset_Tool.dmg and following the instructions solved the problem.

     

    Since I am running Mountain Lion 10.8.2, I had to do one extra thing and that is to use the Ctl-Click and Open on the program since it was not identified as a APP downloaded from the App Store (a new "safety" feature in Mountain Lion but they forgot to update all of their own software to be). Doing this allowed me to run the APP.

  • dlisanto Level 1 (0 points)

    Renaissance Man in Taiwan,

    I also had the same problem and am running Mountain Lion 10.8.2. I downloaded the EDID Reset Tool dmg and couldn't open the program even when doing Ctl-Click. Nothing happens. Is there a certain program I need to open this file?

  • Renaissance Man in Taiwan Level 1 (0 points)

    Dear dlisanto,

     

    No, you don't need to specify any software. Just hold down the control modifier key and click on the file. A popup menu should show up and then select "Open", not "Open With". If you do select "Open With", then select the default, which is DiskImageMounter. You should see "EDID Reset Tool" appear mounted on your desktop or under "Devices" in a finder window.

  • dlisanto Level 1 (0 points)

    Thanks, I actually just opened up a Finder window and loaded it from the sidebar and it worked.

  • Renaissance Man in Taiwan Level 1 (0 points)

    Great!

     

    You probably have your preferences so that these mounted devices don't show up on your desktop so that is why you felt like nothing happened when you did the ctl-click open sequence.