2 Replies Latest reply: Dec 5, 2011 12:43 PM by Winston Churchill
Tim Murray2 Level 1 Level 1 (85 points)

In MobileMe, you could force a sync in the direction you needed, but I don't see any way of doing that with iCloud.

 

For some reason, the first problem was that if any contact was in a group, that contact disappeared. But I have a backup made with the Address Book export feature. (I make a backup every couple of days. I distrust syncing where I can't force the direction.)  I deleted all my contacts on the Mac, imported the backup, and everything including contacts groups is back to normal ... but only for about 20 seconds.  During that few seconds where the Mac's Address Book is empty, the iCloud address book emptied itself as well.

 

Since the Contacts at iCloud is also empty, it appears that the syncing mechanism assumes that iCloud is correct, and deletes everything on my Mac and iPhone.

 

One solution *might* be to disable iCloud, turn MobileMe back on, import contacts, then sync upward to MobileMe. Then, switch back over to iCloud.  But before I try that, does anyone know of a more elegant solution that forces my Mac to be the base data and force an upload to iCloud?

 



MacBook Pro 17, Mac OS X (10.6.8), 4 GB
  • Tim Murray2 Level 1 Level 1 (85 points)

    Update: It appears the iCloud preferences are lying to you. In the preferences I disabled syching of contacts, but contacts still disappear after an import. The only way to retain them is to turn off internet access. BUT, about 20 seconds after I reattach to the internet, my contacts disappear.

     

    Further, upon import and with no internet connection, the Address Book section that populates itself is the iCloud > All iCloud section. The "All on My Mac" is empty. This clearly isn't correct.

     

    Right now, Steve Job is clawing at his casket cover.

  • Winston Churchill Level 10 Level 10 (87,445 points)

    You can't turn Mobile Me back on.

     

    Disable contact syncing on ALL your devices, delete any contacts left anywhere, turn contact syncing back on, ensure iCloud is the default account in your mac's address book contacts, add back the contacts from your back up.

  • Csound1 Level 8 Level 8 (43,355 points)

    Tim Murray2 wrote:

     

    Update: It appears the iCloud preferences are lying to you. In the preferences I disabled syching of contacts, but contacts still disappear after an import. The only way to retain them is to turn off internet access. BUT, about 20 seconds after I reattach to the internet, my contacts disappear.

     

    Further, upon import and with no internet connection, the Address Book section that populates itself is the iCloud > All iCloud section. The "All on My Mac" is empty. This clearly isn't correct.

     

    This clearly is correct, assuming that you want iCloud to handle your contacts, 'On my Mac ' does not sync to iCloud (actually nothing does, you subscribe to your account in iCloud, not sync to it, Google CardDav for a fuller explanation)

     

    If you want your contacts in the On my Mac account copy them there from iCloud, but they will not distribute to any other devices that way, if you want them on multiple devices (like an iPhone) then they have to be in iCloud (or you could sync with a wire via iTunes). Or use a different service.