3 Replies Latest reply: Jul 11, 2012 4:17 PM by kanya.
whitfromboise Level 1 Level 1 (0 points)

Lion won't empty trash (did earlier though) and won't let me reboot, just says emptying the trash 44 items, but makes no progress


MacBook Pro, Mac OS X (10.7.2), says emptying trash, 44 items, but
  • macjack Level 9 Level 9 (50,625 points)

    http://support.apple.com/kb/HT1526?viewlocale=en_US

    EDIT: I'd try a restart first in case some incomplete download or file in use, first.

     

    Go to /Applications /Utilities/Terminal and launch it.

    At the prompt, copy and paste this command

    sudo rm -rf ~/.Trash

    Press Return.

    You will be asked to enter your admin password. It will be invisible.

    Enter it and press Return.

    Log out and back in or restart.

     

    Let us know.


  • Svensk07 Level 1 Level 1 (0 points)

    I had the exact same problem as whitfrombois. I downloaded Spotify when i was in the States and tried to delete it when i came back to Canada. After i put the app in my trash the icon had a big X over it and when i tried to empty my trash it would say "Emptying the trash" 1 item(s) remaining and there was no progress. I tried what macjack had mentioned and had to force quit my finder but when i logged back in my trash was empty so I guess this was the right solution. Well at least it helped me empty my trash!

  • kanya. Level 1 Level 1 (0 points)

    thank you, the command line finally solved my issue! I tried to delete damaged spotify.app for over an hour