5 Replies Latest reply: Dec 26, 2012 6:32 PM by bgranger11
herbieyii Level 1 (0 points)

I has already enter correct apple id and connect to wifi but it still can't sign in to iMessage and faceTime . the notification shown (iMessage Activation . Could not sign in. please check your network connection and try again )


iPod touch
  • lllaass Level 10 (175,932 points)

    Try here:

    iOS: Troubleshooting Messages

    Some users have resolved that error by using Google's DNS server 8.8.8.8 in Setting>wifi

  • rnbehl Level 1 (0 points)

    Same issue here...

  • iGotya Level 1 (10 points)

    Is your wifi set to DHCP or Static. Static is manual so you have to enter IP etc. yourself. That might solve the issue!

  • Bishopbrock Level 1 (0 points)

    I entered the "8.8.8.8" into the DNS blank on two devises.  Worked like a charm. Thanks

  • bgranger11 Level 1 (0 points)

    I GOT IT! I tried all of the other things people suggestions and nothing worked for me. Don't change your DNS.

     

     

    I had to back up all of my everything, turn off facetime and iMessage, and reset my entire phone under settings>general>reset>erase all content and settings. back sure you back up contacts, pictures, apps, etc. on iCloud and your apple ID because it will all be gone. then configure your phone at sq. 1, and in the first couple steps you're gonna wanna skip registering your apple ID, and then move along until you're at the home page. then go to settings, turn on facetime, turn on iMessaging, try to log in. It should work after your phone has reconfigured. then go ahead, once iMessage is working, log into iCloud and your Apple ID so that you get all your **** back. I really hope this helped... blood, sweat and tears went into the process of finding this answer..