Skip navigation

Apple Mail won't display messages in HTML

1364 Views 13 Replies Latest reply: May 6, 2012 1:45 PM by Smitty51 RSS
Emily Kessler Level 1 Level 1 (35 points)
Currently Being Moderated
Dec 7, 2011 11:25 AM

I'm using Apple Mail on my laptop to check email from an account other than iCloud and Gmail.  I also use my iPhone and iPad to check mail from this same account.  Sometimes, newsletters are appearing in Apple Mail in plain text format, and not in HTML format.  What's unusual is that these same messages appear in HTML format on both my iPhone and iPad, so I'm guessing it's not a problem with my mail server, but with the Apple Mail application.  Are there any settings in Apple Mail to ensure I view all messages in HTML format?

 

Thanks!

MacBook Pro, Mac OS X (10.7.2)
  • Smitty51 Calculating status...
    Currently Being Moderated
    Mar 22, 2012 7:37 AM (in response to Emily Kessler)

    I have the same problem.  I am trying the following, but am not sure it works:

     

    https://discussions.apple.com/message/9014586#9014586

  • Smitty51 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 26, 2012 8:03 AM (in response to Emily Kessler)

    I am having the exact same problem.  I have 3 accounts also and the only one I have problems with is the gmail account when I am looking at it via the Apple Mail program on the mac.  If I look the mail message via a web browser in gmail the html is displayed just fine.  I tried the fix that I posted above, it did not fix any of the messages that I have already received but I have not had a problem with new messages since then.  So I don't really know yet if the problem has gone away.  If you figure anything else out please post it, as this is very annoying.

  • mandjapple Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 5, 2012 8:55 AM (in response to Emily Kessler)

    Any results?  I'm having this problem too with a Yahoo account, setup as IMAP in Apple Mail 5.2 on OS X 10.7.3

  • mandjapple Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 5, 2012 11:49 AM (in response to Emily Kessler)

    Thanks.

    I tried:

    defaults write com.apple.mail PreferPlainText -bool False

     

    Which didn't seem to work.

     

    I then tried prefixing "sudo" to the command, to make sure it wasn't a permissions issue and entered the administrator password when it asked.  When I reopened Mail, the HTML formatted messages worked correctly.

     

    sudo defaults write com.apple.mail PreferPlainText -bool False

     


  • mactech1976 Calculating status...
    Currently Being Moderated
    Apr 5, 2012 12:29 PM (in response to mandjapple)

    If anyone else is still having this problem after running the command and rebuilding the mailbox envelope index, I was able to solve this by reverting to an old prefrences file from two years ago. I would also guess that rebuilding (ie deleting the file and entering settings again) would also fix this, but I did not try that as my backup worked great.

  • benalan Calculating status...
    Currently Being Moderated
    Apr 6, 2012 10:52 AM (in response to Emily Kessler)

    Emily -

     

    My wife is having the same problem with her new MacBook Air. She never saw the problem on the old first-gen Air running Snow Leopard.

     

    Here's what's going on:

     

    The messages that are having the problem are encoded as multipart/alternative. That is, they contain this in the received message:

     

    MIME-Version: 1.0

    Content-Type: multipart/alternative;

              boundary="----=_Part_2836956_1545934347.1333570398993"

     

    Downstream, you'll find that boundary string whenever a new "part" begins:

     

    ------=_Part_2836956_1545934347.1333570398993

    Content-Type: text/plain; charset=utf-8

    Content-Transfer-Encoding: quoted-printable

     

    This begins the first part...the plain text part. On down the stream, you'll find the part header again:

     

    ------=_Part_2836956_1545934347.1333570398993

    Content-Type: text/html; charset=utf-8

    Content-Transfer-Encoding: quoted-printable

     

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.=

    w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    <html>

     

    That final <html> tag begins the bulk of the HTML code to render the graphical page. The block must end with a </html> tag to indicate the end of the block...but in this message the last line is:

     

    <td style=3D"color: #000000; text-decoration: none; font-size: 10px; font-f=

    amily: Arial,Helve

     

    ...and that's it. Obviously, the last word should have been "Helvetica" but ***the message was cut off***. I know this because if I open the message source window for the the same message in the gmail section (not the inbox section) the end of the message looks like this:

     

    </body>

    </html>

    ------=_Part_2836956_1545934347.1333570398993--

     

    ...which is what I'd expect in a multipart MIME encoded message.

     

    The amount of data that's missing from the end appears to be about one network packet's worth. I suspect what's going on is that mail is erroneously discarding the final packet of some mail messages.

     

    BTW, I've taken the computer to the Genius bar, and we took the time to create a new user account and a clean mailbox and duplicated the problem there in the store. The genius was unable to recommend a solution to the problem, and suggested that I perform a reinstall-in-place of the OS. Haven't done that yet, as I consider that pretty thin gruel from the perspective of fixing the problem.

     

    In the meantime, I'm trying Sparrow mail as an alternative mail client. So far, I haven't seen the problem using Sparrow (nor, for that matter, on OSX Snow Leopard.)

     

    Sorry I can't be more helpful, but I'll post back in this forum if I come up with a solution. I'll follow the thread...if anybody has any ideas what might be going on please post.

  • Smitty51 Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 6, 2012 1:45 PM (in response to Emily Kessler)

    benalan is right, not all of the message is being read from the imap server.  Not sure who's problem it is, Apple or Google.  I have found a awkward work around sort of using your browser to view your gmail.

     

    Create a mailbox on your mac, make sure it is listed under "ON MY MAC".  Drag (copy) the offending message to this mailbox from your INBOX. Quit mail, restart mail, copy the offending message back to INBOX.  This will cause mail to re-read the message and hopefully get it right this time around.  PS.  This seems to work for me, once I had to do it twice to get it right, I assume because mail read it wrong a scond time.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.