Skip navigation

Copying files from one external HD to another : error -8084

3802 Views 7 Replies Latest reply: Feb 21, 2013 7:48 AM by robynwe RSS
jinniferb Level 1 Level 1 (145 points)
Currently Being Moderated
Dec 7, 2011 12:22 PM

Hello!

 

We are currently running SL server 10.6.8.

 

There are 3 external hard drives connected to it that we use for various data storage.
Daily, I need to copy the contents of EHD #1 over the EHD #2.

 

On occasion, this works without error.
But more often than not, the process hits a bump in the road and aborts the copy giving me an error message "Could not complete process, unexpected error occurred (-8084)".
When I check the results, only certain files had been copied while the rest had not.

 

Now, this is where it gets weird: thinking that there was a particular file or folder that was causing the error, I would go in and copy each folder over one and at a time to try and quarantine which one the Finder is hitting and failing to copy when it produces the error.

 

When I copy the folders one by one (as opposed to all of them at once), no errors...well, most of the time.
Often it gives me the same errors on various folders, but it's never the same folder twice.
I can mark them with colors to indicate that thay have given me copy issues in the past, but this is usually pointless.

 

The main thing that frustrates me is that this error is SERIOUSLY INCONSISTENT.
Some days it doesn't happen at all, some days it only happens when I try to bulk copy (but not individually copy) and some days it happens when I individually copy (but not bulk copy) and some days it does it when I copy both ways.

 

A pretty thorough Google search would indicate that this is a Time Machine-related error, but honestly, we don't use TM and therefore it is turned off.
Otherwise, all I that am seeing in the seach results is that:
a) people encounter this and
b) nobody has ever found a fix OR  cause for it.

 

If anybody out there can shed ANY light on this situation, that would be IMMENSELY helpful to me.

 

Thanks in advance!

  • MrHoffman Level 6 Level 6 (11,720 points)

    Get a third and preferably known-good external disk involved in the sequencing as the source or the target, and process your files normally.

     

    If the problem persists with the new configuration, swap the new disk over to the other original disk, and process your files normally.

     

    This to determine if you have a hardware error with one of the disks.

     

    If the disks are bus powered, move to a powered hub, or (if the disks permit it) to an external power supply.

     

    This to determine if your disks need more power than is available via the USB.

  • MrHoffman Level 6 Level 6 (11,720 points)

    This is a guess and an attempt to reduce the scope of the problem and particularly an attempt to localize the error trigger for an error code that isn't particularly documented (beyond "the operation can’t be completed because an unexpected error occurred (error code -8084)" text), and some of the common triggers for flaky USB device errors can be due to power issues (too much draw or too little available power) and can include device errors.  There can be other potential triggers for device errors, but these are among the easiest to test.

  • Tom Ku Level 1 Level 1 (0 points)

    My workaround probably doesn't address "jinniferb"'s problem, but it may help others to nail down a similar problem, for example as described in the article cited by "jinniferb" (http://www.techweb.com/news/231901757/the-mac-emperor-has-no-clothes.html).

     

    Symptom:  I encountered the intermittent "error code -8084" problem when copying a large set of media files from a hard disk on a computer running Windows 7 (Computer A) over my wired home network to my Mac's OS X Extended Journalled hard disk on Computer B.  I first tried to copy by selecting and dragging a bunch of files from one Finder Window to another on Computer B: One Finder window showing the source files on Computer A (connected via SMB protocol), the other showing the destination folder on the local computer (Computer B). [Note: dragging files from one folder to another on the same computer will cause a move; here the 2 folders are on different computers, so it was a copy instead].  If a copy operation involved even moderately amount of data(like 50MB), it nearly failed with certainty at some time before all the files were copied.   And the failure didn't have anything to do with the files -- I knew for sure because I could copy the file at which the copy operation failed on the next copy attempt.   I have over 3000 files with total size over 100GB to copy over the network.  The copy operation would take over 3 hours to finish even without interruption, so just incrementally copying by hand after each failure wouldn't work for me in practice.

     

    Workaround:  It just so happened that Computer A was also a Mac, with the source data on the Bootcamp partition.  So, I tried another tack:  I booted Computer A into Mac OS X 10.6.8, same as Computer B.  There was no problem opening a Finder window showing the source files in its Bootcomp partition. I opened another Finder window on Computer A with the destination folder on Computer B (but I don't which network protocol is being used in this case, probably not SMB).   Now the copy worked without a hitch -- e.g. dragging over 100GB of files from one Finder Window completed after 3+ hours, without the mysterious "error code -8084".

     

    Tentative Conclusions:

    So, at least in my case, the "error code -8084" is not caused by any of the following:

    . an encrypted or unreadable source file.

    . a problem with the hardware (disk, cable connections, power for hard drives etc) of the source computer or the destination computer.

    .  Time Machine -- computer B (the destination computer) has Time Machine running while the copy is going on.

    . the parts of the network, that is unrelated to the computer operating systems or SMB protocol, which is used to network the 2 different operating systems.

    .  source files being on a NTFS disk and the destination on a hard disk formatted in OS X Extended Journaled.

     

    The combination of NTFS Windows 7 talking to OS X over SMB seems to be cause of the instability.

  • Graham Perrin Level 2 Level 2 (240 points)

    For a file that is with or without a resource fork: when AppleFSCompression is applied, the compressed data may be stored in chunks in the resource fork.

     

    In some situations a compressed file may become unopenable, in a way that can be neither recognised nor resolved by things such as Disk Utility.

     

    Here with Mountain Lion, I have some files with AppleFSCompression that can be copied from one HFS Plus volume to another HFS Plus volume, no error is apparent and no decompression occurs.

     

    If I attempt to copy or move the same files to a file system that is not HFS Plus: the action fails with error code -22 (a negative integer). In other situations for the same files, the error code is 22 (a positive integer).

     

    Today I copied one of the files to a USB flash drive that uses JHFS+, then used that drive with Snow Leopard.

     

    When I attempt to copy the compressed file from the flash drive to the desktop of the Snow Leopard user, the unexpected error is error code -8084.

     

    So in my estimation, the likeliest cause in your case is a problem with AppleFSCompression, affecting some files.

     

    Where some methods of copying will fail when an error such as -8084 or -22 occurs, you may find that ditto will succeed (the error will occur, but copying of other files may continue).

  • robynwe Level 1 Level 1 (0 points)

    Just worked this out.  The problem is something in OSX, but you can use Terminal to get around it.

     

     

    So...

    in your Utilities folder, open Terminal.  This is a command-based operating system.  Remember all these commands are case-sensitive.

     

    Use the command    df -h  to display all your drives.  They will be in a list that looks like  /Volumes/A

     

    Use the command ls or ls -a  to display all files and folders in the folder you currently are.

     

    Use the command cd to move around folders. 

    Eg cd .. to move to the parent folder.

    eg cd Sub to move to the Sub folder in your current folder

    eg cd "/Volumes/Public" to move to the top folder of your Public drive.

    eg cd "/Volumes/A Folder with Spaces" where you have a folder name with spaces.  Put the "" around the whole name.

     

    Use the commands  cp  and mv   (I prefer cp (ie copy) rather than mv (ie move) so I can go back and fix mistakes)

     

    To copy a file from one drive to another, use the command:

    cp filename  destination    don't worry about filetypes.

    eg  cp SNC*   /Volumes/A  to copy all files from your current folder starting with SNC to your A drive.

    eg  cp  -r "/Volumes/Public/Book" /Volumes/A  to copy your whole Book folder from your Public drive to your A drive.  Remember the -r because this means copy the folder and everything in it.

     

    Use this page http://ss64.com/osx/  for more help on the Terminal commands or use google search.

    Also, use OSX to check that the files have moved etc.  Leave your Terminal window open while you do.

     

    Hope I'm not too cryptic.  It's the middle of the night here.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.