Previous 1 2 3 4 Next 45 Replies Latest reply: May 30, 2013 6:42 PM by dmjaeger
TresRoque Level 1 Level 1 (85 points)

Mail's been such a clunker I've moved over to Thunderbird.

 

However, Mail is still loading an email account, when I have deleted all the accounts and even the files in the Library/ Mail folder (and yes, I'd backed them up to external HD just in case).

 

I use POP and MobileMe, but it's the MMe that keeps 'returning'.


Macbook 2.4Ghz (White) 4GB RAM, Mac OS X (10.6.4), Logic Studio 8, Safari 5.0.2, iLife 08, iWork 08, Aperture 2
  • Dansyacht Level 4 Level 4 (2,120 points)

    When you say "Mail is still loading," do you mean it is starting up when you log in?  If so, there are two ways to stop that.

     

    If Mail is still in your dock, right or control click on the icon and then uncheck Options/Open at Login.  Then go ahead and remove the icon from the dock. (Options/Remove from Dock)

     

    Or, go to System Preferences/Accounts/Login Items and remove Mail from the list if it is there.

     

    Some programs with built-in email links to Mail may require setting changes in their preferences.

  • TresRoque Level 1 Level 1 (85 points)

    I'd deleted the icon form the dock and Mail's not a login item.

     

    However, your suggestion did make me realise that I'm still syncing via MMe in sys prefs. I've unchecked it, so we'll see if that stops Mail automatically reinstating ("loading") the account.

     

    Cheers.

  • TresRoque Level 1 Level 1 (85 points)

    Nope. Even if I uncheck everything under the account, it automatically reinstates itself.

     

    I'm reduced to choosing 'Manually' for checking email, from the drop down menu in general prefs.

     

    Any more elegant solutions would be welcome.

  • Dansyacht Level 4 Level 4 (2,120 points)

    I haven't really played much with Thunderbird but I did notice one thing.

     

    In Thunderbird - Preferences - Advanced - General - System Integration there is a button for checking if it is the default mail client.  Have you checked that?

  • TresRoque Level 1 Level 1 (85 points)

    Thunderbird's the default, and I've selected that in Mail default mail settings.

     

    BTW – my manual solution didn't work, as now I'm getting mail for an alias created in my main MMe account. I can't delete the alias as I've not moved to Lion, under which I could then move to iCloud and manage the alias.

     

    (Frankly, Mail has become ome kind of monster, much like MS' IE. There's no escaping it!)

     

    So, still seeking a resounding solution....

  • Glenn Leblanc Level 5 Level 5 (7,325 points)

    Just because you have an account listed in Mail doesn't mean you have to open it. Just use Thunderbird as suggested and don't worry about opening Mail. It doesn't hurt to have more than one mail program on the computer and if you never open it, nothing will happen within it. I have outlook with all my accounts listed, but only on rare occasions will I even open it.

     

    MMe is linked to iCloud in Lion and when you log into iCloud, it autocreates the account in Mail. That may be part of your problem even though you're not using iCloud. When I sign out of iCloud, my Me account disappears from my Mail accounts. I suspect that since you're signed in to MMe, it's still creates the account in Mail even though your using SL. It just seems in some way Mail & MMe are linked. That's just my assumption.

  • TresRoque Level 1 Level 1 (85 points)

    I'm not opening Mail – it opens itself.

     

    I have to use MMe as I've important email accounts attached to it.

     

    It's absurd that:

     

    1. I can't simple 'switch Mail off'

    2. That Mail is tethered to MMe even when I have deleted all the accounts in it.

     

    The result being Mail's an incessant gadfly.

     

    But thanks for the suggestion in para 2.

     

    Failing a solution, I'll have to delete the Mail app from my Mac. Which is pretty naff.

  • X423424X Level 6 Level 6 (14,205 points)

    Mail is not starting up on its own.  Something has to be explicitly launching it.

     

    Unless I missed it above, you never did clearify/answer a question by Dansyacht as to whether mail is launching at login or at some other time.  Assuming it is at login then please post the items in the following folders:

     

    your login items (even if you say mail isn't in there)

    ~/Library/LaunchAgents

    /Library/LaunchAgents

    /Library/StartupItems

     

    And if it as some other time please post exactly the steps you are performing when mail launches.

     

    You could also try logging in to another account to see if mail launches in that account.

  • TresRoque Level 1 Level 1 (85 points)

    1. Mail activates throughout the day, regardless of login.

     

    2. Mail activates while I'm working, even when I'm offline.

     

    3. ~/Library/LaunchAgents

     

    at.obdev.LittleSnitchNetworkMonitor

    at.obdev.LittleSnitchUIAgent

    com.trusteer.rapport.rapportd

    com.wacom.pentablet

    org.glimmerblocker.updater

    org.thebends.iphonedisk.mobile_fs_util

     

    plists

     

    4. /Library/LaunchAgents

     

    com.apple.MobileMeSyncClientAgent

    com.apple.SafariBookmarksSyncer

    com.google.keystone.agent

    com.macpaw.CleanMyMac.helperTool

     

    5. /Library/StartupItems

     

    Arcanastartupsound

    doublecommand

    m-audio firewire audio helper

    pacesupport

    qmaster

     

    6. login items

     

    caffeine

    cinch

    little snitch

     

    7. I opened another user account and there's no apparent issue, although I haven't had all day to test it.

     

    Thanks for the response.

  • X423424X Level 6 Level 6 (14,205 points)
    7. I opened another user account and there's no apparent issue, although I haven't had all day to test it.

    Given what you describe as to when mail is popping up (i.e., ever after logging in), and I am going to assume for the moment that your last point remains true and mail won't auto-launch in another account, then my first suspicions are one of the things in ~/Library/LaunchAgents.

     

    I trust (and use myself) Little Snitch.  So forget those two launchagents.  That leaves,

     

    com.trusteer.rapport.rapportd

    com.wacom.pentablet

    org.glimmerblocker.updater

    org.thebends.iphonedisk.mobile_fs_util

     

    So, as an experiment I would remove these one by one to see if mail stops launching.  And if I had to choose an order I would go with com.trusteer.rapport.rapportd, org.thebends.iphonedisk.mobile_fs_util, org.glimmerblocker.updater, and lastly com.wacom.pentablet.

  • TresRoque Level 1 Level 1 (85 points)

    I deleted all those you recommended, but the problem persists.

     

    Meanwhile, no Mail jumping at me in the other user account.

  • X423424X Level 6 Level 6 (14,205 points)

    Try removing that cinch login item.  Forgot to mention that previously.

     

    Also there is no need to make Little Snitch a login item.  How often do you explicitly open Little Snitch Configuration that you would need to have it pre-launched.  Just put Little Snitch Configuration in your dock for those times when you need it.

     

    Leave Caffeine alone.  I have that one as a login item too.  No problems from it.

     

    If none of these things solve the problem then it will have to be one of the global items in /Library (StartupItems, LaunchAgents, LaunchDaemons).  That's confusing since you say logging into another account doesn't have the problem which is why I was picking on user-specific stuff first.

     

    Note, I forgot to request that you post the contents of /Library/LaunchDaemons.  So post it too if that that cinch login item is not the culprit.

  • TresRoque Level 1 Level 1 (85 points)

    Thanks for getting back to me on this.

     

    In the /Library/LaunchDaemons folder:

     

    com.apple.third_party_32b_kext_logger

    org.glimmerblocker.proxy

    com.trusteer.rooks.rooksd

    at.obdev.littlesnitchd

    com.m-audio.firewire.helper

    PACESupport

    anacron

     

    I googled the above and found that the trusteer plist is dodgy, so followed the instructions here:

     

    http://www.trusteer.com/uninstalling-rapport-mac-os

     

    to uninstal.

     

    Will get back to you if this is the solution.

  • X423424X Level 6 Level 6 (14,205 points)

    While this may not have anything to do with your problem I would suggest you get rid of the PACE anti-piracy stuff and there is really no reason for using anacron on snow leopard.  It made sense in tiger to be able to get, for example, periodic maintenance tasks to run once you machine was awake, but unnecessary with launchagents and launchdaemons in snow leopard.  Is there some other cron task(s) you need anacron for?

     

    Hmm, given that you have anacron, and I asked if you have any cron tasks scheduled, cron can be user specific.  So, just in case, in terminal, post the output from the following command:

     

    crontab -l

     

    (that's a dash "ell" argument if it isn't clear in the font)

Previous 1 2 3 4 Next