12 Replies Latest reply: Apr 10, 2012 2:49 PM by darkera
Derryl S Level 2 Level 2 (185 points)

I am getting the information (a yellow caution triangle) in print dialogs and the printer supply levels in the system prefs that the Maintenance Kit for my Lexmark laser printer (E460dn) needs to be replaced and the barline shows that it is down to about 10%. The kit needs to be replaced after 120,000 copies. Yet, if I run a report direcly from the printer, it says I have printed just a little over 17,000 total pages and that the kit is at 90% which is about right for the number of copies.

 

The toner and fuser levels in the sys prefs for the printer seem to always be accurate. The Maintenance kit bar line was always nearly full scale until recently. The toner cartridge was running out and it has been changed. I thought the caution was for the toner cartridge, but the triangle symbol was still there after replacement so I investigated further.

 

Is there something that can reset or correct the information the system printer prefs pane that is totally inaccurate. There is on that window a message that the levels shown are approximate, but 80% in error is a long way from approximate! Fortunately I checked the printer's report before I spent $150 unnecessarily.


Any suggestions?


Mac Pro, Mac OS X (10.7.2), 2.8 GHz Quad core, 6 GB ram
  • 1. Re: Inaccurate information for printer supply levels in Sys Prefs
    sig Level 8 Level 8 (35,770 points)

    Contact Lexmark.

  • 2. Re: Inaccurate information for printer supply levels in Sys Prefs
    Michel Mommaerts Level 1 Level 1 (15 points)

    I to am having this issue with 10.6.8 and an e120n printer. I'd love to get rid of the Low Supplies warning. I've reset the printer system and reloaded the driver etc without any luck.

     

    Mitch

  • 3. Re: Inaccurate information for printer supply levels in Sys Prefs
    Derryl S Level 2 Level 2 (185 points)

    I run Snow Leopard on another drive in this computer and the same wrong information appears in Supply Levels in prefs as well, so it is not a specific problem to Lion. The warning just appeared in the last 30 days.

     

    Lion Sys Prefs for the printer says driver is 10.7.0. Lexmark released a driver update on July 21, 2011, version 1.0.51. Lexmark says to either use the Apple updater or download from Lexmark for Lion compatibility. I got the new computer in September with Lion installed. It has no software updates to be done.

     

    With that information, it looks like the ball is in Apple's court for proper implementation in the Sys Prefs as it is not getting/intrepreting the information correctly. The printer printout of supplies is correct.

     

    All I want is the information to be correct on the Mac and get rid of that yellow warning triangle (which is false information) that I see eveery time something is printed. The other two items monitored in that screen are correct. Why not all three?

  • 4. Re: Inaccurate information for printer supply levels in Sys Prefs
    Cattus Thraex Level 4 Level 4 (1,715 points)

    Many printers have the same problem, especially (in my experience) when connected to a wl router.

    I have no solution than to accustom to these false messages, you can live with them just as I have been living with them (HP printers)

  • 5. Re: Inaccurate information for printer supply levels in Sys Prefs
    Derryl S Level 2 Level 2 (185 points)

    This is not a wireless router issue as the network is a hardwired router to the computers and printers.

    WiFi connections would be 40% slower than a direct cable connection.

     

    The fact remains, this just occured in the last 30 days. It has not occured in the past two years I have had this printer.

  • 6. Re: Inaccurate information for printer supply levels in Sys Prefs
    Cattus Thraex Level 4 Level 4 (1,715 points)

    I rephrase: ... misguiding ink level in both wl and wiered networks.

  • 7. Re: Inaccurate information for printer supply levels in Sys Prefs
    PAHU Level 6 Level 6 (14,510 points)

    As you mention, this issue first appeared with 10.6.8 due to changes made to CUPS where a function "backend SNMPsupplies" reported warnings rather than errors. For certain brands of printers this call resulted in the incorrect information being reported back to the Mac. While the CUPS organization released a patch to resolve this it seemed that Apple did not do the same and relied on the vendors to change their drivers.

     

    One common workaround at the time was to modify the PPD for the printer so that the SNMP calls were not made. This is done by adding the line "*cupsSNMPSupplies: False" to the printers ppd file located in the /etc/cups/ppd. Note that you will need administrative privileges to perform this workaround.

     

    Before showing the workaround I have to say that I have not heard this issue happening with Lion, but then the printers I support that had this issue on 10.6.8 have no official Lion drivers yet. Given that it only just started recently you would have to question what has changed for this to appear. Does System Preferences > Software Update > Installed Updates show any update around this time?

     

     

    The following steps for 10.6.8 were posted by EFI in their Tech Ticker Alert, posted June 27, 2011.

     

    For this example we will use ColorPrinter as the name of the printer affected by the 10.6.8 update.

     

    1. From the Finder menu choose Go, then Go to Folder...
    2. Enter /etc/cups/ppd in the Go to Folder dialog box and choose Go.
    3. Find the ppd named ColorPrinter.ppd. (This is the same name as the ColorPrinter in Print and Fax with a .ppd extension. )
    4. Drag the ColorPrinter.ppd to the Desktop.
    5. Open the ColorPrinter.ppd with TextEdit.
    6. At the end of the PPD add the following line exactly as written: *cupsSNMPSupplies: False
    7. Save the modified ColorPrinter.ppd to the Desktop.
    8. From the /etc/cups/ppd folder, move the original ColorPrinter.ppd to the trash. Authenticate when prompted.
    9. Drag the modified ColorPrinter.ppd from the Desktop to the /etc/cups/ppd folder. Authenticate when prompted.

     

    Printing should now work as expected.

  • 8. Re: Inaccurate information for printer supply levels in Sys Prefs
    Derryl S Level 2 Level 2 (185 points)

    I show a Lexmark Printer Software update version 2.6 being installed on 9/9/11, which is shortly after I got the new machine with the installed Lion. I had printer issues at that time, but the Apple update resolved them. The OS X 10.7.2 update occured on 10/12/11 and that might be where the issue began and I am just mistaken on how many weeks this has been going on.

     

    From the dates, the apple printer update is the most recent and there were no messages at that time. The Lexmark update occured before I had this machine and Lion. I am suspectiong the 10.7.2 update. I have not checked into the 10.6.x OS updates on the other drive, but this problem is occuring in both. The 10.6.x drive is also up to date from Apple.

     

    I appreciate the instructions, but I may stay with the error because it lets me know easily about other supplies that is working for.

  • 9. Re: Inaccurate information for printer supply levels in Sys Prefs
    Derryl S Level 2 Level 2 (185 points)

    A Lexmark driver update came out from Apple yesterday. It did NOT correct the problem.

     

    Still waiting for a reply from Lexmark. Got an auto reply email two days ago they would assist me "as soon as possible"

  • 10. Re: Inaccurate information for printer supply levels in Sys Prefs
    Derryl S Level 2 Level 2 (185 points)

    Got a response from Lexmark stating:

     

    "The OPC at end-of-life or Optical Photoconductor needs to be replaced is actually a known issue with MAC OS 10.6.x and 10.7. We see it also happening to other printers from other manufacturers. MAC will try to get the supply information from the printer and if it fails to do so then it will show that message."

     

    They then instructed to do the following:

     

    "There are a few things that we can do to try and resolve this problem.

    Please make sure that you have the latest firmware for your printer.

    Go to http://support.lexmark.com/printerfirmware, and type in the keycode "e46x" to download the firmware.

     

    Please Uninstall and Re-install the print driver after the update.

    Go to http://support.apple.com/kb/DL1397 and download the 2.7 driver.

     

    One other thing you can do is to Disable SNMP on the prnter.

    Just go to Network / Ports and Select SNMP and set it to disable."

     

    Updating the firmware appears to have corrected the problem as the warning triangle is gone and the bar in System Prefs supply levels for the printer look accurate. Since I had already updated the Apple driver for Lexmark a few days ago, I did not do the remaining steps. Apparently something in an Apple update some time in the last 30-60 days did not play well with the Lexmark printer firmware (and apparently a lot of other printers) and it needed to be updated.

  • 11. Re: Inaccurate information for printer supply levels in Sys Prefs
    Cattus Thraex Level 4 Level 4 (1,715 points)

    That is good. I would need that for HP 2460

  • 12. Re: Inaccurate information for printer supply levels in Sys Prefs
    darkera Level 1 Level 1 (0 points)

    Derryl,

    thank you for this last message!

    I had a very similar issue with a T630 Lexmark printer.

    It would always say "Unable to query ink levels" or "Unable to query toner level".

    The very competent Lexmark support rep confirmed that a firmware upgrade is useful for OPC errors.
    In my case however, I was directed towards the PPD file 1.08, which is available for download for Windows 2000 (but works well with Mac OS X 10.6 and 10.7).

    Once that PPD was in place, the printer resumed working under 10.6 just as it did before under previous versions of Mac OS X 10.4.

    Of course, the best would be if Lexmark incorporated that 1.08 PPD file into the Lexmark printer driver for the T630 (which still has version 1.07, which won't work on Snow Leopard or Lion).