Previous 1 2 3 4 Next 46 Replies Latest reply: Aug 31, 2014 12:00 PM by borgy1
Baron Sekiya Level 1 Level 1 (20 points)

Weird problem just cropped up today on my iPhone 4 (no longer under warranty). If I try to play the Music app, Pandora, YouTube and many other sound apps I can't hear the audio over the speaker and on some apps a message appears saying 'No Volume Available' on the screen. It has this message in Pandora, in YouTube and the music app just don't have the volume slider.

 

If I plug in headphones all work normally.

 

If I use the Phone app, or Talkatone I can hear the audio via the earpiece and I can switch it to the speaker. So I know the speaker system works as some apps detect the speaker and can route audio through there. Skype on the other hand works via speakerphone but not via the earpiece. Key-clicks and lock sounds don't work via the speaker.

 

I've reset the iPhone a few times, 2x via holding down the power key and shutting it down then restarting with the Apple logo and once forcing a shutdown via power+home buttons.

 

I've restored the iPhone, I'm running iOS 5.0.1, bluetooth is off, mute switch on the side is on (I've switched it both on and off, didn't do anything). I've tried plugging/unplugging in headphones to see if debris or something would be knocked loose but that didn't work. Plugging/unplugging dock connector several times didn't work either.

 

I'm wondering if an app I tired did something weird electrically? I had a headphone jack plugged-in and ran the TASCAM recording app to try and record something. Had a tough time figuring it out and it was while I was trying it that the problem seemed to occur as I couldn't hear anything recorded via the app.

 

I've since removed the app and done all of the above to no avail. I'm going to try another restore. And don't suggest I just go to an Apple Store, the nearest one is a few hundred miles away on another island.


iPhone 4, iOS 5.0.1
  • Baron Sekiya Level 1 Level 1 (20 points)

    Did another restore and still no audio. Very strange.

     

    I did more of the plug/unplug Apple headphone and that didn't work.

     

    I tried cleaning the headphone hole following this video http://www.luckow.com/iphone/

    but I didn't use Windex, that sounded a bit crazy. I used a cut q-tip and some Deoxil D5 electronic cleaner.

     

    Still no sound out of the speaker from keyclicks, Music app, etc.

  • Baron Sekiya Level 1 Level 1 (20 points)

    Did yet another restore. Did a remote wipe first to see if that would clear out anything left behind the others didn't. The weird thing is that I can get the keyclicks to work in a way:

    1. Remote Lock the iPhone from iCloud

    2. Send a Play Sound alert to the iPhone

    3. When I tap my passcode to unlock the proper clicking sounds are there

     

    But the sound control doesn't stick. It still doesn't work via the speaker.

     

    Also. If I put the iPhone 4 into a speaker dock it plays through the dock fine and sometimes when I remove it from the dock the volume control is shown like it's supposed to and I get maybe 1/4 second of audio then the volume control disappears once again.

     

    So I've cleaned the contacts on the dock connector on the bottom of the iPhone 4 and still don't have speaker audio.

  • Baron Sekiya Level 1 Level 1 (20 points)

    More contact cleaning, more reboots but speaker system is still messed up.

     

    The built-in Voice Memos app works normally and can playback audio through the speaker.

     

    Pandora, Music App, NPR apps, Guitar, Magic Piano are all dead sending sound out via the speaker.

     

    Anyone else out there experience this?

  • Baron Sekiya Level 1 Level 1 (20 points)

    Weird workaround

    If I have both Skype and Apple music app going, make a Skype call, put it into speakerphone mode (sound comes out of the speaker as normal), open the App Dock, switch to Apple Music app and hit play the volume control remains up and works normally (though the audio is playing over the Skype call's audio).

    So it seems like more of a software issue rather than a hardware one since Skype and Talkatone work normally and this weird workaround works.

  • Harsh Singh Level 1 Level 1 (0 points)

    Hi There. i am also facing the same issue... exactly the same issue but i am using Iphone 4s.

     

    I also tried to restore the Iphone via itunes and by going into recovery mode but no luck... i was going though the apple forums and it seems to be a hardware issue.

     

    Harsh

  • adibell Level 1 Level 1 (0 points)

    Same problem here for the past week. It all started when I plugs my iPhone into the (official apple) dock to charge overnight as normal, and for some reason it brought up the non-compatible notice, and then tried to listen to music through headphones the morning after, got a couple seconds audio then nothing, unplugged the headphones and then plugged them back in and audio worked gone through headphones, but hen I take the headphones back out, just have no volume controls, no music will play, sound works fine in voice memo app, but not in music, YouTube or most audio related apps.

     

    Odd.

     

    Tried turnin off and on, and resetting (home+power buttons held), but still the same...music controls only appear when I plug in the headphones.

     

    Odd.

     

    Hopefully this is a software fix apple will have a fix for soon enough! Anyone got any solutions in the time being?

  • Michelle Newcomb Level 1 Level 1 (0 points)

    Same here with an iPhone 4.  With the exception of the specific music apps (which I don't have), it all goes down exactly as Baron described.

     

    If I bought this phone the week after Christmas last year, is it worth a trip to the Apple Store this week? 

  • Michelle Newcomb Level 1 Level 1 (0 points)

    I have been sitting here for an hour or so, phone upside down in my robe pocket.  It vibrated with the email from my Genius bar appointment, and I unlocked it WITH KEY CLICKS.  I've now locked and unlocked more than 15 times, volume sliders are back and buttons are working and all seems fine.  (I had a problem with it sticking in landscape mode earlier this year that resolved itself after a couple of days, too.)

     

    I think I'll keep my Genius appointment until the last minute, just in case...

  • Wrangler2004 Level 1 Level 1 (0 points)

    Same issue here on iPhone4. I get "no volume available message" out of different apps. Whenever this happens, I can plug it into the computer, then immediately unplug it and 99% time it will play sound, but only for a few seconds before I get the no volume available message. Also, when I try dialing a number (without headphones plugged in or silent mode turned on) I don't hear the dialing sound when pressing a number. I've also done a system restore and removed unwanted apps with no luck. I'm running iOS 5.0.1.

  • Michelle Newcomb Level 1 Level 1 (0 points)

    My problem came back off and on, so I went in to the Apple Store, where of course, the problem refused to show itself.  The guy said that there are pins inside the headphone jack that were probably messed up and causing it to think there were headphones plugged in.  And they replaced my phone, with one week left in warranty. 

  • DorothyPD Level 1 Level 1 (0 points)

    I have had the exact problem with my new iPhone 4S.  I noticed it wasn't ringing and I went to play music and my volume control slider was gone.  I called support and we rebooted, wiped the system clean, reinstalled the software, reset up the phone, and restored....nothing we tried resolved the problem.  When the headphone jack is plugged into the phone, the volume slider reappears.  The minute the jack is unplugged, the volume slider is gone.  I was told this is a software issue and I am receiving a new phone in the mail.  However, after reading this thread, I fear that I will have the same issue with the next phone.  I am finding refererences for this issue all over the net.

  • DorothyPD Level 1 Level 1 (0 points)

    It occurs to me that there is a flaw in the headphone jack port.  This must Jam not allow the system to restore to open mike.

  • Baron Sekiya Level 1 Level 1 (20 points)

    I went to an Apple Store and let a 'Genius' check it out. First thing he says is that the water damage indicator was activated in the bottom dock connector. I've never dropped my iPhone 4 in water though I probably do live in one heck of a humid place so maybe that's why it activated. He had opened it up and I asked him if there was any indication at all if there was water damage in the iPhone and he said 'no.'

     

    I let him wipe the phone since I had it backed-up via iTunes. Then it started to work and thought we had it fixed but then all of a sudden it stopped producing sound again. This is with no extra apps loaded on it and right there at the Genius Bar with the Genius there. He operated the controls and was just stumped.

     

    He said because it was out of warranty I could get a replacement one there at Apple for (I forget) something like $149, or I could wait a few week when I can get an early upgrade to an iPhone 4S for $199 (that would only be for the 16GB model, mine is a 32GB iPhone 4).

     

    So yeah, the Genius couldn't figure it out. The phone's sound continues to have this problem along with the problem, which I hear many people have, of the home button being disfunctional at times. The iPhone 4 is a flawed design in so many ways: Antenna, Home Button, Audio System, Lower Battery life with iOS 5.

  • Baron Sekiya Level 1 Level 1 (20 points)

    My iPhone 4 is now fixed. I had a third party shop replace the dock connector on the phone. Final cost was about 1/3 of what it would have cost me to do an exchange at the Apple Store. Now my iPhone 4 speaker works fine, even the home button doesn't have any problems as before it would be unresponsive at times.

Previous 1 2 3 4 Next