11 Replies Latest reply: Jul 25, 2012 2:21 AM by stefzke
iRik1988 Level 1 Level 1 (0 points)

Shall i begin to say i love Apple and their great products so much! iI bought a 27'' iMac with snow leopard on it. I really was excited about OSX Lion, and it definilty make it expantasion clear it's a great os!

 

However since the upgrade to Lion there are some issues with the wi-fi conection it sometimes drops then i must reconect the iMac to my router then it works agian. Also the internet connection is very slow. i tried anything you can think of: Switch of wi-fi and then turn it on agian, remove the wi-fi and then enter the same router,switch security settings,switch the channel,reset DRAM it does't solve the problem. I really hope Apple can fix this issue,Aside from the Lion wi-fi drops my iPad had a issue with wi-fi as well under iOS 4.2 the wi-fi sometimes dropped under iOS 5 this is solved.


iMac, Mac OS X (10.7.2)
  • sig Level 8 Level 8 (35,780 points)

    How old is your router? Have you the latest firmware installed on the router?

  • iRik1988 Level 1 Level 1 (0 points)

    The Router is from 2009 it's a Sitecom it only a wireless G router. It proberly runs the original firmware.But as many complian about this issue this is proberly a driver problem in Lion.

  • Glenn Leblanc Level 6 Level 6 (8,580 points)

    I've seen posts that some are creating a new network location for the wi-fi to solve the problem of the intermittent drop offs. I didn't look for the discussion, but I believe they just added the wi-fi to the new location with a different name and left the other.

    It won't hurt you to try it.

  • iRik1988 Level 1 Level 1 (0 points)

    I already tried that, it doest have to do anything with the wi-fi location the problem continues to excist.

    I locked the settings becouse it should work with the automomatic setting in Lion.

  • Glenn Leblanc Level 6 Level 6 (8,580 points)

    OK. I have 2 suggestions that you may have already done.

     

    Depending on where your internet connection is made, either router or modem, do you have the dns addresses input manually or to gotten from the service provider. I had problems wiht the default setting of have it provided, so input manually. I've even changed mine to the open DNS servers 208.67.222.222 & 208.67.220.220 which seem to work better that ATT and a little faster internet.

     

    If you're using manuel DCHP settings in the Network preferences, change it to using DCHP and renew lease. I put the router address as the DNS server in the advanced pane sincemy router makes the internet connection to the DNS servers.

  • iRik1988 Level 1 Level 1 (0 points)

    Yes mate i have already changed it and the issue is still not fixed. . There is only 1 fix that works for 100% and that is sadly downgrading to Snow Leopard. I have no plans to downgrade to Snow Leopard.

  • sig Level 8 Level 8 (35,780 points)

    Update your firmware.

  • Glenn Leblanc Level 6 Level 6 (8,580 points)

    Sorry, don't know what else to say. So many posts on the subject with so little success.

     

    I would suggest a router upgrade, but may not solve the problem. Check for router updates on the one you have. Since it's old, there are probably updates for it.

  • Guntis Level 1 Level 1 (35 points)

    Try this solution:

    http://osxdaily.com/2011/11/06/lion-wi-fi-problems-solution-mac/

     

    Before proceeding, make sure you have done the following:

    • Be sure you are running the latest version of Mac OS X ( get 10.7.2+)
    • Apply all available system and software updates available to your Mac from  Apple menu > Software Update
    • Reset the WiFi Router

    After you’re positive you’re on the newest version of OS X and have all software updates applied to the Mac in question, proceed with the solution:

    Add a New Network Location & Renew DHCP Lease

    • Launch “System Preferences” from the  Apple menu
    • Select the “Network” panel
    • Click on the “Location” pull down menu and choose “Edit Locations…”
    • Click on the + plus icon to add a new network location, give it a unique name, and click “Done”
    • Back at the Network panel with the newly created location selected, click on “Advanced” in the bottom right corner
    • Click on the “TCP/IP” tab
    • Click on “Renew DHCP Lease” and wait for the numbers on the left to repopulate, then click “OK”

     

    You should now have a stable wireless connection under Mac OS X Lion 10.7.2.

    For most users the wifi stability issue was resolved with installing the latest OS X Lion updates, but in some cases is seems that old network connection profiles brought the problem forward for to the newest OS update. You may have to enter the wireless network password again before you can connect to the router, if you don’t know that be sure to find it out from someone who does before troubleshooting with this tip.

  • foj774 Level 1 Level 1 (0 points)

    That does not work for me. I've done it numerous times on various wi-fi networks I use. On one unsecured network, the wi-fi connection came back automatically as I did other work, but I could not replicate how. Also, at two other locations that are important, and where I cannot influence the router settings (which work for all other user, as far as I can tell), I cannot restore the connection for the life of me. My wi-fi icon shows greyed-out bars with an exclamation point icon through the middle. I am on 10.7.4 now, but have had problems since 10.7.2. Here is some of the crap I get:

    5/20/12 5:48:10.513 PM UserEventAgent: CaptiveNetworkSupport:CaptivePublishState:1211 en1 - PreProbe

    5/20/12 5:48:10.545 PM configd: network configuration changed.

    5/20/12 5:48:17.000 PM kernel: en1: 802.11d country code set to 'US'.

    5/20/12 5:48:17.000 PM kernel: en1: Supported channels 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64 149 153 157 161 165

    5/20/12 5:48:18.000 PM kernel: AirPort: Link Up on en1

    5/20/12 5:48:18.000 PM kernel: en1: BSSID changed to 00:23:69:ee:c2:10

    5/20/12 5:48:19.596 PM airportd: _doAutoJoin: Already associated to “FREE Knology Hot Spot”. Bailing on auto-join.

    5/20/12 5:48:22.511 PM mDNSResponder: mDNS_RegisterInterface: Frequent transitions for interface en1 (FE80:0000:0000:0000:0219:E3FF:FED8:8CA8)

    5/20/12 5:48:36.099 PM configd: subnet_route: write routing socket failed, Network is unreachable

    5/20/12 5:48:37.717 PM configd: network configuration changed.

    5/20/12 5:48:37.744 PM UserEventAgent: CaptiveNetworkSupport:CaptivePublishState:1211 en1 - Probe

    5/20/12 5:48:37.753 PM UserEventAgent: CaptiveNetworkSupport:CaptiveStartDetect:2371 starting probe to determine captivity...

    5/20/12 5:48:37.753 PM UserEventAgent: CaptiveNetworkSupport:wispr_detect_redirect_async:424 user-agent:"CaptiveNetworkSupport-173 wispr" url:"http://www.apple.com/library/test/success.html"

    5/20/12 5:48:37.755 PM UserEventAgent: async_http_read_stream:375 kCFStreamEventErrorOccurred kCFErrorDomainCFNetwork/2: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error 2.)

    5/20/12 5:48:37.755 PM UserEventAgent: CaptiveNetworkSupport:wispr_detect_http_done:196 DNS failure - scheduling timer to try again in 0.10 seconds. retryCount=1

    5/20/12 5:48:37.857 PM UserEventAgent: async_http_read_stream:375 kCFStreamEventErrorOccurred kCFErrorDomainCFNetwork/2: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error 2.)

    5/20/12 5:48:37.857 PM UserEventAgent: CaptiveNetworkSupport:wispr_detect_http_done:196 DNS failure - scheduling timer to try again in 0.10 seconds. retryCount=2

    Not sure that makes any difference. Any help is appreciated.

  • stefzke Level 1 Level 1 (0 points)

    Hi,

     

    I have basically the same problem. The network I want to connect to, I cannot influence (router etc). DHCP cannot negotiate an IP address nor is the standard gateway set. I don't understand why everything works fine on all other networks I use except this one... Also a bunch of other people (including other mac users) have no problems connecting to this network. Have you solved this problem yet?

     

    Best regards,

     

    Stefan