Skip navigation

SSL ERR_get_error deprecated

337 Views 0 Replies Latest reply: Dec 12, 2011 1:00 PM by GuyHelmer RSS
GuyHelmer Calculating status...
Currently Being Moderated
Dec 12, 2011 1:00 PM

Tried building a C application under OS X Lion that uses the OpenSSL library but I am getting this link error for two of the OpenSSL function calls:

 

Undefined symbols for architecture x86_64:

  "_ERR_get_error", referenced from:

      _main in ccoD9L1k.o

      _icap_io_startssl in ccoD9L1k.o

  "_ERR_error_string", referenced from:

      _main in ccoD9L1k.o

      _icap_io_startssl in ccoD9L1k.o

ld: symbol(s) not found for architecture x86_64

collect2: ld returned 1 exit status

*** Error code 1

 

Any thoughts?

 

Thanks,

Guy

MacBook Pro, Mac OS X (10.7)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.