13 Replies Latest reply: Aug 1, 2013 6:35 PM by johnfromcedar rapids
ajb66 Level 1 Level 1

I tried to import a new cd and it won't show up in iTunes.  After about 10-15 seconds the cd is ejected. 


MacBook Pro
  • shldr2thewheel Level 7 Level 7

    The drive accepts discs but they do not mount or are automatically ejected

    1. Check the disc's surface for scratches and dirt, since these things can prevent the disc from appearing on the desktop.
    2. Reset the Power Manager (PMU) or System Management Controller (SMC).
    3. Ensure your drive can read the specific type of disc being used. For example a "combo drive" can read a DVD-R and burn a CD-R however it cannot burn a DVD-R. The utility System Profiler may provide additional information regarding what media your computer supports.
    4. If the discs continue to not be recognized, please contact Apple, contact an Apple Authorized Service Provider, or make an appointment with an Apple Retail Store for additional troubleshooting, evaluation, or service.
  • ajb66 Level 1 Level 1

    Thanks for the suggestions.  I gave them a try, but no joy so I guess I'll be making a trip to the genius bar later this week.

  • shldr2thewheel Level 7 Level 7

    does it play dvd's and just not cd's?

  • ajb66 Level 1 Level 1

    Hadn't thought to try that.  DVD worked just fine.  So, it must be a problem with iTunes and not the hardware?  A quick check shows a new version 10.5.2 available.  I'll try installing it.  Maybe that will solve my problem.

  • ajb66 Level 1 Level 1

    Thanks. I tried resetting the SMC but that didn't help. I just checked the software and there is an update so I'm giving that a shot.

  • ajb66 Level 1 Level 1

    The software update seems to have fixed it (at least for now). I can't believe I didn't think to check for an update before I posted here. It is weird though since I imported a cd a few days ago with no problem and then without any changes it suddenly stopped working. I guess that is part of the magical mystery of computers.

     

    Thanks again for your help!

  • shldr2thewheel Level 7 Level 7

    The new itunes update was just released today

  • ajb66 Level 1 Level 1

    Unfortunately it only worked to import 1 cd.  When I tried to import a second cd it wouldn't recognize the cd and ejected it again after about 15 seconds.  Ugh!

  • Karen Cardoza Level 1 Level 1

    The same thing is happening to me. I have some CDs that I bought last year and they mount and play. I just got two new ones this year and they won't mount. I can play them on a PC though and had done that first. It's weird that these two new ones are not recognized on my MBP.  Now, I can't rip them to play on my ipod. :-(  Unfortunately, my Apple Care has run out so a trip to the genius bar will likely cost me a lot for an annoyance. Has anyone else had this happen and is the a solution?

  • ajb66 Level 1 Level 1

    I ended up at the Genius Bar.  They determined that the laser on my CD drive wasn't working properly.  The likely cause was a CD a student tried to use for a presentation that had apparantly been soaked in cheap perfume before she put it in my computer.  Ugh! 

     

    $160 later I have a new optical drive and everything works great.  They had the part in stock so it only took a couple of days. 

     

    Sorry I don't have a better fix.

  • Ellyenne Level 1 Level 1
    expertise.desktops
    Desktops

    I had this problem AFTER the last iTunes update.  I purchased a commercially made CD and it would not load.  It would try to load 3 times, then eject. It played on all my other CD players.  I could even play it on the PC at work.  This was brand new in a sealed case.

     

    I've loaded 100's of CD's before & several after this onewithout problems, so I knew it wasn't a problem with the CD/DVD internal drive. But, I still did everything the troubleshooting page said, and nothing worked. This was still the only CD I've ever had that wouldn't load in iTunes.

     

    After searching the forum, I found some archived posts.  One mentioned using an external CD drive. I dug out an old QueFire I purchased for $20 when my G4 Cube's "toaster" CD player failed, and plugged it in.

     

    Worked perfectly. Loaded fast and VERY clean.  Better than the internal drive.

  • johnfromcedar rapids Level 1 Level 1

    I had the exact same problem. I have a BluRay/DVD cleaner disk I used for my BluRay player and put that in my drive. It behaved the same way as the CDs. It spun for about 15 secs, then ejected. I then put in the CD that wouldn't run before and it ran perfectly.