Previous 1 2 3 4 Next 58 Replies Latest reply: Apr 14, 2012 11:00 PM by sjsammydee Go to original post
  • maxgruv Level 1 Level 1

    Yes, that's the one I turned off and might have done the trick.

  • tonyakay13 Level 1 Level 1

    I'm trying it out now.  Turning off iCloud bookmark synching for Safari seems to be working currently!

  • Jon_E Level 1 Level 1

    For some reason, cookies are no longer resetting to never. I don't know what changed. I do have Safari bookmarks backup on iCloud ON so that's not a problem for me at least.

  • toddrubi Level 1 Level 1

    Don't have iCloud, yet, but ---

     

    I cleared "History" and cleared "Cookies and Data":

     

    Settings>Safari>Clear History

    Settings>Safari>Clear Cookies and Data

     

    It didn't really work. The "Accept Cookies" under Settings>Safari>Privacy still went to "Never" by itself today. 

  • dantastic1 Level 1 Level 1

    For what it's worth, I've been having the same problem ever since I got my iPhone 4s.  I've been trying to isolate what triggers the cookie setting change, but so far I haven't had much luck.  I do have one suspicion which is that the settings change occurs when my phone reconnects to the guest wifi network at my workplace.  This is a secured but open network in which I have to enter login credentials on a webpage to get access - similar to many hotels.  The iPhone remembers the credentials, so I don't have to enter them each time.  But it seems that when I reconnect after being gone for a day or two (i.e. after my current login has expired), the cookies become disabled.

     

    I'm curious if anyone else on this thread is routinely connecting to a login/password secured wireless network.  Perhaps there's some connection, perhaps not.

     

    I look forward to finding a permanent fix for this issue!

  • RonfromCOS Level 1 Level 1

    Like all of you, I have been having the same problem for a while now, ever since IOS 5 came out. I can't figure out what triggers the reset to "Never accept cookies" but I have gone so far as to restore my iPhone 4 with no luck. Glad to know I'm not alone at least. I have noticed that it has reset after a sync (wired in my case) and without syncing. I've go no clue what triggers this.

  • sjsammydee Level 1 Level 1

    I have this same problem too.  Like some of you, I think it happens after a WiFi sync.  I don't have an Exchange account.   It's quite frustrating; hope Apple can fix this ASAP.

  • sandbox32 Level 1 Level 1

    iPhone 4S / iOS 5.0.1 / iCloud bookmarks OFF

     

    Cookies are still resetting to Never, but I only use iCloud for Find My iPhone. I'll try to test the problem after Wi-Fi sync and when connecting to unsecured Wi-Fi.

  • RonfromCOS Level 1 Level 1

    My cookies have been resetting to never but I don't sync via Wi-Fi. I'm a hard line syncer. I am not sure about the corralation between iCloud and cookies resetting, but it very well may be the case. I don't beleive the problem has anything to do with unsecured networks since I have seen my reset on secured networks plenty of times.

  • crikey2 Level 1 Level 1

    Yup i get the safari accept cookies resetting to Never all the time too on my 4S. First iPhone product I've had, so I thought this was possibly "normal" behaviour so it's nice to hear its not - would be even nicer if Apple fixed it though!

  • ggkkss Level 1 Level 1

    OK - so everyone here agrees that it is a problem...  How we do we get Apple to notice this discussion, acknowledge that there is a bug and (most importantly) fix it?!?

     

    Hey Apple!  Yo! Over here… we’re all getting very frustrated.

  • Lawrence Finch Level 8 Level 8
    expertise.macosx
    Mac OS X

    Do you have an Exchange email account from your employer or school on your phone? If you do it is likely that your Exchange security policy is disabling cookies on the phone. If this is the case then Apple can do nothing about it.

  • sjsammydee Level 1 Level 1

    I, for one, do not have an Exchange account ... and every single time my phone syncs with iTunes the policy gets reset to "None". 

  • olson4 Level 1 Level 1

    One more user here having the same problem and having no luck identifying the culprit. Frustrating!

    I do use Exchange and sync to iCloud.

  • sandbox32 Level 1 Level 1

    Send a bug report to http://www.apple.com/feedback/ (or http://bugreport.apple.com/ for those with developer accounts). From what I've heard, Apple responds very well to duplicate bug reports. Try to link to as many of these forum threads as you can.