Previous 1 2 Next 15 Replies Latest reply: Dec 18, 2011 11:41 PM by skyetbc1997
Damienfromdublin Level 1 Level 1 (0 points)

Hi there folks,

I have an iMAC G5 with the leopard version 10.5.8 about a week ago in facebook it started asking me to update my flash player to be able to watch video's or upload photos which i thought was only a facebook thing as they always change the layout from time to time, but yesterday my youtube videos stopped working now also and its saying i need to update my flash player too so i presume adobe have released a newer version. which is driving me crazy cause i have tried everything possible to download flash player for my version of mac only to find that aparently the new flash player doesnt support PPC MAC, i have been onto support which told me to uninstall the version i had and reinstall the 10.1 archived version on the adobe website which i did succesfully but still no luck, im not a mac wiz and sometimes regret getting one as i just seem to have problems with it from time to time. although they look great and when working are amazing im beggining to wish i had just a normal pc which would be more compatible with everything else ugh, i just wanna fling this out the window now , can someone please help me with what to do i would be SO GRATEFULL PLEASE and THANKYOU . Damien


iMac, Mac OS X (10.5.8)
  • Klaus1 Level 8 Level 8 (46,775 points)

    I share your pain.

     

    The only real answer is to start again:

     

    The latest version of Adobe FlashPlayer can be obtained from here:

     

    http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFl ash

     

    You can check here what version of Flash player you actually have installed:  http://kb2.adobe.com/cps/155/tn_15507.html

     

    You can check here:  http://www.adobe.com/products/flash/about/  to see which version you should install for your Mac and OS. Note that version 10,1,102,64 is the last version available to PPC Mac users*. The latest version, 10.2.152.25, 10.3.x beta, or later, is for Intel Macs only, as Adobe no longer support the PPC platform. Version 11.0.1.152 is for Lion.

     

    * Unhelpfully, if you want the last version for PPC Macs, you need to go here:  http://kb2.adobe.com/cps/142/tn_14266.html  and scroll down to 'Archived Versions/Older Archives'. The first one on the list, Flash Player 10.1.102.64 is the one you download. More information here:  http://kb2.adobe.com/cps/838/cpsid_83808.html

     

    You should first uninstall any previous version of Flash Player, using the uninstaller from here (make sure you use the correct one!):

     

    http://kb2.adobe.com/cps/909/cpsid_90906.html

     

    and also that you follow the instructions closely, such as closing ALL applications first before installing. You must also carry out a permission repair after installing anything from Adobe.

  • kalifromsussex Level 1 Level 1 (0 points)

    Dear Klaus1

     

    Thank you for this information. Unfortunately, the only thing I have been able to achieve is to uninstall my old Flashplayer. Trying the first of the links you suggested only got me to the page. I couldn't get the "download" button to operate and neither would the boxes above it permit me to enter the type of system etc.

     

    From what you have said, it maybe that the problem is because I am using wireless access so that application remains open when I go to download. Do you think that that is the case or is there some other reason?

     

    Also, if I manage to re-install the appropriate Flash Player for Leopard, will that mean I am still unable to access sites that say I should have the newer version of Flash Player? If that's the case I can save myself more irritation and give up now!

     

    Thank you in advance for any help you may be able to offer.

     

    Kali

  • Klaus1 Level 8 Level 8 (46,775 points)

    The 'button functions' on the page are probably Javascript related. Do you have that turned on?

     

    The answers to your other questions are: probably yes!

  • kalifromsussex Level 1 Level 1 (0 points)

    Dear Klaus1

     

    Thank you I will go and look at Java things. Then again if it makes no difference I may give up and eat biscuits instead.

     

    Thanks again and may your biscuit tin never be empty

     

    Kali

  • Klaus1 Level 8 Level 8 (46,775 points)

     

  • skyetbc1997 Level 1 Level 1 (0 points)

    I have been reading this post with great interest as I have the exact same problem myself and keep getting sent round in circles on the Adobe site.  I am not the most computer literate, although a know a little bit.  I am a bit lost with the Java thingy.  I stumbled across another posting on  a forum somewhere and they mentioned opening the Java in my applications folder.  However, I can't seem to find Java in there.

     

    I have uninstalled all my flash players (or I THINK I have as I did the 'Uninstall' as directed on the adobe site).  But when I look in my finder I have found some more flash player  bits and pieces.

     

    Any help to get an older version re installed would be REALLY appreciated as I can't seem to access an important website that isn't just for me to watch videos etc.. 

     

    HELP!!!  PLEASE!!

     

  • Klaus1 Level 8 Level 8 (46,775 points)

    Java is not in your Applications folder and in any case has nothing to do with Flash. You set Java, and Jacascript, in Safari Preferences/Security.

  • skyetbc1997 Level 1 Level 1 (0 points)

    Thank you for letting me know, Klaus.  I had just read somewhere that the Java setting could have been effecting the downloading, but I didn't know what Java was.  I checked the Java where you said and I have them enabled so they are not effecting the downloading capability.    I think I am likely to have a bit of a problem with trying to download the Flash player, going by what I have been reading on this, and other forums. 

  • skyetbc1997 Level 1 Level 1 (0 points)

    I have now downloaded the older 10.1 version of Flashplayer but when I do onto websites that require it, it is still saying that I have to upgrade my Flash Player. 

     

     

    HELP!!

  • Klaus1 Level 8 Level 8 (46,775 points)

    There is not a lot we can do about that!

  • skyetbc1997 Level 1 Level 1 (0 points)

    So does that mean I have to go out and buy a whole new Apple for hundreds of pounds   just so that I can watch videos via iplayer websites when there is nothing wrong with the one I have?

  • BDAqua Level 10 Level 10 (120,655 points)

    Well, there was a hack on here somewhere that purportedly worked a bit by changing the version reported to 10.2. something, but I can't find it today, of course that'll fail when the site really does use some of the later versions functions instead of just checking for it.

     

    Not sure, might've been a file called...

     

    flashplayer10_2_p2_32bit_mac_111710.dmg

  • Klaus1 Level 8 Level 8 (46,775 points)

    No.

     

    I am in the same boat. I cannot watch flash videos on the BBC website or on BBC iPlayer, although all other flash videos (YouTube for example) are fine.

     

    For reasons that passeth all understanding, they work with the PPC version of Firefox, called TenFourFoxG5.app, once you have anabled plug-ins, as it does not natively support Flash.

     

    You can download TenFourFoxG5 from here:

     

    http://www.floodgap.com/software/tenfourfox/

     

    Now for the intersting bit: TenFourFox, like Firefox, does not support most plug-ins. Unless you are prone to headaches (in which case don't) you can read about that here:

     

    http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

     

    But there is a workaround!

     

    Open TenFourFox and type in the address bar: about:config (no spaces) and click return. This gives you a warning that it might harm the application. Ignore that and click on 'I'll be careful, I promise' and you get the config file that you can edit - with great care.

     

    Look/search (scroll down) for: tenfourfox.plugins.enabled

    Set it to true. (Double click it to toggle it)

     

    Now close TenFourFox, open it again, and Flash will now work, as it now uses the plug-ins that Safari has stored.

     

    I am using Flash 10.1.102.64 in TenFourFox and it works just fine.

  • Philscbx Level 1 Level 1 (145 points)

    Same boat with older 05' version of PowerBook G4-2gb ram,

    version 10.4.11, the end of the road for him.

     

    I have newer milled aluminum MacBookPro, and other gear,

    and still need older one if newer is working on other stuff.

    The old guy's perfect doing email, forums and such, or loaded movies.

     

    The word Update, is lately Warning/ Danger, even if device is a year old.

    Older one in a few minutes overheats to where It's not possible to have on your lap,

    then shut it down.

    I suspect Java/flash combo. Activity monitor, maxed out doing nothing.

     

    We need a simple Software to say what's Wrong, vs hunt for something.

    FaceBook, I never go to, is now the number one killing force on the road.

    Worldwide everyday on the freeway, chicks gluded to it vs the windshield.

     

    Seeing your issue with 10.5.8, pretty much confirms 10.4.11.

    Running Disk Utility, It never has issues listed.

    Disk Utility run on newer gear w/10.6.8, is a huge 1/2hr deal.

     

    Being much of the new software is geared for the iPad & iCloud,

    Apple or ? could make an iPad type hack for these older guys.

    Maybe it's the new Ca-Ching, pass them in left lane.

    I and 5 million others still have 5-7 year old working machine.

    The PC crowd throws them in the trash in 3 yrs.

     

    Can't believe a team hasn't built a better ware beyond Adobe.

    Cheers

     

    I'm definately looking into what Klaus1 has up.

Previous 1 2 Next