Previous 1 2 Next 17 Replies Latest reply: May 31, 2015 11:19 AM by felixowl
shedjbeli Level 1 Level 1 (0 points)

Dear Apple Support Community,

 

This is my first post, so I hope I do everything correctly! 

 

Over the weekend (12-10-11), I received a replacement Sprint iPhone 4S.  It appeared as if I activated the phone correctly, as everything worked fine for two days.  Then, yesterday (12-12-11), the phone lost its ability to connect to Sprint's 3G network.  It keeps giving a "Could Not Activate Cellular Data Network" error.  So, unless I'm on Wi-Fi, the only thing I can do is make phone calls and send regular texts (not even iMessages)!    For what it's worth, my wifes  iPhone 4S works fine on Sprint's 3G network (without Wi-Fi turned on), so it's not some sort of outage.

 

I called Sprint's customer support, and they're totally stumped.  We did all the standard soft, hard, and network resets, but NOTHING seems to  fix this problem.  So, they're solution is to take the phone in for repair.  I'm reticent to do this, as I finally have a perfect iPhone (after two previous exchanges).  Honestly, I don't think this a phone issue, rather something on Sprint's end.  From some Internet searching, some Verizon customers experienced similar issues (with the same run-around, apparently, too)!

 

Does anyone have any insight as to what might remedy this issue?

 

I would be extremely grateful for any input, and have a great day!!

 

SASCHA 


iPhone 4S, iOS 5.0.1
  • wjosten Level 10 Level 10 (93,750 points)

    Have Sprint de-activate your phone, then re-activate it. Might be best to go to a Sprint store to do this.

  • shedjbeli Level 1 Level 1 (0 points)

    wjosten:  Thank you so much for the quick reply.  Sprint (customer care, not a stor) just had me reset and clear my whole phone.  Now, I'm doing a "Restore from iCloud Backup."

     

    Dumb question, but is that the same as a de-activation/re-activation?

     

    Please let me know what you think!

     

    With much appreciation,

     

    SASCHA 

  • KiltedTim Level 8 Level 8 (44,660 points)

    No. Either Sprint borked up the activation, or they did not provision your line correctly. I'm betting on the latter. A co-worker (our CEO actually) recently got a Verizon iPhone and they failed to activate the data on her line. Sounds very similar to what's happening to you.

  • wjosten Level 10 Level 10 (93,750 points)

    I've seen this before, and 99.9% of the time it's because the carrier(in your case Sprint) does not have your account provisioned properly. You may call a CSR & they say everything looks fine, when of course it isn't. Go to a Sprint store, have them de-activate your phone, then re-activate it.

  • shedjbeli Level 1 Level 1 (0 points)

    UPDATE:  I, honestly, would tend to agree with both wjosten and KiltedTim.  However, Sprint insisted I try the "Restore from iCloud" option.  As much of a pain it was, for now, everything seems to be working correctly ... it's been over two days, now.

     

    Let's keep our fingers crossed.  I hope this basically mimicked a de-activation/re-activation scenario! 

     

    Thanks for all your input, folks!

  • wjosten Level 10 Level 10 (93,750 points)

    shedjbeli wrote:

    Sprint insisted I try the "Restore from iCloud" option. 

     

    FYI:

     

    That is de-activating/re-activating your phone .

  • jbonner801 Level 1 Level 1 (0 points)

    WORKING FIX

     

    Hi. I got the iPhone 4S 64gib from Sprint. I formally used Blackberry for many years.

    I torn from the love of my Blackberry all these years and ended up returning the the iPhone 4S and was sorry I did.

    It didn't take me look to re-order the iPhone 4S again, and now I am sticking with it.

     

    I have heard with Sprint there is problems with switching from say having a iPhone 4S and then switching to a Blackberry then back to the iPhone 4S.... As stated here you get the error "could not activate the cellular data network".

     

    Do this ONLY if you have everything backup on "iCloud" or your PC... I used "iCloud" and many people I know did.

    Go to "reset" and choose "Erase All Content and Settings".. (Remember use ONLY if you have everything back up very recently)... This worked for me and several other people. I hope this helped...

  • Larrytrip40 Level 1 Level 1 (0 points)

    Hey, i just tried it and it worked for me.

  • alexisbc26 Level 1 Level 1 (0 points)

    tried this and didn't work!

  • Javamav Level 1 Level 1 (0 points)

    I recently had the same issue after updating my son's phone to an iPhone 4 (from an HTC android). I also looked around on the internet to find solutions, and like most other people have discovered, no solid answers could be found to this problem. As a 20 year AppleTech, I refused to let this phone (or Sprint for that matter) beat me. A bit of digging into the iPhone and researching how Sprint's system worked, here is what I came up with.

     

    The Problem: All cell phone carriers have a locked system. Meaning that when a phone is registered on the cellular data network, the phone's MAC Address and account information is stored within the carrier's network to prevent other phones from stealing that user's data connection. When you get a new phone and try to register it on the network, your carrier's system sees that your account is alerady linked with a different phone's (your old phone) MAC Address. Think of it as highjack prevention. Some carriers don't see this issue because they are much better at deleting the old phone out of the system.

     

    Solution: Connect to a WiFi network and let the phone sit for about 30 seconds, this allows your phone to call home (over the internet) and let the systems know that it is the new "registered" phone for that account (why it can't do that through the voice network is beyond me). Then dial (for Sprint users) ##873283# (I am not sure what the update number for Verizon is, sorry). This will force the Sprint systems to update the cellular data link with your new MAC Address and refresh the link to the new phone. Your phone should now have data network access again.

     

    I have done this successfully on quite a few differrent phones that Sprint was unable to get working. Having Sprint unregister/re-register the phone will only work if Sprint (the employee) remembers to delete out the old phone's information first. The key is to get the old information gone first...then register the new phone.

     

    I hope this helps.

  • mckinleyjune Level 1 Level 1 (0 points)

    You are the MOST GENIUS person ever!!!!  Thank you so much!!  Worked like a charm in literally 15 seconds!!

  • heavenlee49 Level 1 Level 1 (0 points)

    OMG!!!! thank you soooo much!!!! it worked so fast i cant believe that i was about to erase all of my content!!! im so glad i checked this post lol

  • Kimberly5116 Level 1 Level 1 (0 points)

    Javamav -  YOU FIXED MINE TOO!   I was on the phone with Sprint for over an hour.  They said they were doing updates in my area and that was the problem.  Funny, my other 4 lines were fine and this line is the one I had done the ESN swap on and swapped back.   THANK YOU SO MUCH

  • wanderlusting02 Level 1 Level 1 (0 points)

    Thank you SO very much Javamav! I spoke with two people last night from Sprint and all they could tell me to do was the ##update# - they didn't even tell me to try to reset my network settings - my best friend had to google a fix for me.

     

    The IT person at my office said that the ##update# wasn't working because there was no data connection - that's how it updates. As soon as I connected to our office wifi and did the update, I ran outside (to get a signal) and it worked! Everything started updating (emails, linkedin, etc).

     

    You saved me from the headache of having to go to a Spring store and possible losing all of my information.

Previous 1 2 Next