5 Replies Latest reply: Dec 20, 2011 8:49 AM by benno36
fk23 Level 1 Level 1 (0 points)

I downloaded the new BBC iPlayer app on Monday.  Tuesday is when I tried to use it but it tells me I'm outside the UK and it won't play.  It tells me the same when I try the web-based iPlayer.

 

It works fine over WIFI.

 

I reset my network settings - no change.

I turned off data roaming  - no change

I checked my IP address (I am Orange), it lists a static IP based in the UK with Orange network details on it.

I have a friend who works for BBC conent and he checked my IP with their iPlayer tool - my IP looks fine to them. 

 

I called Orange.

I spent half an hour on the phone to a woman who didn't seem to even understand how apps worked. She directed me to a link on the Apple Support pages which doesn't even work.  "They don't deal with 3rd party apps" was the last I was told, despite the fact I'm sure the problem is with the phone not the app itself.

 

I am frustrated.

 

Anyone got any idea why my phone would be showing (to the BBC iPlayer) that I am abroad?

I cannot check the UK specific content for 4oD or ITV Player as they will only run on WIFI, and my WIFI connection does not appear to be the issue.

Could Orange be re-routing outside of the UK and coming back to the UK...and that's what confusing it?


What can I do to fix this?


iPhone 4S, iOS 5.0.1
  • fk23 Level 1 Level 1 (0 points)

    This was buried in minutes in here. Anyone able to help. My network won't.

  • benno36 Level 1 Level 1 (0 points)

    I have an iphone with Orange which is also giving me the same problem.

     

    I went to www.ip2location.com and it tells me I am in the USA, my ISP is Amazon.com Inc. How is this possible!

     

    Someone from Orange needs to help

  • fk23 Level 1 Level 1 (0 points)

    That's what mine said too when I went direct to their checker.

     

    But I use the Speed Test app and that shows a different IP address, one which links to Orange in the UK.

     

    At the moment it's giving me 31.81.44.53, but that Ip2location site gives me 50.19.92.191. Google tells me I am on 50.16.198.92. 

     

    I am confused and frustrated.

    I did several full restores yesterday, several times when the phone restarted it gave US as the defualt locaiton at startup, but this morning when I just did a settings wipe, it gave me the UK, and I thought that had fixed it.  I didn't.     

     

    Very odd.

     

    Gosh I thought I solved it then, one of the sites told me my app Onavo was creating a proxy. Deleting the app didn't help - may have to delete the profile which may be buried elsewhere on the phone. Oh, it's in the General tab under profiles - if you have a profile at all.


    Cannot confirm if this works yet as I only have 2G at home but if you have Onavo, I think it's creating a proxy server connection (directing you to the USA). Delete the app, delete the profile and please let me know if it works for you!

     

    Can't be more than 99% certain, but removing my Onavo profile has now given me a UK IP. Should work!

  • fk23 Level 1 Level 1 (0 points)

    Onavo was the problem, issue resolved. Thanks me.

    Thanks.

  • benno36 Level 1 Level 1 (0 points)

    Yep, same resolution for me too. This also opens up the possibility of using a USA IP address when required.