8 Replies Latest reply: Mar 23, 2012 1:53 AM by Jsfulham
mattsturges Level 1 Level 1 (0 points)

I have several updates available on my iPad2 and I cannot get them to update.  It will say "Waiting" or will just be faded out with the loading bar below it, but they will not load.  I have tried the following:

-Signing out of my iPad and signing back in

-Signing out of my iPad, restarting it, and signing back in

-Connecting to iTunes and "check for downloads"

-Updating it to 5.0.1

-Syncing it

-Checking iCloud for the apps to re-download

 

Does anyone have any other suggestions?

 

Thank you.


iPad 2
  • 1. Re: Apps on iPad 2 will not update?
    Chuck Konfrst Level 4 Level 4 (2,050 points)

    This happens to me on occasion.  One way that has fixed it is to hold down Home and Power for 15 seconds or so until you see the white Apple logo.  The only other way was to delete the apps and re-download them.  But if you do that, you'll lose any data on those apps.

  • 2. Re: Apps on iPad 2 will not update?
    SolidWood Level 1 Level 1 (50 points)

    I saw this behavior as well, my issue was that there was not enough space for the app to download, expand, and install. This will cause the download to stall or "grey out". Apps need a little more space than stated on the App Store to install, then they are the specified size from the store. Rule of thumb for me is to have at least twice as much space free on my device than the app requires.

  • 3. Re: Apps on iPad 2 will not update?
    v1nsai Level 1 Level 1 (0 points)

    This just started happening recently too. Have tried signing in and out, killing wifi and rebooting.  Made sure and I have more than 2 gb of space available, should be able to update Netflix.

  • 4. Re: Apps on iPad 2 will not update?
    Jsfulham Level 1 Level 1 (0 points)

    Sad thing is this is happening to me too weeks after your post and in some cases months after seeing it on other boards. Still no nearer to fixing it. Wasted an evening on this. Thanks Apple. Anyone got any other ideas please?

    Pretty hauling given Apple solicits the update via the app store then appears to shrug their shoulders when it does not work. Seems like apple is going to downhill.

  • 5. Re: Apps on iPad 2 will not update?
    v1nsai Level 1 Level 1 (0 points)

    I let it waste an hour or two of my time trying to figure it out, then backed up in iTunes and restored.  Had to update too, better not lose the ability to jailbreak when it comes out for the A5 chipset.

     

    I'm not mad at Apple.  Problems like this rarely happen, though when they do options are pretty limited.  On Android it probably would have been much easier to clear caches or update the app or at least view the log and see whats happening and to fix the problem, but problems like this would be coming up a lot more frequently.  First problem I've had since buying an iPad in August.  I'll take it.

  • 6. Re: Apps on iPad 2 will not update?
    Jsfulham Level 1 Level 1 (0 points)

    It's 1am here in the uk just worked out the download on iTunes then synced it. All ok now. I am disappointed that Apple don't do more to share the knowledge. I never asked for the update, they advertised it. They should ensure it works. That is customer service. Still I will get over it. But maybe I will get an Android phone instead of the iPhone I was dreaming about.

  • 7. Re: Apps on iPad 2 will not update?
    yaztastic Level 1 Level 1 (0 points)

    a little late ... but here is what i do to fix this issue

     

    connect your ipad to your computer

    let it sync

    go to the apps tab

    remove any apps that are hung by unchecking them

    sync

    select those same apps

    sync

     

    should work again as usual

  • 8. Re: Apps on iPad 2 will not update?
    Jsfulham Level 1 Level 1 (0 points)

    Well better late than never.....

     

    I have used the live customer support service several times, something I was not aware of when I had the only issue I have had with Apple products.

     

    I also own an iPhone 4s now purchased from an Apple store. I got the iPad from a dealer rather than Apple so I not experienced the superb service to be found at an Apple store.

     

    Anyway thanks for your tip.